4 Replies Latest reply: Feb 12, 2013 12:52 PM by 968707 RSS

    Upgraded from 3.2.1 to 4.1

    968707
      We upgarde APEX to 4.1 and Have issues during SSO.

      APEX app has integration with Luminis. Now instead of doing SSO, getting an error message as access Denied.

      Does anyone have same kinds of issue?


      Any suggestion will be appreciated.

      Prak.
        • 1. Re: Upgraded from 3.2.1 to 4.1
          flavioc
          The first thing that comes off the top of my mind: is there some sort of custom PL/SQL procedure that handles the SSO?
          In 3.2.1 did you grant execute on that procedure to the apex public user (either ANONYMOUS or APEX_PUBLIC_USER)?
          Did you include this procedure in the list of procedures authorized via function wwv_flow_epg_include_mod_local?

          When upgrading APEX, custom procedures authorized via wwv_flow_epg_include_mod_local are not automatically updated, the newly installed function doesn't copy over the existing version, so you may end up with some broken pages if they rely on this mechanism.

          May be this doesn't apply to you, but the access denied error is typical of this situation (but also others perhaps).

          Flavio

          ----
          http://oraclequirks.blogspot.com
          http://www.yocoya.com
          • 2. Re: Upgraded from 3.2.1 to 4.1
            968707
            Flavioc,
            Since SSO is set with Luminis. So, it is doing LDAP for the password.

            I have found that the following parameter value is NULL but when I check the source code its not null. So actually the value of p_instance is not pulled.


            <PARAM a:name="p_instance" a:value="${FormArray.p_instance}" />

            Does the value name changes on Apex 4.1


            Prak.
            • 3. Re: Upgraded from 3.2.1 to 4.1
              flavioc
              This doesn't look like an HTML fragment generated by Apex so I have no idea where this p_instance should come from.

              Flavio

              ----
              http://oraclequirks.blogspot.com
              http://www.yocoya.com
              • 4. Re: Upgraded from 3.2.1 to 4.1
                968707
                Is there any one you know about integration of Apex 4.1 with Luminis?