This discussion is archived
2 Replies Latest reply: Feb 11, 2013 7:58 AM by 966015 RSS

Delay when trying to connect to NodeManager via WLST

966015 Newbie
Currently Being Moderated
Hi i am using WLST with a custom script to start up my environment but when the script reaches the nmConnect command it takes for ever!!

the script i am using is:

startNodeManager(verbose='false', NodeManagerHome='/opt/oracle/Middleware/wlserver_10.3/common/nodemanager', ListenPort='5556', ListenAddress='hostname')
nmConnect(host='hostname',port='5556',username='weblogic',password='password',domainName='Domain',domainDir='/opt/oracle/Middleware/user_projects/domains/Domain')
nmStart('AdminServer')
exit()

The script is successful, but is takes a lot of time to finish the connection with the node manager
----------------------------------------
nodemanager.properties file

DomainsFile=/opt/oracle/Middleware/wlserver_10.3/common/nodemanager/nodemanager.domains
LogLimit=0
DomainsDirRemoteSharingEnabled=false
PropertiesVersion=10.3
AuthenticationEnabled=true
NodeManagerHome=/opt/oracle/Middleware/wlserver_10.3/common/nodemanager
javaHome=/opt/oracle/jdk1.6.0_39
JavaHome=/opt/oracle/jdk1.6.0_39/jre
LogLevel=INFO
DomainsFileEnabled=true
StartScriptName=startWebLogic.sh
ListenAddress=hostname
NativeVersionEnabled=true
ListenPort=5556
LogToStderr=true
SecureListener=true
LogCount=1
StopScriptEnabled=true
DomainRegistrationEnabled=true
QuitEnabled=false
LogAppend=true
StateCheckInterval=500
CrashRecoveryEnabled=true
StartScriptEnabled=true
LogFile=/opt/oracle/Middleware/wlserver_10.3/common/nodemanager/nodemanager.log
LogFormatter=weblogic.nodemanager.server.LogFormatter
ListenBacklog=50


After some search i suspect that the certificates weblogic is using cause the problem .. but i an not sure..

Can anybody help??

Edited by: 963012 on Feb 11, 2013 2:23 AM
  • 1. Re: Delay when trying to connect to NodeManager via WLST
    Peter.Lorenzen Explorer
    Currently Being Moderated
    Hi,

    It could be because of low Entropy that makes the SSL functions very slow.
    Check http://theheat.dk/blog/?p=486

    Regards Peter
  • 2. Re: Delay when trying to connect to NodeManager via WLST
    966015 Newbie
    Currently Being Moderated
    Hi Peter and thank you for your answer!

    I will try any of those cases and i will see how is goes.

    Unfortunately i think that the nature of the machine that i have installed my weblogic is not helping.

    It is a vm with a 100 network switch and i am using ntfs for storage, but a mistake was made and the logical volume has linear mapping..

    That together with the 10/100 network switch makes the machine a bit slow in terms of IO...

    i will try the first one with MEM_ARGS="${MEM_ARGS} -Djava.security.egd=file:/dev/./urandom" because i saw in a SR of Oracle Support that is was suggested to a client

    Edited by: 963012 on Feb 11, 2013 7:57 AM

    Edited by: 963012 on Feb 11, 2013 7:58 AM

    Edited by: 963012 on Feb 11, 2013 7:58 AM

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points