3 Replies Latest reply on Feb 14, 2013 5:10 PM by BBHFMUser

    Smart view Connection Error

    BBHFMUser
      Hi All,

      We have HFM 11.1.2.1.000 with 2 HFM servers installed on Windows 2008 SP1 R2 64 bit. We are getting the below shown error when we try access the application using smart view.

      *"Invalid Session. One possibility is that the connection has timed out. Login again"*

      any suggestions to resolve this issue.
        • 1. Re: Smart view Connection Error
          091575
          Hi,

          Please check the version of your smartview and work space.
          both should be same.
          • 2. Re: Smart view Connection Error
            beyerch2
            - The most obvious answer is that your session cookie has expired. One of my gripes with Smart View is there is just some stupid U/I going on and this is one of those times.

            In a perfect world, if your session has expired, you would think that Smart view, would just drop/delete it, and then prompt you with a login box so that you can re-authenticate, right? Wrong.

            Instead, you actually have to open up the connection manager, locate the connection in question, right click on it, and select the Disconnect option.....

            I believe closing Excel USUALLY will force it to reconnect; however, I've seen a few times where you have to manually do this.

            - In regards to the advise about needing the same version of Smartview that corresponds to workspace, not true at all.

            a.) The Smartview version is NOT tied to workspace necessarily. If you locate the folder that holds the Smartview.EXE file on the web server, you'll see an XML file that contains a version number. THIS is how Smartview plug-in knows whether your version on the client is the same, older, or newer than what is on the server.

            You can replace the Smartview.exe / XML file WITHOUT upgrading Workspace in the event a new version of Smartview is released, etc. If you are inventive you can also modify the Workspace Install menu to allow you to add another download option. I did this so that my users can have a choice between 32 or 64 bit Smartview.....

            b.) MOST versions of Smartview are backwards compatable; therefore, running a newer version that what came out of the box with Smartview web service is very possible and probably makes the most sense. (Furthermore, if there are new versions you should update the web download files so that end users are getting the latest and greatest, see a.)

            c.) In SOME cases, you can even use an older version of Smartview, though there are some conditions:
            - Some versions of Smartview do not support compression; therefore, they will not work at all IF you have enabled web compression when you configured Smartview web
            - The web administrator can FORCE users to upgrade; otherwise, Smartview will not work.

            d.) If you were using an older version, at a minimum you would receive a notice warning you that you are using an older version..... (This can be configured as well though by the Web Admin; however, out of the box this is enabled)

            Hope that helps.
            1 person found this helpful
            • 3. Re: Smart view Connection Error
              BBHFMUser
              Hi Beyerch,

              Thanks for your inputs on this.

              Actually we have tried the below options to fix this,

              1. "Invalidate SSO" by selecting "Disconnect All" in Smart view.
              2. Login using accessing with the admin account credentials.

              but it didn't help us. We tried simulating the same issue in our personal system, started the services in the same order as in Production. We got the same error.
              We were able to access the application when we restarted the provider services

              "HFMWebServiceManager", "HyS9FinancialManagementWebSvcs", "HyS9aps", "Hyperion Studio Service BPMS bpms1"

              We did the same in production and the issue is resolved now.

              Thanks Again.