2 Replies Latest reply: Feb 13, 2013 6:31 PM by 880813 RSS

    weblogic Administrator Server won't start after a fresh WCC install

    880813
      Hi guys, i followed this [install documentation|http://docs.oracle.com/cd/E23943_01/doc.1111/e14538/qiecm.htm#sthref8] to install wls and WCC on a OEL6 (64bit), all went relatively smoothly. Then when I get ready to start weblogic admin server for the first time, it errors out on me.

      system:
      -Oracle Enterprise Linux6 (64bit)
      -WebLogic Server 12.1.1
      -Webcenter Content 11g
      -Oracle DB 11g

      basic steps I've took:
      1) RCU installed UCM, URM, IPM, and IBR schemas into 11g DB
      2) installed wls, created a basic domain (base_domain) with Admin Server as a place holder
      3) installed WCC, create new domain (wcc_domain) with Admin Server
      4) start wls Admin Server: $WCC_DOMAIN_HOME/bin/startWebLogic.sh
      5) error.......

      [high level error msg]
      Feb 12, 2013 10:27:07 PM oracle.security.jps.internal.keystore.file.FileKeyStoreManager openKeyStore
      WARNING: Opening of file based keystore failed.
      <Feb 12, 2013 10:27:07 PM CST> <Error> <Security> <BEA-090892> <The loading of OPSS java security policy provider failed due to exception, see the exception stack trace or the server log file for root cause. If still see no obvious cause, enable the debug flag -Djava.security.debug=jpspolicy to get more information. Error message: JPS-06514: Opening of file based keystore failed.>

      <Feb 12, 2013 10:27:07 PM CST> <Critical> <WebLogicServer> <BEA-000386> <Server subsystem failed. Reason: weblogic.security.SecurityInitializationException: The loading of OPSS java security policy provider failed due to exception, see the exception stack trace or the server log file for root cause. If still see no obvious cause, enable the debug flag -Djava.security.debug=jpspolicy to get more information. Error message: JPS-06514: Opening of file based keystore failed.
      weblogic.security.SecurityInitializationException: The loading of OPSS java security policy provider failed due to exception, see the exception stack trace or the server log file for root cause. If still see no obvious cause, enable the debug flag -Djava.security.debug=jpspolicy to get more information. Error message: JPS-06514: Opening of file based keystore failed.

      at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.loadOPSSPolicy(CommonSecurityServiceManagerDelegateImpl.java:1402)
           at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.initialize(CommonSecurityServiceManagerDelegateImpl.java:1022)
           at weblogic.security.service.SecurityServiceManager.initialize(SecurityServiceManager.java:873)
           at weblogic.security.SecurityService.start(SecurityService.java:148)
           at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
           Truncated. see log file for complete stacktrace
      Caused By: oracle.security.jps.JpsRuntimeException: JPS-06514: Opening of file based keystore failed.
           at oracle.security.jps.internal.policystore.PolicyDelegationController.<init>(PolicyDelegationController.java:167)
           at oracle.security.jps.internal.policystore.JavaPolicyProvider.<init>(JavaPolicyProvider.java:369)
           at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
           at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
           at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
           Truncated. see log file for complete stacktrace
      Caused By: oracle.security.jps.JpsException: JPS-06514: Opening of file based keystore failed.
           at oracle.security.jps.internal.policystore.PolicyUtil.getDefaultPDPService(PolicyUtil.java:2855)
           at oracle.security.jps.internal.policystore.PolicyUtil.getPDPService(PolicyUtil.java:3099)
           at oracle.security.jps.internal.policystore.PolicyDelegationController.<init>(PolicyDelegationController.java:164)
           at oracle.security.jps.internal.policystore.JavaPolicyProvider.<init>(JavaPolicyProvider.java:369)
           at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
           Truncated. see log file for complete stacktrace
      Caused By: oracle.security.jps.service.keystore.KeyStoreServiceException: JPS-06514: Opening of file based keystore failed.
           at oracle.security.jps.internal.keystore.file.FileKeyStoreManager.openKeyStore(FileKeyStoreManager.java:374)
           at oracle.security.jps.internal.keystore.file.FileKeyStoreServiceImpl.doInit(FileKeyStoreServiceImpl.java:105)
           at oracle.security.jps.internal.keystore.file.FileKeyStoreServiceImpl.<init>(FileKeyStoreServiceImpl.java:77)
           at oracle.security.jps.internal.keystore.file.FileKeyStoreServiceImpl.<init>(FileKeyStoreServiceImpl.java:67)
           at oracle.security.jps.internal.keystore.KeyStoreProvider.getInstance(KeyStoreProvider.java:157)
           Truncated. see log file for complete stacktrace
      [high level error msg]

      steps I've took to tackle this problem:
      1) removed $WCC_DOMAIN/security folder, then re-enter username/password
      <result> can't find SerializedSystemIni.dat file
      2) create a boot.properties file in folder
      <result> same keystore error as above
      3) re-generate a new SerializedSystemIni.dat file [described here|http://www.wikiconsole.com/wiki/?p=3041]
      <result> same keystore error as above
      4) tried modify cwallet.sso [described here|https://forums.oracle.com/forums/thread.jspa?threadID=2266436]
      <result> can't modify, content in sso file is encrtyped
      5) review message with debug option enabled
      <result> it said error from LDAP [described here|http://docs.oracle.com/cd/E17904_01/core.1111/e10043/aptrouble.htm] but I don't have LDAP enabled/installed
      6) create a key store based on WCC install doc (IRM section)
      <result> same keystore error as above

      none of the steps above work, only option left I can think of, is maybe install it with wls 10.3 (seems like that's what the installation doc used). I honestly hope it could be as simple as that, but if I'm missing anything critical, please let me know.

      Thank you

      p.s: please feel free to ask me to post the long lengthy debug output