4 Replies Latest reply: Feb 13, 2013 3:27 PM by 875076 RSS

    some question on go url syntax

    875076
      Hi All,

      I need a third eye to check why the following code is not working. I might be missing something. I have placed the code in the column formula.

      I have one more question on go url. If we use more column parameters to pass like P0=3 in the column formula, which value of the source column ( like P3 or P6 or P9) will be displayed in the main report as there will be three source column in the go url in column formula.

      Thanks,
      Virat
      '<_a href=http://ccdev-06.dev.dca.com:7001/analytics/saw.dll?Go&Path=/My%20Folders/Region_D&Action=Navigate&P0=1&P1=eq&P2="Site"."Region"&P3='||Replace("Site"."Region",' ' ,'%20')||'<_/a>'
        • 1. Re: some question on go url syntax
          Srini VEERAVALLI
          Try this
          '<_a href=http://ccdev-06.dev.dca.com:7001/analytics/saw.dll?Go&Path=%2FMy%20Folders%2FRegion_D&Action=Navigate&P0=1&P1=eq&P2="Site"."Region"&P3="'||Replace("Site"."Region",' ' ,'%20')||'"<_/a>'

          Read this
          http://docs.oracle.com/cd/E21043_01/bi.1111/e16364/apiwebintegrate.htm#CACCHBHC

          Question for you:
          'My Folders' is the user's folder then it suppose to be like
          /users/<userid>/Region_D

          Edited by: Srini VEERAVALLI on Feb 13, 2013 9:13 AM
          • 2. Re: some question on go url syntax
            875076
            The following code does not work.

            If i just run the
            http://ccdev-06.dev.dca.com:7001/analytics/saw.dll?PortalGo&Action=prompt&path=%2Fusers%2Fweblogic%2FRegion_D 
            on new tab of browser the new report opens without any passing of parameters to filter.
            '<_a href=http://ccdev-06.dev.dca.com:7001/analytics/saw.dll?PortalGo&Action=prompt&path=%2Fusers%2Fweblogic%2FRegion_D&Action=Navigate&P0=1&P1=eq&P2="Site"."Region"&P3='||Replace("Site"."Region",' ' ,'%20')||'<_/a>'
            Thanks,

            Virat
            • 3. Re: some question on go url syntax
              Srini VEERAVALLI
              Make sure Region is set to Is Prompted
              and use the below you are missing "
              "'||Replace("Site"."Region",' ' ,'%20')||'"

              *URL should be something like below*
              *http://klpc-275:7003/analytics/saw.dll?PortalGo&path=/users/weblogic/Region_D&Action=Navigate&P0=1&P1=eq&P2="SITE"."Region"&P3='01'*

              Edited by: Srini VEERAVALLI on Feb 13, 2013 3:22 PM

              You are facing issue because of this
              Action=prompt

              Edited by: Srini VEERAVALLI on Feb 13, 2013 3:22 PM
              • 4. Re: some question on go url syntax
                875076
                Its working now. Thanks so much Srini:)

                Sushil/V

                Edited by: 872073 on Feb 13, 2013 1:23 PM

                Edited by: 872073 on Feb 13, 2013 1:27 PM