12 Replies Latest reply on Feb 14, 2013 4:25 PM by 972454

    Essbase Application Copy


      I have all my essbase application in D: drive. I need to copy some ASO applications to E: Drive under (essbase\AnalyticServices\APP) with diffent name and provision some users to the copied backup databse databse. Since our D drive is full it is just like creating a copy of the existing app with some other location. Refresh needs to happened every night. please suggest how to copy entire application to diiferent drive?

        • 1. Re: Essbase Application Copy
          I can create copy application using MAXL with in the same drive. But, How to specify the Drive or path for the application at the time to creation?
          • 2. Re: Essbase Application Copy
            Th. Reich
            As far as I know (please correct me if I'm wrong) you cannot specify an alternate path where to store the application when copying the cube.
            But what you could do is specify another location for the data files. For that you could use the alter tablespace statement of MaxL.
            For details (11.1.1.x) see:
            • 3. Re: Essbase Application Copy

              I have tried the table space option too. But, I after restarting the application it is just creating a folder with application name in the alternate path with inside empty folder default. I didn't under stand clearly how could it work. Can i push the database inside to this newly created folder?

              I have tried the option alter system set eas_loc 'alternatepath'; also. this statement is executing successfully but after that also copy application is creating in regular folder only. I think some needs to change the application storage settings.

              • 4. Re: Essbase Application Copy
                The folder structure and certain files will always exist on the drive where Essbase was installed for both ASO and BSO. For example, the database directory that contains the outline and load rules. If you change the tablespaces for the data and the temp space, it means the new location will be used for those. If you do an application copy from EAS, there is no way to specify the new location for those files during the copy. IT would copy them to the Essbase path, you would then need to change them and reload the data
                • 5. Re: Essbase Application Copy

                  Thanks for your reply.

                  Could you please tell me wether the below plan will work or not.

                  1. Will create a copy application in current drive

                  Create application TEST1 as REAL1;

                  2. alter the table space

                  alter tablespaceTEST1.'default' alter file_location 'targetpath' set max_filesize or max_disksize;

                  3. Reload the databse

                  alter application TEST1 unload database test1;

                  alter application TEST1 load database test1;

                  • 6. Re: Essbase Application Copy
                    Th. Reich
                    I think this will not work.
                    Changing the tablespace would mean that you would have to add new one and remove current one. Than as stated by Glenn already you have to completely reload the data.
                    However what you could try is a filesystem copy of the old tablespace files on the drive to the new one - may be this will work as well so you wouldn't have to completely reload all data.
                    So I would try:
                    - Copy application using MaxL
                    - Add tablespace for new drive
                    - copy files of old tablespace to new one
                    - delete old tablespace
                    - reload app and test if data is still there

                    As I don't know if it will work, please don't test this on a productive system.
                    • 7. Re: Essbase Application Copy
                      I hope copy table space files will not work. Since, I need the entire process to be automated. We can't copy files trough Maxl. I have tried changing the table space and loading the data in copy application. It is storying dat files in copy application.

                      I think there is no option to copy entire database to newlocation with all the scripts and databse folder. any way I am proceed with changing table space. Hope so client will accept this.
                      • 8. Re: Essbase Application Copy
                        how to create a copy application with only outline. no need to copy other artifacts in the application. please suggest the Maxl code for this.
                        • 9. Re: Essbase Application Copy
                          Is it possible to you copy an application without the data then make an export/import from one application to another?

                          Once i have done that in an BSO cube. Even though i made it manually. I don't know if its possible to automate the process.

                          1 - Copy Sample.Basic to TEST.Basic (without data).
                          2 - Alter tablespace of TEST.Basic
                          3 - Export data Sample.Basic (define some directory)
                          4 - Import data into TEST.Basic.
                          • 10. Re: Essbase Application Copy
                            Thanks for all your help.

                            My client accepted with the table space change and data load automation.

                            I have one question.

                            How to search for Application using Maxl. I mean If the application exist with the given name Process should not run. Can any one suggest?
                            • 11. Re: Essbase Application Copy
                              in your batch or shell script look for the existance of the application directory in the under the app directory in the arborpath. If it exists don't run the MaxL.
                              If it is windows look for the if exists command
                              • 12. Re: Essbase Application Copy

                                It's working.