3 Replies Latest reply: Feb 15, 2013 3:26 PM by Ivanigorovich-Oracle RSS

    when I debug code the debugger does not stop at breakpoints

    NikosTUC
      Hi guys,

      I have solstudio 12.2 in an oracle linux 6.1 server.

      I setup a fortran project which builds and executes nicely.

      However, when I debug the program does not stop at my breakpoints in the fortran source file. I use f90.

      What is the problem?

      Thank you,
      Nikos
        • 1. Re: when I debug code the debugger does not stop at breakpoints
          Ivanigorovich-Oracle
          First, from the main menu choose Tools->Options->C/C++->DebuggingOptions
          Choose the SessionStartup catgeory
          Uncheck "Finish Debug Session When Program exits".
          This will make sure that the debugger windows stay put and don't vanish
          if your programs runs through w/o hitting breakpoints.

          Then, from the main menu choose Windows->Debugging->DbxConsole.

          Now, place your breakpoints and Debug your program.

          In the DbxConsole you should see the command that the dbx, the debugger engine, gets
          in order to place a breakpoint. Are there any error messages or other clues?

          Another way to see why breakpoints aren't taking hold is to open
          the breakpoint window. It's usually available if you have a debugging session.
          Breakpoints that haven't taken hold are rendered in a "broken" state with a crack through
          them. If you hover over the breakpoint glyph you'll get a balloon describing the error
          message associated with the broken breakpoint.
          • 2. Re: when I debug code the debugger does not stop at breakpoints
            NikosTUC
            Hi again,

            OK, this time the windows remain open but again the program executes without stopping at my breakpoints.

            I get a warning window with the message: "*No symbolic information*".

            At the DBX Console I get the following info:

            For information about new features see `help changes'
            To remove this message, put `dbxenv suppress_startup_message 7.8' in your .dbxrc
            +(dbx) cd /home/staff/nikos/Desktop/programming/fortran/test_makefile+
            +(dbx) debug /home/staff/nikos/Desktop/programming/fortran/test_makefile/prog1+
            Reading prog1
            Reading ld-linux-x86-64.so.2
            Reading libfai.so.1
            Reading libfui.so.1
            Reading libfsu.so.1
            Reading libmtsk.so.1
            Reading libpthread.so.0
            Reading libm.so.6
            Reading libc.so.6
            Reading librt.so.1
            Reading libdl.so.2
            +(dbx) dbx: warning: unknown language, 'c' assumed+
            cd /home/staff/nikos/Desktop/programming/fortran/test_makefile
            +(dbx) runargs+
            +(dbx) intercept -set -unhandled, -unexpected+
            +(dbx) stop at "/home/staff/nikos/Desktop/programming/fortran/test_makefile/prog1.f":6+
            dbx: no executable code at line "prog1.f":6
            +(dbx) stop at "/home/staff/nikos/Desktop/programming/fortran/test_makefile/prog1.f":7+
            dbx: no executable code at line "prog1.f":7
            +(dbx) stop at "/home/staff/nikos/Desktop/programming/fortran/test_makefile/prog1.f":3+
            dbx: no executable code at line "prog1.f":3
            +(dbx) run+
            Running: prog1
            +(process id 12392)+

            execution completed, exit code is 0

            My bookmarks are at the prog1.f which is executed.

            Can you tell what is wrong using this information?

            Thank you
            • 3. Re: when I debug code the debugger does not stop at breakpoints
              Ivanigorovich-Oracle
              nikos wrote:

              I get a warning window with the message: "*No symbolic information*".
              You need to compile your code with the -g (for debuG) option to get that symbolic information.

              I do concede that the error messages are not helpful enough.

              Is "*No symbolic information*" what you saw verbatim?
              The only one resembling that from dbx is actually in the form
              "No symbolic information for '%s'"