2 Replies Latest reply on Feb 16, 2013 12:47 AM by 991391

    Java7_13 + WindowsXP + https = invalid jar error


      I have troubles in starting any (authority signed or self signed) applets from
      a https server(ssl), despite of the fact, if http(ssl) server has authority signed or
      self signed certificate, the problem is always the same, when loading it, Java reports in extended info
      the error "invalid jar".
      That happens only on Windows XP machines, I have tested it on five different XP SP2 and XP SP3 machines
      with installed Java7_13, all Xp installations have this problem.

      At same time it works perfect, when the http address is used, (even if https had "invalid jar" error)

      1. It works perfect on Windows7 clients with Java7_13 as good from https as from https, always good..
      2. It works perfect on Windows XP with old Java6 as good from https as from http, again always good.

      Sometimes, when i resign the applet, it can work via https on xp machines few times, but after it
      begins again to give the error about "invalid jar" on https address, and at same time it works always
      perfect from http by serving same! applets.

      From this behavior I can assume, new Java7_13 + WindowsXP + https starting is not anymore working

      One more thing to mention, I have tested it on Internet Explorer 7, FireFox 18, and Chrome on XP machines,
      they show always same behavior on https address - "invalid jar"
      Also it is not browser dependent.

      May be it depends on some special caching settings? Is that possible..
      However i use usual applet tag without any special caching params.

      Actually it went for us to nightmare, because many our customers with HTTPS server and Windows XP + Java7_13 reported already the non working error, which leads back to this problem with "invalid jar" error.
        • 1. Re: Java7_13 + WindowsXP + https = invalid jar error
          May be that helps for the Oracle programmers to find the error source faster..

          java.io.IOException: Invalid jar file
               at com.sun.deploy.net.DownloadEngine.downloadTemporaryJarFile(Unknown Source)
               at com.sun.deploy.net.DownloadEngine.downloadJarFileWithoutCache(Unknown Source)
               at com.sun.deploy.net.DownloadEngine.getTemporaryJarFile(Unknown Source)
               at com.sun.deploy.cache.ResourceProviderImpl.getTemporaryJarFile(Unknown Source)
               at com.sun.deploy.cache.ResourceProviderImpl.getJarResourceWithoutCache(Unknown Source)
               at com.sun.deploy.cache.ResourceProviderImpl.getResource(Unknown Source)
               at sun.plugin.PluginURLJarFileCallBack$1.run(Unknown Source)
               at java.security.AccessController.doPrivileged(Native Method)
               at sun.plugin.PluginURLJarFileCallBack.retrieve(Unknown Source)
               at sun.net.www.protocol.jar.URLJarFile.retrieve(Unknown Source)
               at sun.net.www.protocol.jar.URLJarFile.getJarFile(Unknown Source)
               at sun.net.www.protocol.jar.JarFileFactory.get(Unknown Source)
               at sun.net.www.protocol.jar.JarURLConnection.connect(Unknown Source)
               at sun.plugin.net.protocol.jar.CachedJarURLConnection.connect(Unknown Source)
               at sun.plugin.net.protocol.jar.CachedJarURLConnection.getJarFileInternal(Unknown Source)
               at sun.plugin.net.protocol.jar.CachedJarURLConnection.getJarFile(Unknown Source)
               at com.sun.deploy.security.DeployURLClassPath$JarLoader.getJarFile(Unknown Source)
               at com.sun.deploy.security.DeployURLClassPath$JarLoader.access$1000(Unknown Source)
               at com.sun.deploy.security.DeployURLClassPath$JarLoader$1.run(Unknown Source)
               at java.security.AccessController.doPrivileged(Native Method)
               at com.sun.deploy.security.DeployURLClassPath$JarLoader.ensureOpen(Unknown Source)
               at com.sun.deploy.security.DeployURLClassPath$JarLoader.<init>(Unknown Source)
               at com.sun.deploy.security.DeployURLClassPath$3.run(Unknown Source)
               at java.security.AccessController.doPrivileged(Native Method)
               at com.sun.deploy.security.DeployURLClassPath.getLoader(Unknown Source)
               at com.sun.deploy.security.DeployURLClassPath.getLoader(Unknown Source)
               at com.sun.deploy.security.DeployURLClassPath.getResource(Unknown Source)
               at sun.plugin2.applet.Plugin2ClassLoader$2.run(Unknown Source)
               at java.security.AccessController.doPrivileged(Native Method)
               at sun.plugin2.applet.Plugin2ClassLoader.findClassHelper(Unknown Source)
               at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)
               at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Unknown Source)
               at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
               at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Unknown Source)
               at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
               at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
               at java.lang.ClassLoader.loadClass(Unknown Source)
               at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Unknown Source)
               at sun.plugin2.applet.Plugin2Manager.initAppletAdapter(Unknown Source)
               at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
               at java.lang.Thread.run(Unknown Source)
          • 2. Re: Java7_13 + WindowsXP + https = invalid jar error

            my problem was also self solved.
            1. Deinstalled java7 completely...

            2. Removed %APPDATA%\SUN from hard drive

            3. Removed %USERPROFILE%\Local settings\Appdata\SUN from hard drive.

            4. Downloaded full Java7_13 offline installation

            5. Installed it (does not yet help)

            6. Run installation again and reinstall it.. (on this point it seems, Java resets registry entries, but not by usual installation, why?)

            Now everything runs on my XP system without any problem... well, why did it not work with https, but worked before with http, that is the question..
            However solved is solved..