2 Replies Latest reply: Feb 18, 2013 7:49 AM by 991584 RSS

    Error with jre7

    991584
      Hi,

      after an update of my java, a script I often used up to now does not work anymore.

      the command executed was

      java.exe -Xms6m -Xmx6m -Djava.net.preferIPv4Stack=true -XX:PermSize=8m -Djava.library.path=. -classpath sip.jar;ua.jar;mailapi.jar;smtp.jar;activation.jar;skype.jar;log4j-1.2.15.jar;siptosis.jar;. "local.ua.SkypeUA" %1

      and now using the same command the java usage messages appear.

      I guess that some of the options used in the command above are no more available or have been replaced with newer equivalent options.

      Could you suggest what to try?

      here after my java -version command result

      java version "1.6.0_20"
      Java(TM) SE Runtime Environment (build 1.6.0_20-b02)
      Java HotSpot(TM) 64-Bit Server VM (build 16.3-b01, mixed mode)
        • 1. Re: Error with jre7
          gimbal2
          You screwed up big time somewhere along the line. You are expecting to be using Java 7 according to the thread title, yet you are actually running an older Java 6 runtime.

          You are giving Java a heap of 6 megabytes. Why so little?
          • 2. Re: Error with jre7
            991584
            Yes you are right.

            in fact there are 2 jre version...

            one is

            C:\Program Files\Java\jre6\bin

            and the other one is

            C:\Program Files (x86)\Java\jre7\bin

            my script does not work using jre7 ( i don't know why) but it is still working linking on the path the older version jre6.

            Do you know what may I fix to make it working even with jre7?

            Mchiri