This discussion is archived
0 Replies Latest reply: Feb 18, 2013 8:11 AM by janpla RSS

New LDOM - 'VTOC part of TI failed'

janpla Newbie
Currently Being Moderated
I have created a new LDOM, with a zfs volume of 30GB, single slice, and an .iso file as the install DVD:

root@anopheles # ldm list -l sunsparcdbg
NAME STATE FLAGS CONS VCPU MEMORY UTIL UPTIME
sunsparcdbg active -n---- 5004 4 4G 0.1% 35m

SOFTSTATE
Solaris running

UUID
28a904bc-e42e-ccf6-dfbc-fedbd0a885d4

MAC
00:14:4f:f9:83:da

HOSTID
0x84f983da

CONTROL
failure-policy=ignore
extended-mapin-space=off

DEPENDENCY
master=

CORE
CID CPUSET
1 (12, 13, 14, 15)

VCPU
VID PID CID UTIL STRAND
0 12 1 0.2% 100%
1 13 1 0.1% 100%
2 14 1 0.1% 100%
3 15 1 0.1% 100%

MEMORY
RA PA SIZE
0x20000000 0x920000000 4G

VARIABLES
auto-boot?=true
boot-device=sunsparcdbg

NETWORK
NAME SERVICE ID DEVICE MAC MODE PVID VID MTU LINKPROP
vnet1 primary-vsw0@primary 0 network@0 00:14:4f:f8:dc:bd 1 1500

DISK
NAME VOLUME TOUT ID DEVICE SERVER MPGROUP
sunsparcdbg sunsparcdbg@primary-vds0 0 disk@0 primary
sol11_dvd sol11_dvd@primary-vds0 1 disk@1 primary

VCONS
NAME SERVICE PORT
sunsparcdbg primary-vcc0@primary 5004

It starts up well enough; devalias from the ok prompt shows:

{0} ok devalias
sol11_dvd /virtual-devices@100/channel-devices@200/disk@1
sunsparcdbg /virtual-devices@100/channel-devices@200/disk@0
vnet1 /virtual-devices@100/channel-devices@200/network@0
net /virtual-devices@100/channel-devices@200/network@0
disk /virtual-devices@100/channel-devices@200/disk@0
virtual-console /virtual-devices/console@1
name aliases

I can boot up from the DVD, sol11_dvd, but when it tries to install on the disk, sunsparcdbg, it immediately fails and the install log shows:

2013-02-18 16:07:04,971 - INFO : text-install:120 **** START ****
2013-02-18 16:07:25,312 - INFO : network_type.py:181 Configuring NIC as: none
2013-02-18 16:07:00,255 - ERROR : ti_install.py:314 Failed to initialize disk
2013-02-18 16:07:00,255 - ERROR : ti_install.py:315 VTOC part of TI failed
Traceback (most recent call last):
File "/usr/lib/python2.6/vendor-packages/osol_install/text_install/ti_install.py", line 278, in do_ti
tgt.create_disk_target(tgt_disk, False)
TypeError: VTOC part of TI failed

What is likely to be the problem?

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points