1 2 Previous Next 15 Replies Latest reply: Mar 8, 2013 6:54 AM by Mark Wagoner RSS

    Skillbuilder Modal Page Border Problem

    Mark Wagoner
      I have installed the Skillbuilder Modal Page plug-in both at work and on the Oracle hosted app site and in both places I am having the same issue, although slightly different.

      In each case when the popup window is displayed it does not have any borders. The title is displayed (at the top on our in-house system and at the bottom in the hosted environment).

      Also, and this is more of an oddity, I can't find where you change the theme for the poup on the hosted environment. On the in-house system there is a Settings region when you edit the plugin but this doesn't exist in the hosted environment. I assume this has something to do with the Apex version (we are using 4.0 in-house) but I would think it should still be possible to select a theme.

      The hosted app can be found at http://apex.oracle.com/pls/apex/f?p=71666:1:0::::: Click theTest Button to display the popup window.

      Any help would be appreciated.

      Thanks,
      Mark
        • 1. Re: Skillbuilder Modal Page Border Problem
          Tom Petrus
          Go to Shared Components > Plugins > select the modal page plugin. You can set the theme there. It'll probably be on 'Custom' since that is the default when you import the plugin, and this'll cause the non-styled modal.
          • 2. Re: Skillbuilder Modal Page Border Problem
            Mark Wagoner
            No, you can't set the theme there. At least not on the hosted version.

            And even if I could that won't fix the display issue. I have tested all 5 of the themes that come with the plug-in on our in-house system and none of them work. In fact, two of them make things worse.
            • 3. Re: Skillbuilder Modal Page Border Problem
              714270
              Mark Wagoner wrote:
              No, you can't set the theme there. At least not on the hosted version.

              And even if I could that won't fix the display issue. I have tested all 5 of the themes that come with the plug-in on our in-house system and none of them work. In fact, two of them make things worse.
              I had exactly the same issue when I first used the plugin and I did the same what Tom has suggested to fix the issue.
              Which 2 themes make the modal worse? I am using the plugin in my app and did not find any such problems.
              BTW, I hope your "Embed in Frames" under Edit Application Properties -> Security -> Browser Security is set correctly as described here:
              http://www.danielmcghan.us/2011/08/new-browser-security-attributes-in-apex.html



              Thanks,
              Rohit
              • 4. Re: Skillbuilder Modal Page Border Problem
                Tom Petrus
                Oh shoot, you are correct. Well, seems this has moved a bit (curses! Still have no 4.2 instance locally!). Go to "Shared Components > Component Settings > SkillBuilders Modal Page". Or in the plugin find "Component Settings" in the "Tasks" region on the right!
                • 5. Re: Skillbuilder Modal Page Border Problem
                  Mark Wagoner
                  Yes, i tlooks like Oracle moved it. And selecting a different theme (it was set to 'custom') fixed the problem, at least on the hosted environment. But I still have the problem in-house reghardless of the theme.

                  I can only think of two things that might be causing the problem. Either the plugin doesn't work with Apex 4.0 or there is something messed up with our installation. Looking at Firebug I don't see any errors regarding the image files used to drw the border so they must be getting downloaded. I was going to try deleting and re-installing the plugin but there doesn't seem to be a delete option.

                  Regarding which themes are worse; 1, 4 and 5. Themes 2 and 3 sort of work in that the page content is at least displayed. None of them look anything like the demo, however.

                  Any guess on how I should proceed?
                  • 6. Re: Skillbuilder Modal Page Border Problem
                    Tom Petrus
                    Okay,
                    Open a modal page. Inspect the html with firebug and look for a div with id "cboxTopRight". In the style tab there should be a "background" attirbute for #cboxTopRight which has a URL to the image used for styling the colorbox. When you hover over it, does it load the image?
                    For example, on mine i get (and i use theme 1)
                    #cboxTopRight {
                        background: url("wwv_flow_file_mgr.get_file?p_plugin_id=34805360636160040356&p_security_group_id=1377027056414870&p_file_name=t1controls.png") no-repeat scroll -130px 0 transparent;
                        height: 21px;
                        width: 21px;
                    }
                    Aside from that, does your page have an HTML5 doctype?
                    • 7. Re: Skillbuilder Modal Page Border Problem
                      TexasApexDeveloper
                      Didn't they have two versions? I had thought the newer version was for APEX 4.1 and beyond and the 1.x version was for APEX 4.0?? Just remember Dan talking about this in threads up here.. I have a copy of the older plugin if you would like it sent to you..

                      In looking at Dan's blog, he notes that the new version of the plugin uses colorbox versus a different method for displaying the modal pages: http://www.danielmcghan.us/2012/04/modal-page-goes-colorbox.html

                      Let me know here in this thread with your e-mail address and I will send you the plugin code..

                      Thank you,

                      Tony Miller
                      Ruckersville, VA
                      • 8. Re: Skillbuilder Modal Page Border Problem
                        Mark Wagoner
                        Yes, the image appears. There is no doctype defined for the page, just the html tag with a lang element.
                        • 9. Re: Skillbuilder Modal Page Border Problem
                          Mark Wagoner
                          Yes, can you send me the old version please? The email is mwagoner at cornerstonebrands dot com. How do I uninstall the current one?
                          • 10. Re: Skillbuilder Modal Page Border Problem
                            TexasApexDeveloper
                            Simple answer: http://nuijten.blogspot.com/2010/08/apex-40-removing-plugins.html

                            Thank you,

                            Tony Miller
                            Ruckersville, VA
                            • 11. Re: Skillbuilder Modal Page Border Problem
                              Mark Wagoner
                              I got version 2.0.0 uninstalled but when I try install 1.0.0 I get a "not compatible" error. Looks like I'll have to find something else. Thanks for all the help.
                              • 12. Re: Skillbuilder Modal Page Border Problem
                                TexasApexDeveloper
                                Hmm, have you visited Skillbuilders site and posted a question to Dan himself? IT might be he has an answer, since he is the builder of the plugin...

                                Thank you,

                                Tony Miller
                                Ruckersville, VA
                                • 13. Re: Skillbuilder Modal Page Border Problem
                                  Mark Wagoner
                                  I had posted a question there earlier but he told me to post it in the forums. He said they monitor posts with "skillbuilder" in the subject. I guess that might not be totally accurate.
                                  • 14. Re: Skillbuilder Modal Page Border Problem
                                    dmcghan
                                    Mark,

                                    First of all, "SkillBuilders" is spelled with an s at the end. The monitoring software doesn't look for mispeling ;)

                                    Please email me a request for version 1 of the plug-in and I will send you a copy that shouldn't have any install errors.

                                    Regards,
                                    Dan

                                    blog: http://DanielMcghan.us/
                                    work: http://SkillBuilders.com/APEX/
                                    1 2 Previous Next