This discussion is archived
2 Replies Latest reply: Feb 21, 2013 4:26 AM by Akanksha Sheoran Kaler RSS

Unable to  Install EM 12c on Windows 2003

Murali.Raju Newbie
Currently Being Moderated
OS : windows 2003
Database 10g

I have tried to installed EM12c failed on
*"Agent Configuration Assistant has failed"* => Install Progress.

In logfile.
*********************************
NFO: oracle.sysman.top.agent:Secure REPOSITORY_URL found. New agent should be configured for secure mode
INFO: oracle.sysman.top.agent:Secure emdWalletSrcUrl found. New agent should be configured for secure mode
INFO: oracle.sysman.top.agent:Oracle Enterprise Manager Cloud Control 12c Release 2
INFO: oracle.sysman.top.agent:Copyright (c) 1996, 2012 Oracle Corporation. All rights reserved.
INFO: oracle.sysman.top.agent:Property 'agentTZRegion' is missing from E:\oracleias\agent\agent_inst/sysman/config/emd.properties. Updating it...
INFO: oracle.sysman.top.agent:Default timezone for the system is:GMT+05:30 which is not supported. Installing a default timesone of GMT
INFO: oracle.sysman.top.agent:An agentTZregion of 'GMT' is installed in E:\oracleias\agent\agent_inst/sysman/config/emd.properties.
INFO: oracle.sysman.top.agent:The command: cmd /c set NEED_EXIT_CODE=1&&E:\oracleias\agent\core\12.1.0.2.0\bin\emctl.bat deploy agent -L -o xxxxt12:4899 -N E:\oracleias\agent\agent_inst xxxxt12:3872 camst12 completed with status=0
INFO: oracle.sysman.top.agent:Exit value -1
INFO: oracle.sysman.top.agent:AgentUpgradeMain CreateService FAILED: The specified service already exists.



INFO: oracle.sysman.top.agent:Failed in creating service Oracleagent12c1Agent

SEVERE: oracle.sysman.top.agent:Agent configuration has failed
INFO: oracle.sysman.top.agent:AgentConfiguration:agent configuration finished with status = false
INFO: oracle.sysman.top.agent:AgentConfiguration:agent configuration finished with status = false
INFO: oracle.sysman.top.agent:The plug-in Agent Configuration Assistant has failed its perform method
********************************

I have checked metalink says BUG:14184260

Apply Patch 14184260 on problematic Agent to resolve the issue.

But i am unable to download the patch , Please help on this issue.

Regards
Murali R
  • 1. Re: Unable to  Install EM 12c on Windows 2003
    mnazim Expert
    Currently Being Moderated
    Try this
    login to metalink- Patches and update- type 14184260 -press button search - select the require version patch - Click on download.
  • 2. Re: Unable to  Install EM 12c on Windows 2003
    Akanksha Sheoran Kaler Pro
    Currently Being Moderated
    Let me share some details on TZ issue. The bug that you are referring 14184260 is well known to us and is a JDK bug. The above bug is just a workaround for the jdk bug on only windows2003 hosts. Since Asia/Calcutta time zone has been deemed obsolete. It has been replaced by Asia/Kolkata. On windows, java returns a GMT offset timezone value and EMcode tries to find a supported timezone that maps to this GMT offset timezone. Failing to this it throw you the above TZ error. This all I can share with you on this forum if you are keen to know more pls log an SR and support will explain you in detail. We have fixed this bug for our next EM release

    On Unix/Linux: set TZ=Asia/Calcutta in the environment and execute: "emctl resettz agent". Then follow the instructions that are displayed after the command executes and it will solve the problem.

    For agent deploy on windows host we have documented the exact steps in MOS note 1530571.1. The note was just created a day back so it you cant see it yet, drop me an email and i can send u the steps. The steps are tried by another customer for agent deploy and works fine.
    Now to your usecase, once we confirm that you are running into same TZ issue while doing the EM fresh install on win 2003, i need to verify the steps for fresh install and have some internal discussions /testing. I request you to open an Sr so that we can move forward and help you.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points