4 Replies Latest reply: Jul 22, 2013 10:01 AM by KeishaD RSS

    Charts not displaying after upgrading to HTML5 Charts in APEX 4.2

    KeishaD
      Hi,

      I just upgraded my APEX 4.0 application to 4.2, and ran the utility to upgrade my charts to HTML5. After completing the upgrade, I noticed my charts no longer displayed in the region.

      I am currently using IE9 to view the application, since that's the browser over 90% of my users have.

      Is there something more I need to install?


      Thanks Keisha!!
        • 1. Re: Charts not displaying after upgrading to HTML5 Charts in APEX 4.2
          714270
          KeishaD wrote:
          Hi,

          I just upgraded my APEX 4.0 application to 4.2, and ran the utility to upgrade my charts to HTML5. After completing the upgrade, I noticed my charts no longer displayed in the region.

          I am currently using IE9 to view the application, since that's the browser over 90% of my users have.

          Is there something more I need to install?


          Thanks Keisha!!
          What is the behavior in other browsers? Secondly, you can look at the 4.2.1 patch set; there a few fixes related to HTML5 chart (though I am not sure if that would fix your problem). Here is the list of bugs that have been fixed in the patch set:
          http://www.oracle.com/technetwork/developer-tools/apex/application-express/apex-421-patch-set-notes-1885751.html#BABJCAFA
          • 2. Re: Charts not displaying after upgrading to HTML5 Charts in APEX 4.2
            Hilary Farrell-Oracle
            Hi Keisha,

            To assist in resolving your issue, it would be really helpful if you could please provide the following additional information:


            <li>Is your chart using custom XML?</li>
            <li>What type of chart have you created (e.g. 2D Pie)? Please note that only chart types exposed via our Create wizards are covered by our license with AnyChart - the third party charting utility that we incorporate into APEX.</li>
            <li>On the Chart Attributes page, if you change "Chart Rendering" to "Flash Chart", and click Apply Changes, is your chart still not rendering? I'm curious at to whether the issue is HTML5 specific.</li>
            <li>Is the page in question using a Desktop or Mobile user interface? Given that you've just upgraded to 4.2, I'm going to assume it's Desktop.</li>
            <li>When you run the page with DEBUG switched on, click on the "Show XML" link that displays under the chart, and review the XML associated with the chart. Do you see any errors reported?</li>
            <li>If you have a workspace on apex.oracle.com, would you mind creating a testcase so I can take a closer look? You should just be able to use the XML associated with your chart, and use it to populate the Custom XML region of the test chart.</li>


            Regards,
            Hilary
            • 3. Re: Charts not displaying after upgrading to HTML5 Charts in APEX 4.2
              KeishaD

              Hi 714270,

               

              Thanks for the information on the patch set!! I was pulled off onto something else, so I will look into the link when I get back around to working on this.

              • 4. Re: Charts not displaying after upgrading to HTML5 Charts in APEX 4.2
                KeishaD

                Hi Hilary,

                 

                 

                Thanks for your willingnes to help with this question.   Unfortunately, I was pulled off onto something else. So once I get back around to working on this, I'll look up the answers to the questions above. If the issue still exists,I would be soo appreciative of your help if your time allows.

                 

                Thanks!!!!!