This discussion is archived
3 Replies Latest reply: May 22, 2013 10:20 PM by omniwolf RSS

Problem with deployment.properties and Java 7

h4xx0r Newbie
Currently Being Moderated
We use deployment.config and deployment.properties files for Windows 7 32-bit and 32-bit Java. These work fine with Java 6u41 while Java 7u15 does use the browser settings. Anyhow the control panel does show the settings, but they are ignored by Java 7.
The auto proxy does work correctly when we delete the deployment.* files and set the auto proxy manually in the control panel, but this is not an option for us.

Is this a Java 7 bug?

TIA

deployment.config:
deployment.system.config=file\:C:/Windows/Sun/Java/Deployment/deployment.properties
deployment.system.config.mandatory=true

deployment.properties:
deployment.proxy.type=2
deployment.proxy.auto.config.url=http\://example.com/proxy.pac

Reference:
http://docs.oracle.com/javase/7/docs/technotes/guides/deployment/deployment-guide/properties.html
  • 1. Re: Problem with deployment.properties and Java 7
    993114 Newbie
    Currently Being Moderated
    try to add into deployment.properties:
    deployment.version=7.0
  • 2. Re: Problem with deployment.properties and Java 7
    1006813 Newbie
    Currently Being Moderated
    I have a similar problem. The only difference is that my deployment.proxy.auto.config.url = file \: ... and points to a local pac file.

    This configuration works on XP with both Java 6 and Java 7
    Java 6 on Windows 7 is also ok.

    But the combination Java 7u21 on Windows 7 does not work. Workaround is to delete the system level deployment.properties and configure java in user level deployment.properties, but it is not a good solution.

    Does anyone have a hint?

    PS adding deployment.version=7.0 did not solve the problem

    Edited by: 1003810 on May 2, 2013 1:01 PM
  • 3. Re: Problem with deployment.properties and Java 7
    omniwolf Newbie
    Currently Being Moderated
    I'm having the same problem as well. Java 7u21 (32bit), win7 64bit. All i'm trying to do is set

    deployment.security.level=MEDIUM

    in my deployment.properties, but it won't work, i have exactly the same deployment.config as the OP.


    I have noticed, if i go into the user deployment.properties for the user (C:\Users\<name>\AppData\LocalLow\Sun\Java\Deployment\deployment.properties), and delete the file, nothing changes (a new one just gets created with the non system wide settings). HOWEVER, if you open that user deployment.properties file, and remove the entries that you are trying to configure via the system wide deployment.properties, then the system wide deployment.properties comes into play and works.
    But obviously this is not something I want to have to do on every work station.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points