6 Replies Latest reply on Feb 22, 2013 9:32 PM by BillC

    APEX LISTENER Install troubleshooting

      Hi, I need help.. :-)

      Default Database connection not configured properly

      What I have done:
           connect APEX_LISTENER/mypasswd1
           connect APEX_PUBLIC_USER/mypasswd2
           connect APEX_REST_PUBLIC_USER/mypasswd1

      Check default.xml
      password: replaced encrypted one with clear text one for APEX_PUBLIC_USER to ensure it is correct
      even tried APEX_LISTENER password just incase

      Is there a simple JDBC test to see if it connects? it is APEX_PUBLIC_USER who is connecting isn't it?

      java -jar apex.war
      Feb 22, 2013 12:44:40 PM oracle.dbtools.standalone.Standalone execute
      INFO: NOTE:

      Standalone mode is designed for use in development and test environments. It is not supported for use in production environments.

      Feb 22, 2013 12:44:40 PM oracle.dbtools.standalone.Standalone execute
      INFO: Starting standalone Web Container in: /data/oracle/orawd/product/11.2.0/dbhome_1/apex_listener/apex
      Feb 22, 2013 12:44:41 PM oracle.dbtools.standalone.Deployer deploy
      INFO: Will deploy application path = /data/oracle/orawd/product/11.2.0/dbhome_1/apex_listener/apex/apex/WEB-INF/web.xml
      Feb 22, 2013 12:44:41 PM oracle.dbtools.standalone.Deployer deploy
      INFO: Deployed application path = /data/oracle/orawd/product/11.2.0/dbhome_1/apex_listener/apex/apex/WEB-INF/web.xml
      Feb 22, 2013 12:44:41 PM oracle.dbtools.common.config.file.ConfigurationFolder logConfigFolder
      INFO: Using configuration folder: /data/oracle/orawd/product/11.2.0/dbhome_1/apex_listener/apex
      Default Database connection not configured properly
      Feb 22, 2013 12:44:42 PM oracle.dbtools.rt.web.SCListener contextInitialized
      INFO: Oracle Application Express Listener initialized
      Application Express Listener version :
      Application Express Listener server info: Grizzly/1.9.49

      Feb 22, 2013 12:44:42 PM com.sun.grizzly.Controller logVersion
      INFO: GRIZZLY0001: Starting Grizzly Framework 1.9.49 - 2/22/13 12:44 PM
      Feb 22, 2013 12:44:42 PM oracle.dbtools.standalone.Standalone execute
      INFO: http://localhost:8888/apex started.
        • 1. Re: APEX LISTENER Install troubleshooting
          Tim St. H.
          The way you have it described, you are running in stand alone mode.

          To test, you can open a browser (on that machine) to the URL you were given:

          If it is working you should get a session and navigated to the admin URL.


          -- Tim St.
          • 2. Re: APEX LISTENER Install troubleshooting
            Ok, so "Default Database connection not configured properly" would be no problem?
            • 3. Re: APEX LISTENER Install troubleshooting
              Tim St. H.
              That could be a problem.

              I was answering the question:
              BillC wrote:
              Is there a simple JDBC test to see if it connects? it is APEX_PUBLIC_USER who is connecting isn't it?
              Yes - APEX_PUBLIC_USER is the connecting user.
              You can use SQLPLUS to make sure you have the correct password.

              After that, it is the SERVER, PORT, SID/SERVICE in the APEX listener you need to confirm.
              You can TNSPING to confirm you have the correct selections for those.

              You can always re-run the
              java -jar apex.war setup
              command to all of the basic settings.

              The reason I mention that is because if you modify the settings manually - we need to ask "which file?" because there is the default and the database specific one too.

              Try making a request to the service in standalone mode and you should get a terminal output (the window stays open) with a more detailed error. I would guess there will be an ORA-12514, TNS listener does not currently know of service requested in descriptor or something similar that will give you the "debug" information you are looking for.

              --Tim St.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               
              • 4. Re: APEX LISTENER Install troubleshooting
                Ok, I just used a little JDBC test program: http://www.mkyong.com/jdbc/connect-to-oracle-db-via-jdbc-driver-java/

                and got the following (Connection refused??)

                [orawd@REX jdbctest]$ java OracleJDBC
                -------- Oracle JDBC Connection Testing ------
                Oracle JDBC Driver Registered!
                Connection Failed! Check output console
                java.sql.SQLRecoverableException: IO Error: The Network Adapter could not establish the connection
                at oracle.jdbc.driver.T4CConnection.logon(T4CConnection.java:458)
                at oracle.jdbc.driver.PhysicalConnection.<init>(PhysicalConnection.java:546)
                at oracle.jdbc.driver.T4CConnection.<init>(T4CConnection.java:236)
                at oracle.jdbc.driver.T4CDriverExtension.getConnection(T4CDriverExtension.java:32)
                at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:521)
                at java.sql.DriverManager.getConnection(Unknown Source)
                at java.sql.DriverManager.getConnection(Unknown Source)
                at OracleJDBC.main(OracleJDBC.java:29)
                Caused by: oracle.net.ns.NetException: The Network Adapter could not establish the connection
                at oracle.net.nt.ConnStrategy.execute(ConnStrategy.java:392)
                at oracle.net.resolver.AddrResolution.resolveAndExecute(AddrResolution.java:434)
                at oracle.net.ns.NSProtocol.establishConnection(NSProtocol.java:687)
                at oracle.net.ns.NSProtocol.connect(NSProtocol.java:247)
                at oracle.jdbc.driver.T4CConnection.connect(T4CConnection.java:1102)
                at oracle.jdbc.driver.T4CConnection.logon(T4CConnection.java:320)
                ... 7 more
                Caused by: java.net.ConnectException: Connection refused
                at java.net.PlainSocketImpl.socketConnect(Native Method)
                at java.net.PlainSocketImpl.doConnect(Unknown Source)
                at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
                at java.net.PlainSocketImpl.connect(Unknown Source)
                at java.net.SocksSocketImpl.connect(Unknown Source)
                at java.net.Socket.connect(Unknown Source)
                at oracle.net.nt.TcpNTAdapter.connect(TcpNTAdapter.java:150)
                at oracle.net.nt.ConnOption.connect(ConnOption.java:133)
                at oracle.net.nt.ConnStrategy.execute(ConnStrategy.java:370)

                I tried WCER being the SID
                               connection = DriverManager.getConnection(
                                         "jdbc:oracle:thin:@localhost:1521:WCER", "APEX_PUBLIC_USER",

                               connection = DriverManager.getConnection(
                                         "jdbc:oracle:thin:@<url>:1521:WCER", "APEX_PUBLIC_USER",

                               connection = DriverManager.getConnection(
                                         "jdbc:oracle:thin:@<ip address>:1521:WCER", "APEX_PUBLIC_USER",
                • 5. Re: APEX LISTENER Install troubleshooting
                  sqlplus apex_public_user/mypasswd@WCER

                  was successful..
                  • 6. Re: APEX LISTENER Install troubleshooting
                    OK, I found the problem.. I had the port wrong 1555 not 1521.