5 Replies Latest reply: Feb 27, 2013 9:11 AM by Michel RSS

    PeopleTools 8.53 Ren Server.

    user7137712
      Hi,

      I've got peopletools installed on a windows 7 laptop. I've got the Ren Server running and can run the block test. The PeopleSoft logo is visible as per: "The PeopleSoft gif in the upper left corner will not load if the page's URL is incompatible with the PeopleSoft Authentication Token; this is a normal feature of REN Server security."

      So it appears the ren server URL and PeopleSoft token are OK.

      However, I can't run the ping test as I get an access denied message.

      Has anyone any suggestions!

      Thanks,

      Steve.
        • 1. Re: PeopleTools 8.53 Ren Server.
          Michel
          Windows 7 is not a certified server OS for PeopleSoft. Are you sure you are running it on your laptop and not on (virtual) server?

          Anything in your Application server logs (Specifically the REN server logs)?
          What is the exact error message?
          • 2. Re: PeopleTools 8.53 Ren Server.
            user7137712
            Hi,

            Thanks for reply.. I'm not using any form virtualisation. The application server, web server and windows database are all on a laptop running windows 7.

            The Ren Server buffer test runs OK and I can see the PeopleSoft logo when I run the buffer test.

            However, the ping tests generates a (Notice) message in the PSRENSRV_0225.log file of:

            (Dgb) tunnel id =
            (Notice) Access denied, no PS_TOKEN and tunnel id found.

            I am running the Ren Server with a log_severity_level =Debug .
            • 3. Re: PeopleTools 8.53 Ren Server.
              user756542
              That particular issue usually occurs if you don't have authentication domain set up on your web server and/or REN server. Try the following:

              1) If the authentication domain is not set up on the web server, do the following:
              a. Navigate to PeopleTools > Web Profile > Web Profile Configuration > General tab -> Authentication Domain
              b. Enter the authentication domain. Eg .oracle.com /* Note leading dot character */

              2) If authentication domain is not set up on the REN server, do the following:
              a. Navigate to PeopleTools > REN Server Configuration > REN Server Cluster > REN Server Cluster tab > Authentication Token
              b . Enter the authentication token. Eg oracle.com /* Note there is **no leading dot character */

              Also make sure you are using same protocol to access PeopleSoft application and REN server (in other words, if you log into PeopleSoft application using https, then you need to access REN server using https)

              -Karen
              • 4. Re: PeopleTools 8.53 Ren Server.
                user7137712
                Karen,

                I've looked at all those settings. I think my problem might be that I'm on a "Laptop" which does not have a domain. I'm using the laptop hosts file to mirror the URL used on our development web server. Everything looks good other than the Ren Server not being happy with the PS_TOKEN value.

                Guess I've got some more head scratching to do. I got the Ren Server working in tools 8.52. However, I don't seem to be having much success with 8.53.

                Cheers,

                Steve.
                • 5. Re: PeopleTools 8.53 Ren Server.
                  Michel
                  Try adding this line to the psrenconfig.txt file (should exist in your application server domain directory).

                  ns_param disable_authentication true

                  Clear app server cache en restart.

                  https://support.oracle.com/epmos/faces/DocumentDisplay?id=663691.1