This discussion is archived
10 Replies Latest reply: Feb 25, 2013 1:06 PM by EBSDBA RSS

adadmin problem

user9338712 Newbie
Currently Being Moderated
Dear All,

I did a fresh installation of oracle EBS on Linux 64 bit , and after running adadmin , it disconnects abnormally as you can see below
AD Administration is verifying your username/password.
The status of various features in this run of AD Administration is:

                                           <-Feature version in->
Feature                          Active?   APPLTOP    Data model    Flags
------------------------------   -------   --------   -----------   -----------
CHECKFILE                        Yes       1          1             Y N N Y N Y
PREREQ                           Yes       6          6             Y N N Y N Y
CONCURRENT_SESSIONS              No        2          2             Y Y N Y Y N
[applprod@AOUProdFINDB scripts]$
[applprod@AOUProdFINDB scripts]$
[applprod@AOUProdFINDB scripts]$ adadmin
Tried running autoconfig, tried bouncing apps and db tier..

Any idea
  • 1. Re: adadmin problem
    user9338712 Newbie
    Currently Being Moderated
    No errors in db alert log..

    Any idea
  • 2. Re: adadmin problem
    Hussein Sawwan-Oracle Employee ACE
    Currently Being Moderated
    I did a fresh installation of oracle EBS on Linux 64 bit , and after running adadmin , it disconnects abnormally as you can see below
    Did you complete all the steps in (Oracle E-Business Suite Installation and Upgrade Notes Release 12 (12.1.1) for Linux x86-64 [ID 761566.1])?
    AD Administration is verifying your username/password.
    The status of various features in this run of AD Administration is:
    
    <-Feature version in->
    Feature                          Active?   APPLTOP    Data model    Flags
    ------------------------------   -------   --------   -----------   -----------
    CHECKFILE                        Yes       1          1             Y N N Y N Y
    PREREQ                           Yes       6          6             Y N N Y N Y
    CONCURRENT_SESSIONS              No        2          2             Y Y N Y Y N
    [applprod@AOUProdFINDB scripts]$
    [applprod@AOUProdFINDB scripts]$
    [applprod@AOUProdFINDB scripts]$ adadmin
    Tried running autoconfig, tried bouncing apps and db tier..

    Any idea
    Can you reproduce the issue with any other AD utility (like adpatch)?

    Thanks,
    Hussein
  • 3. Re: adadmin problem
    Hussein Sawwan-Oracle Employee ACE
    Currently Being Moderated
    user9338712 wrote:
    No errors in db alert log..

    Any idea
    Can you please verify the status of "apps/applsys/system" accounts and make sure the passwords are valid and none of the accounts is locked?

    Thanks,
    Hussein
  • 4. Re: adadmin problem
    user9338712 Newbie
    Currently Being Moderated
    Thanks Hussein
    SQL> select username,account_status from dba_users where username='APPS';
    
    USERNAME                       ACCOUNT_STATUS
    ------------------------------ --------------------------------
    APPS                           OPEN
    
    SQL> select username,account_status from dba_users where username='APPLSYS';
    
    USERNAME                       ACCOUNT_STATUS
    ------------------------------ --------------------------------
    APPLSYS                        OPEN
    
    SQL> select username,account_status from dba_users where username='SYSTEM';
    
    USERNAME                       ACCOUNT_STATUS
    ------------------------------ --------------------------------
    SYSTEM                         OPEN
    Moreover, I did adrelink.sh for ad using adrelink.sh force=y "ad all"


    Still the same problem

    Edited by: user9338712 on Feb 25, 2013 12:11 PM
  • 5. Re: adadmin problem
    user9338712 Newbie
    Currently Being Moderated
    SQL> select username,account_status from dba_users where account_status like '%LOCK%';
    
    USERNAME                       ACCOUNT_STATUS
    ------------------------------ --------------------------------
    AD_MONITOR                     EXPIRED & LOCKED
    SI_INFORMTN_SCHEMA             EXPIRED & LOCKED
    EM_MONITOR                     EXPIRED & LOCKED
    XS$NULL                        EXPIRED & LOCKED
    SPATIAL_WFS_ADMIN_USR          EXPIRED & LOCKED
    TSMSYS                         EXPIRED & LOCKED
    ORACLE_OCM                     EXPIRED & LOCKED
    SPATIAL_CSW_ADMIN_USR          EXPIRED & LOCKED
    XDB                            EXPIRED & LOCKED
    DMSYS                          EXPIRED & LOCKED
    DIP                            EXPIRED & LOCKED
    
    USERNAME                       ACCOUNT_STATUS
    ------------------------------ --------------------------------
    ANONYMOUS                      EXPIRED & LOCKED
    MDDATA                         EXPIRED & LOCKED
  • 6. Re: adadmin problem
    Hussein Sawwan-Oracle Employee ACE
    Currently Being Moderated
    Can you reproduce the issue with adpatch?

    Thanks,
    Hussein
  • 7. Re: adadmin problem
    user9338712 Newbie
    Currently Being Moderated
    Thanks Hussein.

    Adpatch works fine.. all the steps in the document followed
  • 8. Re: adadmin problem
    user9338712 Newbie
    Currently Being Moderated
    I believe after doing the below , I got the below problem.. how do I rever it back

    Link to Motif library in Oracle Application Server 10.1.2 (on Oracle Linux 5, RHEL 5, Oracle Linux 6 and RHEL 6 only)

    Perform the following command (as root on your system) to update a required link to a Motif library prior to relinking or patching the 10.1.2 Application Server Oracle Home:

    # unlink /usr/lib/libXtst.so.6
    # ln -s /usr/X11R6/lib/libXtst.so.6.1 /usr/lib/libXtst.so.6
  • 9. Re: adadmin problem
    Hussein Sawwan-Oracle Employee ACE
    Currently Being Moderated
    user9338712 wrote:
    I believe after doing the below , I got the below problem.. how do I rever it back

    Link to Motif library in Oracle Application Server 10.1.2 (on Oracle Linux 5, RHEL 5, Oracle Linux 6 and RHEL 6 only)

    Perform the following command (as root on your system) to update a required link to a Motif library prior to relinking or patching the 10.1.2 Application Server Oracle Home:

    # unlink /usr/lib/libXtst.so.6
    # ln -s /usr/X11R6/lib/libXtst.so.6.1 /usr/lib/libXtst.so.6
    What is your OS? If you are on Linux 5/6 you do not need to revert. And, if adpatch works properly then adadmin should work with no issues.

    Do you have any invalid objects in the database?

    Thanks,
    Hussein
  • 10. Re: adadmin problem
    EBSDBA Expert
    Currently Being Moderated
    user9338712 wrote:
    I believe after doing the below , I got the below problem.. how do I rever it back

    Link to Motif library in Oracle Application Server 10.1.2 (on Oracle Linux 5, RHEL 5, Oracle Linux 6 and RHEL 6 only)

    Perform the following command (as root on your system) to update a required link to a Motif library prior to relinking or patching the 10.1.2 Application Server Oracle Home:

    # unlink /usr/lib/libXtst.so.6
    # ln -s /usr/X11R6/lib/libXtst.so.6.1 /usr/lib/libXtst.so.6
    These steps should not cause any problems.

    What problem are you getting now? Is it same as before?

    To revert it back, you need to unlink the current link and create the old link.

    #unlink /usr/lib/libXtst.so.6
    #ln -s <file where libXtst.so.6 was pointing before> /usr/lib/libXtst.so.6

    Thanks

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points