3 Replies Latest reply: Apr 29, 2013 9:23 AM by adi_071 RSS

    apex listener 2.0 and Glassfish  configuration

    Sivamani
      Hi,

      I have doubts about the following

      i) java -jar apex.war static <apex directory>\images

      ii) deploying i.war on glassfish

      In first where i can find the apex image directory.Because the apex is in database tier but i am deploying the apex listener and glassfish in application tier.
      where is the location of i.war file.

      Please assist.

      Thanks
        • 1. Re: apex listener 2.0 and Glassfish  configuration
          Sivamani
          Hi all i manually copied the apex images into some folder called /ebs/TEST/apex/images and used the command

          java -jar apex.war static /ebs/TEST/apex/images

          after this it created i.war file.and i deployed it in Glassfish.But now the apex login page is blank.getting 404 - Not Found ..Could some one help me on it..
          • 2. Re: apex listener 2.0 and Glassfish  configuration
            Mindmap
            Hello,
            Please make sure that you did something similar to this:

            To create the i.war file:

            On Windows. right click on the CMD, then choose Run as asministrator
            C:\Users\Fateh>java -jar G:\listener2\apex.war static C:\apex\images
            Then it tells you where you can find it as you can see below :
             WAR Generation complete
             WAR location     : C:\Users\Fateh\i.war
             Context path     : /i
             Static resources : C:\apex\images
            Then when you deploy the i.war, make sure to delete the i from Context Root item

            Best Regards,
            Fateh
            ---
            If you believe that my answer was correct, then please mark it as correct or helpful.
            • 3. Re: apex listener 2.0 and Glassfish  configuration
              adi_071
              Hi,

              go to location of your glassfish domain log (mine is C:\glassfish3\glassfish\domains\domain1\logs). Check what it says in server.log file. You might have problem with authorization of users (APEX_PUBLIC_USER). Password for this user should be the same as the one
              you provided while configuring apex.war.

              Regards,
              adi_071