14 Replies Latest reply: Mar 14, 2013 8:40 AM by KVRK RSS

    Zoom enabled forms not opening

    KVRK
      Hi All,

      We have a Dev instance which is cloned from Prod.

      We have got zoom buttom enabled in couple of forms using AXF accelerator.

      After cloning, the forms (ex: AP Invoice work bench) are not opening at all.
      All other forms are opening.

      What could be the issue.

      I have tried recompiling the CUSTOM.pll
      Checked the axf tables.

      Your inputs please
        • 1. Re: Zoom enabled forms not opening
          Srinath Menon-Oracle
          Hi ,

          Please check the EBS master log and IPM logs to see what exactly is the error message shown when launching the form .

          Thanks,
          Srinath
          • 2. Re: Zoom enabled forms not opening
            KVRK
            Thanks for the update Srinath.

            Forms are opening now. But dont know the root cause.
            Found a workaround to reinstall JRE on desktop, after which forms are opening today.

            However, when we click on zoom, getting this error in logs and not getting connected to imaging:

            -----------------------------------------------
            02-28-2013 10:37:00 AXF Managed Attachment is not enabled
            02-28-2013 10:37:02 AXFCustom.launch_command_soap AXFVersion = 2
            02-28-2013 10:37:02 Get_soap_policy ---> enter
            02-28-2013 10:37:02 Policy ----> USER_NAME_TOKEN
            02-28-2013 10:37:02 Setting the soapSecurity
            02-28-2013 10:37:02 get_username_token policy ---> enter
            02-28-2013 10:37:02 get_soap_username ----> enter
            02-28-2013 10:37:02 Get_Soap_password ---> Enter
            02-28-2013 10:37:02 get_soap_username ----> enter
            02-28-2013 10:37:02 Get_Soap_password ---> Enter
            02-28-2013 10:37:02 AXF.Check_For_Secure_Mode Enter
            02-28-2013 10:37:02 AXF.Check_For_Secure_Mode Secure Mode is found to be FALSE
            02-28-2013 10:37:02 AXFCustom.launch_command_soap , Secure Mode is OFF
            02-28-2013 10:37:02 Unhandled exception in AXFCustom.launch_command_soap SQLCODE = -29273: ORA-29273: HTTP request failed
            ORA-06512: at "SYS.UTL_HTTP", line 1130
            ORA-28759: failure to open file
            ORA-06512: at "APPS.AXF_SOAPCALL", line 14
            ---------------------------------------------------------------------------
            Went through the "How to Troubleshoot AXF Errors on the Initial HTTP Call to IPM "SQLCODE = -29273: ORA-29273: HTTP request failed" [ID 1293056.1]"
            but its not working.

            Please advise.
            • 3. Re: Zoom enabled forms not opening
              VikrantKorde 1
              Hi KVRK,

              You need to chek the Request and response files generated during the SOAP calls. You will be able to find these on apps DB server under /usr/tmp folder. THe files you should be looking at are
              - <EBS_USER>MASTERLOG.txt
              - <EBS_USER>RAWrequest.txt
              - <EBS_USER>RAWresponse.txt
              - <EBS_USER>_Response.xml

              You will come to know the reason behind that.

              Regards,
              Vikrant Korde.
              • 4. Re: Zoom enabled forms not opening
                KVRK
                Thanks Vikranth.

                Zoom is enabled now and when we click on it, imagin is opening but, getting "repository error"
                Here is the log :
                It saying invalid credentials. Where do we need to change ?
                Please advise.
                --------------
                Caused by: oracle.imaging.ImagingException: TCM-00787: A repository error occurred.
                faultType: SYSTEM
                faultDetails:
                ErrorCode = oracle.stellent.ridc.protocol.ServiceException, ErrorMessage = Unable to retrieve search results. Connection authorization failed. Invalid credentials.
                at oracle.imaging.repository.ucm.UcmErrors.convertRepositoryError(UcmErrors.java:126)
                at oracle.imaging.repository.ucm.UcmCompiledSearch.execute(UcmCompiledSearch.java:74)
                at oracle.imaging.repository.ucm.UcmRepositoryManager.executeCompiledSearch(UcmRepositoryManager.java:987)
                at oracle.imaging.search.SearchExecuteManager$SearchExecutionRunnable.run(SearchExecuteManager.java:238)
                at java.lang.Thread.run(Thread.java:662)
                Caused by: oracle.stellent.ridc.protocol.ServiceException: Unable to retrieve search results. Connection authorization failed. Invalid credentials.
                at oracle.stellent.ridc.protocol.ServiceResponse.getResponseAsBinder(ServiceResponse.java:142)
                at oracle.stellent.ridc.protocol.ServiceResponse.getResponseAsBinder(ServiceResponse.java:108)
                at oracle.imaging.repository.ucm.UcmResponse.<init>(UcmResponse.java:68)
                at oracle.imaging.repository.ucm.UcmRequest.makeOneServiceCall(UcmRequest.java:425)
                at oracle.imaging.repository.ucm.UcmRequest.makeServiceCall(UcmRequest.java:228)
                at oracle.imaging.repository.ucm.UcmCompiledSearch.execute(UcmCompiledSearch.java:70)
                ... 3 more
                ----------
                • 5. Re: Zoom enabled forms not opening
                  KVRK
                  Also.. here is the error i am getting when i try to open any document in the content server or imaging:

                  !csUserEventMessage,sampleuser,CIS!$!$!csConnectionAuthFailed
                  intradoc.common.ServiceException:
                  at intradoc.server.ServiceRequestImplementor.buildServiceException(ServiceRequestImplementor.java:2115)
                  at intradoc.server.Service.buildServiceException(Service.java:2326)
                  at intradoc.server.Service.createServiceExceptionEx(Service.java:2320)
                  at intradoc.server.Service.createServiceException(Service.java:2315)
                  at intradoc.server.ServiceSecurityImplementor.validateRemoteClientConnectionPrivilege(ServiceSecurityImplementor.java:718)
                  at intradoc.server.ServiceSecurityImplementor.globalSecurityCheck(ServiceSecurityImplementor.java:232)
                  at intradoc.upload.UploadSecurityImplementor.globalSecurityCheck(UploadSecurityImplementor.java:57)
                  at intradoc.server.Service.globalSecurityCheck(Service.java:2737)
                  at intradoc.server.ServiceRequestImplementor.doRequest(ServiceRequestImplementor.java:678)
                  at intradoc.server.Service.doRequest(Service.java:1956)
                  at intradoc.server.ServiceManager.processCommand(ServiceManager.java:437)
                  at intradoc.server.IdcServerThread.processRequest(IdcServerThread.java:265)
                  at intradoc.server.IdcServerThread.run(IdcServerThread.java:160)
                  at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTuningWorkManagerImpl.java:545)
                  at weblogic.work.ExecuteThread.execute(ExecuteThread.java:256)
                  at weblogic.work.ExecuteThread.run(ExecuteThread.java:221)
                  Caused by: intradoc.common.ServiceException: !csConnectionAuthFailed
                  at intradoc.provider.ProxyConnectionUtils.getRemotePassword(ProxyConnectionUtils.java:262)
                  at intradoc.provider.ProxyConnectionUtils.incomingProxyAuth(ProxyConnectionUtils.java:241)
                  at intradoc.provider.SocketIncomingConnection.getAndCheckConnectionProperties(SocketIncomingConnection.java:255)
                  at intradoc.provider.SocketIncomingConnection.checkRequestAllowed(SocketIncomingConnection.java:163)
                  at intradoc.server.ServiceSecurityImplementor.validateRemoteClientConnectionPrivilege(ServiceSecurityImplementor.java:714)
                  at intradoc.server.ServiceSecurityImplementor.globalSecurityCheck(ServiceSecurityImplementor.java:232)
                  at intradoc.upload.UploadSecurityImplementor.globalSecurityCheck(UploadSecurityImplementor.java:60)
                  at intradoc.server.Service.globalSecurityCheck(Service.java:2738)
                  ... 8 more
                  • 6. Re: Zoom enabled forms not opening
                    Bijesh Krishnadas
                    Have you checked the AXF config tables (AXF_PROPERTIES & AXF_COFIGS) to ensure that all parameters are correct?

                    Also check that the AXF_SOAP_USER has been correctly setup in the FND_VAULT and that the correct credential key is setup in weblogic (IPM).
                    • 7. Re: Zoom enabled forms not opening
                      Srinath Menon-Oracle
                      Hi ,

                      Can you check if config.cfg has the following set of entries :

                      ProxyPassword=managed
                      ProxyPasswordEncoding=managed

                      If yes , then comment these 2 entries and save the file . Restart WCC Managed server and test again .

                      Thanks,
                      Srinath
                      • 8. Re: Zoom enabled forms not opening
                        VikrantKorde 1
                        Hi KVRK,

                        You need to check if the security is given properly for that IPM application under application security and document security.
                        Are you getting this error for super admin user also?

                        Regards,
                        Vikrant Korde.
                        • 9. Re: Zoom enabled forms not opening
                          KVRK
                          Hi Brajesh,
                          I have checked AXF config tables (AXF_PROPERTIES & AXF_COFIGS) and FND_VAULT, AXF_SOAP_USER

                          Please let me know on what needs to be done for Credential key setup ?
                          • 10. Re: Zoom enabled forms not opening
                            KVRK
                            Hi Srinath,

                            I have checked and those entries are not there at all.

                            Thanks
                            • 11. Re: Zoom enabled forms not opening
                              Srinath Menon-Oracle
                              Hi ,

                              Please post the config.cfg entries here .

                              Thanks,
                              Srinath
                              • 12. Re: Zoom enabled forms not opening
                                KVRK
                                Hi All,

                                The issue was resolved.
                                Srinath, you are right. the entires were wrong.
                                We had two config files :

                                /../../ipm/Oracle/Middleware/user_projects/domains/ipm-domain/ucm/cs/config/config.cfg
                                /../../ipm/ecmdata/ucm/cs/config/config.cfg

                                I was looking at the first but had the below entires in the 2nd config file which was causing the issue.

                                ProxyPassword=managed
                                ProxyPasswordEncoding=managed

                                But not sure why the file is updated at all. It was working fine earlier.

                                Thanks for all your help
                                • 13. Re: Zoom enabled forms not opening
                                  Srinath Menon-Oracle
                                  Hi ,

                                  Can you please mark the thread as answered for other boarders benefit .

                                  Thanks,
                                  Srinath
                                  • 14. Re: Zoom enabled forms not opening
                                    KVRK
                                    Done Srinath.