2 Replies Latest reply on Mar 4, 2013 4:45 PM by Elena.mtc

    Get_Block Error when installing an application

      Hi all,

      I tried to recover a backup I had made some days ago, and I got the following error when installing the application:

      Error GET_BLOCK Error.
      ORA-20001: GET_STMT error. ORA-20001: Execution of the statement was unsuccessful. ORA-06550: line 34, column 68: PLS-00103: Encountered the symbol "&" when expecting one of the following: ) , * & = - + < / > at in is mod remainder not rem <an exponent (**)> <> or != or ~= >= <= <> and or like like2 like4 likec between || multiset member submultiset <pre> <br>begin <

      I looked in the .sql application and searched for the """ or even for the symbols &" and I found nothing. I checked the character set and it seems right, the application is in UNICODE-UTF8 and the database is in UTF8 as well. I'm working with APEX version 4.1.1 and apex listener 1.1.

      Has anyone got this error before, or does anyone have a tip on where to investigate?

      Thanks in advance.
        • 1. Re: Get_Block Error when installing an application

          I forgot to say that I tried exporting the application from the SQL Developer, and I got the same error.
          Although I didn't try to import it from the SQL Developer since I don't know how to change the APP_ID (just using replace?) and I don't want to overwrite the existing application, but to install it with another ID.

          • 2. Re: Get_Block Error when installing an application
            For those who have gotten this error as well..

            The problem was in the buttons Expand /Collapse that I had in some trees. I had them with a redirect url pointing to a javascript code like this:
            I changed these buttons, I set an action "Defined by a Dynamic Action". This DA is called when the button is clicked and executes this javascript code:
            Now it works. Hope it can help someone.