This discussion is archived
3 Replies Latest reply: Feb 28, 2013 10:15 PM by user10526115 RSS

Failed to start Weblogic as Windows service on Windows 2008R2

user10526115 Newbie
Currently Being Moderated
Hello,
I was able to create a windows service for weblogic admin server but it is failing after showing status as started.
Below are the steps I followed to create the service:

Create installSvc_iw.cmd
**********************
@echo off
SETLOCAL


set WL_HOME=G:\BEA\wlserver_10.3
set DOMAIN_NAME=iw
set USERDOMAIN_HOME=G:\BEA\iw\domains\iw
set SERVER_NAME=AdminServer
set WLS_USER=weblogic
set WLS_PW=weblogic
@rem set PRODUCTION_MODE=false
set MEM_ARGS=-Xms512m -Xmx512m -Dweblogic.log.RedirectStdoutToServerLogEnabled=true
set JAVA_HOME=C:\PROGRA~1\Java\jdk1.6.0_33
set PATH=%PATH%;%JAVA_HOME%\bin
set JAVA_VENDOR=Sun
set JAVA_VM=-server
set CLASSPATH=G:\BEA\patch_wls1030\profiles\default\sys_manifest_classpath\weblogic_patch.jar;G:\BEA\patch_cie660\profiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\PROGRA~1\Java\jdk1.6.0_33\lib\tools.jar;G:\BEA\wlserver_10.3\server\lib\weblogic_sp.jar;G:\BEA\wlserver_10.3\server\lib\weblogic.jar;G:\BEA\modules\features\weblogic.server.modules_10.3.0.0.jar;G:\BEA\wlserver_10.3\server\lib\webservices.jar;G:\BEA\modules\org.apache.ant_1.6.5/lib/ant-all.jar;G:\BEA\modules\net.sf.antcontrib_1.0.0.0_1-0b2/lib/ant-contrib.jar;;G:\BEA\wlserver_10.3\common\eval\pointbase\lib\pbclient57.jar;G:\BEA\wlserver_10.3\server\lib\xqrl.jar;;
set JAVA_OPTIONS = -Xverify:none -da -Dplatform.home=G:\BEA\wlserver_10.3 -Dwls.home=G:\BEA\wlserver_10.3\server -Dweblogic.home=G:\BEA\wlserver_10.3\server -Dweblogic.management.discover=true -Dwlw.iterativeDev= -Dwlw.testConsole= -Dwlw.logErrorsToConsole= -Dweblogic.ext.dirs=G:\BEA\patch_wls1030\profiles\default\sysext_manifest_classpath;G:\BEA\patch_cie660\profiles\default\sysext_manifest_classpath -Dweblogic.Stderr=G:\BEA\ASstderr.txt
call "G:\BEA\wlserver_10.3\server\bin\installSvc.cmd"

@echo %JAVA_OPTIONS%

pause

ENDLOCAL
********************
After execution of the script admin server was successfully created as windows service.
Command line from regedit:
***********************************
-server -Xms256m -Xmx1024m -XX:CompileThreshold=8000 -XX:PermSize=48m -XX:MaxPermSize=256m -Xverify:none -da -Dplatform.home=G:\BEA\wlserver_10.3 -Dwls.home=G:\BEA\wlserver_10.3\server -Dweblogic.home=G:\BEA\wlserver_10.3\server -Dweblogic.management.discover=true -Dwlw.iterativeDev= -Dwlw.testConsole= -Dwlw.logErrorsToConsole= -Dweblogic.ext.dirs=G:\BEA\patch_wls1030\profiles\default\sysext_manifest_classpath;G:\BEA\patch_cie660\profiles\default\sysext_manifest_classpath -classpath "G:\BEA\patch_wls1030\profiles\default\sys_manifest_classpath\weblogic_patch.jar;G:\BEA\patch_cie660\profiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\PROGRA~1\Java\jdk1.6.0_33\lib\tools.jar;G:\BEA\wlserver_10.3\server\lib\weblogic_sp.jar;G:\BEA\wlserver_10.3\server\lib\weblogic.jar;G:\BEA\modules\features\weblogic.server.modules_10.3.0.0.jar;G:\BEA\wlserver_10.3\server\lib\webservices.jar;G:\BEA\modules\org.apache.ant_1.6.5/lib/ant-all.jar;G:\BEA\modules\net.sf.antcontrib_1.0.0.0_1-0b2/lib/ant-contrib.jar;;G:\BEA\patch_wls1030\profiles\default\sys_manifest_classpath\weblogic_patch.jar;G:\BEA\patch_cie660\profiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\PROGRA~1\Java\jdk1.6.0_33\lib\tools.jar;G:\BEA\wlserver_10.3\server\lib\weblogic_sp.jar;G:\BEA\wlserver_10.3\server\lib\weblogic.jar;G:\BEA\modules\features\weblogic.server.modules_10.3.0.0.jar;G:\BEA\wlserver_10.3\server\lib\webservices.jar;G:\BEA\modules\org.apache.ant_1.6.5/lib/ant-all.jar;G:\BEA\modules\net.sf.antcontrib_1.0.0.0_1-0b2/lib/ant-contrib.jar;;G:\BEA\wlserver_10.3\common\eval\pointbase\lib\pbclient57.jar;G:\BEA\wlserver_10.3\server\lib\xqrl.jar;" -Dweblogic.Name=AdminServer -Dweblogic.management.username=weblogic -Dweblogic.ProductionModeEnabled= -Djava.security.policy="G:\BEA\wlserver_10.3\server\lib\weblogic.policy" weblogic.Server

****************************
Log message after the service failed to start:
*******************
g:\BEA\wlserver_10.3\server\bin>beasvc -debug "Oracle beasvc iw_AdminServer"

Debugging service ....... Oracle beasvc iw_AdminServer

Command Line: ....... -server -Xms256m -Xmx1024m -XX:CompileThreshold=8000 -XX:PermSize=48m -XX:MaxPermSize=256m -Xverify:none -da -Dplatform.home=G:\BEA\wlserver_10.3 -Dwls.home=G:\BEA\wlserver_10.3\server -Dweblogic.home=G:\BEA\wlserver_10.3\server -Dweblogic.management.discover=true -Dwlw.iterativeDev= -Dwlw.testConsole= -Dwlw.logErrorsToConsole= -Dweblogic.ext.dirs=G:\BEA\patch_wls10
30\profiles\default\sysext_manifest_classpath;G:\BEA\patch_cie660\profiles\default\sysext_manifest_classpath -classpath "G:\BEA\patch_wls1030\profiles\default\sys_manifest_classpath\weblogic_patch.jar;G:\BEA\patch_cie660\profiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\PROGRA~1\Java\jdk1.6.0_33\lib\tools.jar;G:\BEA\wlserver_10.3\server\lib\weblogic_sp.jar;G:\BEA\wlserver_10.3\server\lib\weblogic.jar;G:\BEA\modules\features\weblogic.server.modules_10.3.0.0.jar;G:\BEA\wlserver_10.3\server\lib\webservices.jar;G:\
BEA\modules\org.apache.ant_1.6.5/lib/ant-all.jar;G:\BEA\modules\net.sf.antcontrib_1.0.0.0_1-0b2/lib/ant-contrib.jar;;G:\BEA\patch_wls1030\profiles\default\sys_manifest_classpath\weblogic_patch.jar;G:\BEA\patch_cie660\profiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\PROGRA~1\Java\jdk1.6.0_33\lib\tools.jar;G:\BEA\wlserver_10.3\server\lib\weblogic_sp.jar;G:\BEA\wlserver_10.3\server\lib\weblogic.jar;G:\BEA\modules\features\weblogic.server.modules_10.3.0.0.jar;G:\BEA\wlserver_10.3\server\lib\webservices.jar;G:\BEA\modules\org.apache.ant_1.6.5/lib/ant-all.jar;G:\BEA\modules\net.sf.antcontrib_1.0.0.0_1-0b2/lib/ant-contrib.jar;;G:\BEA\wlserver_10.3\common\eval\pointbase\lib\pbclient57.jar;G:\BEA\wlserver_10.3\server\lib\xqrl.jar;" -Dweblogic.Name=AdminServer -Dweblogic.management.username=weblogic -Dweblogic.ProductionModeEnabled= -Djava.security.policy="G:\BEA\wlserver_10.3\server\lib\weblogic.policy" weblogic.Server

Current Directory: ....... G:\BEA\iw\domains\iw

Path: ....... G:\BEA\wlserver_10.3\server\native\win\x64\;G:\BEA\wlserver_10.3\server\bin;C:\PROGRA~1\Java\jdk1.6.0_33\jre\bin;C:\PROGRA~1\Java\jdk1.6.0_33\bin;G:\BEA\wlserver_10.3\server\native\win\x64\oci920_8;%JAVA_HOME%\bin;G:\inuat\inserver6\envoy\bin;G:\oracle\product\11.2.0\client_1\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C
:\Program Files\IBM\GSK7\bin;C:\Program Files\IBM\GSK7\lib;C:\IBM\ITM\bin;C:\IBM\ITM\TMAITM6;C:\IBM\ITM\InstallITM

Java Home: ....... C:\PROGRA~1\Java\jdk1.6.0_33

Delay: ....... 0

Thread created successfully!
<Feb 27, 2013 3:46:55 PM PST> <Info> <WebLogicServer> <BEA-000377> <Starting WebLogic Server with Java HotSpot(TM) 64-Bit Server VM
Version 20.8-b03 from Sun Microsystems Inc.>
<Feb 27, 2013 3:46:55 PM PST> <Info> <Management> <BEA-141107> <Version: WebLogic Server 10.3 Fri Jul 25 16:30:05 EDT 2008 1137967
>
<Feb 27, 2013 3:46:55 PM PST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to STARTING>
<Feb 27, 2013 3:46:55 PM PST> <Info> <WorkManager> <BEA-002900> <Initializing self-tuning thread pool>
<Feb 27, 2013 3:46:55 PM PST> <Notice> <Log Management> <BEA-170019> <The server log file G:\BEA\iw\domains\iw\servers\AdminServer\logs\AdminServer.log is opened. All server side log events will be written to this file.>
<Feb 27, 2013 3:46:57 PM PST> <Notice> <Security> <BEA-090082> <Security initializing using security realm myrealm.>
<Feb 27, 2013 3:46:57 PM PST> <Critical> <Security> <BEA-090052> <Server installed as Windows NT service with incorrect password for
user weblogic; The password may have been changed since the server was installed as a Windows NT Service. Contact the Windows NT system administrator.>
<Feb 27, 2013 3:46:57 PM PST> <Critical> <WebLogicServer> <BEA-000386> <Server subsystem failed. Reason: weblogic.security.SecurityI
nitializationException: Server installed as Windows NT service with incorrect password for user weblogic; The password may have been changed since the server was installed as a Windows NT Service. Contact the Windows NT system administrator.
weblogic.security.SecurityInitializationException: Server installed as Windows NT service with incorrect password for user weblogic; The password may have been changed since the server was installed as a Windows NT Service. Contact the Windows NT system administra
tor.
at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.doBootAuthorization(Unknown Source)
at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.initialize(Unknown Source)
at weblogic.security.service.SecurityServiceManager.initialize(Unknown Source)
at weblogic.security.SecurityService.start(SecurityService.java:141)
at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
Truncated. see log file for complete stacktrace
>
<Feb 27, 2013 3:46:57 PM PST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FAILED>
<Feb 27, 2013 3:46:57 PM PST> <Error> <WebLogicServer> <BEA-000383> <A critical service failed. The server will shut itself down>
<Feb 27, 2013 3:46:57 PM PST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FORCE_SHUTTING_DOWN>
***************************************
After getting the error, did following steps to resolve:

1. Changed the boot.properties
username=weblogic
password=weblogic

2. Deleted data folder in G:\BEA\iw\domains\iw\servers\AdminServer\data
3. Changed teh config.xml
Before:
<default-realm>myrealm</default-realm>
<credential-encrypted>{3DES}Yz3FAHIf6WvrUGCV5Hxv34dcouBOIFD2SQ/BelbFvFsinZBBNOcL1VkdyuK+rfP+aYCXFOOA8vb7Hd8TyWU334G0Wyg4zXjW</credential-encrypted>
<node-manager-username>weblogic</node-manager-username>
<node-manager-password-encrypted>{3DES}+9Z0wglJdE9Ai34yrCVkKA==</node-manager-password-encrypted>
After:
<default-realm>myrealm</default-realm>
     <credential-encrypted>{3DES}Yz3FAHIf6WvrUGCV5Hxv34dcouBOIFD2SQ/BelbFvFsinZBBNOcL1VkdyuK+rfP+aYCXFOOA8vb7Hd8TyWU334G0Wyg4zXjW</credential-encrypted>
<node-manager-username>weblogic</node-manager-username>
<node-manager-password-encrypted>weblogic</node-manager-password-encrypted>
4. Authentication providers changed it to SUFFICIENT for all the providers .

I had gone through all the solution provided by the forum but nothing worked in my favor.

I hope I will get the solution here.

Thanks,
Jit

Edited by: user10526115 on Feb 27, 2013 5:59 PM

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points