5 Replies Latest reply: Mar 13, 2013 12:36 PM by 992731 RSS

    How to disable automatic archive gap automatic resolution

    992731
      Hi everyone,

      I'am trying to resolve manually archivelog gap for physical standby database ( production environnement) because the network link was not able to transport lot of generated logs. Besides that, there was trouble with automatic archive gap resolution (not retrieving the correct sequence)

      So, I copied manually the needed archivelogs and registerd them as doc says.

      after that, I issued the following command:
       recover automatic from '/u07/oradata/archivelogs/missing/' standby database until cancel;
      which gave me this error message:


      ORA-16145:
      archival for thread# string sequence# string in progress


      I undertood that automatic resolution is working again (too late for me) and it's (as it appears herebelow) retrieving archive logs I had already copied manually as I mentied.
      SQL> select process, status, sequence# from v$managed_standby;
      
      PROCESS   STATUS        SEQUENCE#
      --------- ------------ ----------
      ARCH      CONNECTED             0
      ARCH      CONNECTED             0
      ARCH      CONNECTED             0
      ARCH      CONNECTED             0
      RFS       IDLE             435501
      RFS       IDLE             435500
      RFS       IDLE             435499
      RFS       IDLE             435826
      RFS       IDLE             435495
      RFS       IDLE             435496
      I did effort to transport those 17GB of needed archivelogs on external hard drive. So, I want to stop gap automatic resolution because it's very slow (limited bandwidth).

      Is there any way to do that?
      Thanks a lot.


      Notes:
      -I'am using Managed physical standby.
      -I'am not using Dataguard Broker
      - here is my parameter
      SQL> show parameter log_archive_dest_2
      
      NAME                                 TYPE        VALUE
      ------------------------------------ ----------- ------------------------------
      log_archive_dest_2                   string      SERVICE=AGRTEST_S LGWR ASYNC R
                                                       EOPEN=60 MAX_FAILURE=20 DELAY=
                                                       720 OPTIONAL  NOAFFIRM VALID_F
                                                       OR=ONLINE_LOGFILES,PRIMARY_ROL
                                                       E)   DB_UNIQUE_NAME=AGRTEST_S
                                                       VERIFY
      -Oracle version: 10.2.0.4.0

      Regards,
      Bilal
        • 1. Re: How to disable automatic archive gap automatic resolution
          Shivananda Rao
          Hello,

          If it would have been only few archives that were to be registered, then you could use:
          alter database register logfile '<archive log path>';
          But since you say that the archive size is around 17GB, try to catalog the directory containing the archives that you copied on the standby
          RMAN>catalog start with '<path of the archives that have been copied to standby>';
          Once you register them manually, you can start the MRP on the standby database.

          Hope this helps http://jarneil.wordpress.com/2008/05/16/registering-archive-logfiles-on-a-standby/



          Regards,
          Shivananda
          • 2. Re: How to disable automatic archive gap automatic resolution
            CKPT
            To resolve the huge archive gap, You can go for incremental rollforward, You can use link from my blog http://www.oracle-ckpt.com/rman-incremental-backups-to-roll-forward-a-physical-standby-database-2/

            & more.

            As i read your post, It is issue more with Network rather than anything.
            What is the redo log file size do you have? However you are using Real-time apply. Then if you once resolve the GAP between primary and standby later only the current redo has to be transferred from primary to standby.

            Apart from that, I would suggest to see network tuning, By adjusting SDU/TDU size in Network parameters, So that you can control the size of the data need to send across the network.

            For this, I suggest you to review MAA Network best practices document http://www.oracle.com/technetwork/database/features/availability/maa-wp-10gr2-dataguardnetworkbestpr-134557.pdf

            Review it and let me know after you performed above changes.

            Edited by: CKPT on Feb 28, 2013 9:58 PM
            • 3. Re: How to disable automatic archive gap automatic resolution
              Hemant K Chitale
              Set LOG_ARCHIVE_DEST_STATE_2='DEFER' on the primary. That will prevent the two databases from communicating with each other while the Standby recovers from the archivelogs that you have copied over.
              Once the Standby has completed the catchup or the lag is a very small number of archivelogs, set LOG_ARCHIVE_DSET_STATE_2='ENABLE' on the primary.


              Hemant K Chitale
              • 4. Re: How to disable automatic archive gap automatic resolution
                Hemant K Chitale
                Set LOG_ARCHIVE_DEST_STATE_2 ='DEFER' on the Primary. That will stop the two databases from communicating with each other. You can then have the Standby RECOVER using the Archivelogs that you have copied over.
                Once the gap is very low, you can then set LOG_ARCHIVE_DEST_STATE_2='ENABLE' to re-enable gap resolution.


                Hemant K Chitale
                • 5. Re: How to disable automatic archive gap automatic resolution
                  992731
                  Thank you everybody,

                  I resolved the issue using :

                  RMAN>catalog start with '<path of the archives that have been copied to standby>';

                  along with setting the parameter:

                  LOG_ARCHIVE_DEST_STATE_2='DEFER'

                  for the network issue, we discovered that some switch need to be replaced.