1 Reply Latest reply: Apr 2, 2013 10:02 AM by 994091 RSS

    Dependency Issue or Problem with JNLP file

      Hello, I am new to Java Web Start and am having problems exporting an RCP project. I don't know if this is an Eclipse problem or a Java problem, but after wrapping everything in my product file up in a new feature and exporting, when I launch I get this message:

      MissingFieldException[ The following required field is missing from the launch file: <jnlp><information><vendor>]
           at com.sun.javaws.jnl.XMLFormat.buildInformationDesc(Unknown Source)

      looking through the web it seems like it was suggested that there might be a missing dependency somewhere.

      So with that, I started removing features from my export feature. I was able to pinpoint a few features that if I were to leave them out, then I was able to bypass this error. Things appeared to download fine, but then the application didn't start. The log says:

           at java.util.Hashtable.put(Unknown Source)
           at org.eclipse.equinox.launcher.WebStartMain.basicRun(WebStartMain.java:78)
           at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
           at org.eclipse.equinox.launcher.WebStartMain.main(WebStartMain.java:57)
           at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
           at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
           at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
           at java.lang.reflect.Method.invoke(Unknown Source)
           at com.sun.javaws.Launcher.executeApplication(Unknown Source)
           at com.sun.javaws.Launcher.executeMainClass(Unknown Source)
           at com.sun.javaws.Launcher.doLaunchApp(Unknown Source)
           at com.sun.javaws.Launcher.run(Unknown Source)
           at java.lang.Thread.run(Unknown Source)

      Which seems to point to an osgi framework issue. I did happen to notice that the folder that it was writing out to was going to my desktop, not to my actual user home.

      So I don't know if this is a problem with my JNLP file (I can post if necessary), or if I have another issue (or multiple). I've been banging my head on this one for some time, so any help would be greatly appreciated!
        • 1. Re: Dependency Issue or Problem with JNLP file
          I guess I'll answer my own question here... it doesn't seem too publicized, but when exporting feature for Java Web Start the vendor information must be filled out. This would have been an easy fix based on the error message, except that this was referring to an Eclipse library that was not under my direct control. Had to import this library and make sure the information was filled out, and then re-export for Java Web Start to work.