9 Replies Latest reply: Mar 6, 2013 8:49 AM by CArnold RSS

    Maximum number of input records errors, tried different XML settings

    CISguy
      Hello,

      I've got a PIVOT table where I'm getting *"Exceeded configured maximum number of allowed input records."*

      My report is 20 columns * about 6000 rows so 120,0000. I've tried upping both the bolded settings below to 500,000 to no avail. I get the same error in the table view where the settings is still set to 64,000 rows.

      <Pivot>
      <MaxVisibleColumns>5000</MaxVisibleColumns>
      <MaxVisiblePages>2500</MaxVisiblePages>
      *<MaxVisibleRows>500000</MaxVisibleRows>*
      <MaxVisibleSections>5000</MaxVisibleSections>
      *<DefaultRowsDisplayed>500000</DefaultRowsDisplayed>*
      <MaxCells>5000000</MaxCells>
      <DefaultRowsDisplayedInDownload>15000</DefaultRowsDisplayedInDownload>
      </Pivot>
        • 1. Re: Maximum number of input records errors, tried different XML settings
          CArnold
          I was getting the same error yesterday. I followed the steps mentioned in Oracle Doc ID 1338331.1 and it seemed to work for me:

          1) Stop Presentation Server.

          2) Take a back-up copy of your current instanceconfig.xml file in this directory

          <OBIEE_HOME>/instances\instance2\config\OracleBIPresentationServicesComponent\coreapplication_obips1

          3) Edit instanceconfig.xml and make the following changes.

          i. Increase the values for the following two parameters in the <Cube> section; for example:
          <Cube>
          <CubeMaxRecords>5000000</CubeMaxRecords>
          <CubeMaxPopulatedCells>15000000</CubeMaxPopulatedCells>
          </Cube>



          ii. Increase the values for the following two parameters in the <Pivot> section; for example:
          <Pivot>
          <MaxCells>4000000</MaxCells>
          <MaxVisibleRows>140000</MaxVisibleRows>
          ....
          </Pivot>


          Leave the other parameter values in the Pivot section at their default values.



          iii. Increase these 2 settings in the <Table> section; for example:
          <Table>
          <MaxCells>4000000</MaxCells>
          <MaxVisibleRows>140000</MaxVisibleRows>
          </Table>


          Leave the other parameter values in the Table section at their default values.



          iv. Increase this setting in the <Charts> section; for example:
          <Charts>
          <MaxVisibleRows>140000</MaxVisibleRows>
          </Charts>


          Leave the other parameter values in the Chart section at their default values.



          4) Increase the following parameters in the WebLogic FMW Console or Enterprise Manager.

          Click on Fam_bifoundation_domain -> Business Intelligence -> coreapplications -> Capacity Management -> Performance. Change these to settings as follow:
          Maximum Number of Rows Processed when Rendering a Table View Number Of Rows: 800000
          Maximum Number of Rows to Download Number Of Rows: 140000
          • 2. Re: Maximum number of input records errors, tried different XML settings
            CISguy
            thanks Arnold in CA, I'll give it a try. Say, you aren't Arnold Schwarzenegger are you? Hah!
            • 3. Re: Maximum number of input records errors, tried different XML settings
              CArnold
              Lol...my muscles aren't as big, and my wallet is not as fat as his.
              • 4. Re: Maximum number of input records errors, tried different XML settings
                CISguy
                We don't have cube and chart sections in our instanceconfig.xml, but we also aren't using either of those. Our table settings is already at 500k which is higher than your recommendation.

                We're checking on the settings in Step 4) but I'm not optimistic.
                • 5. Re: Maximum number of input records errors, tried different XML settings
                  CArnold
                  Yes, we did not have the Cube or Chart sections in the our instanceconfig.xml file either. I had to add it.

                  I know it seems strange...for us it was a pivot table that was throwing the error, but making all of the entries suggested in the document is what fixed our issue.
                  Initially we made the recommended changes, but left out the Cube section. We still had the issue until we added the Cube section.
                  • 6. Re: Maximum number of input records errors, tried different XML settings
                    CISguy
                    would you mind pasting your cube and chart sections in their entirety here? Would be greatly appreciated.
                    • 7. Re: Maximum number of input records errors, tried different XML settings
                      CArnold
                      Here is my whole 'Views' section:

                      <Views>
                      <Pivot>
                      <!--This Configuration setting is managed by Oracle Business Intelligence Enterprise Manager
                      -->
                      <DefaultRowsDisplayedInDelivery>75</DefaultRowsDisplayedInDelivery>
                      <!--This Configuration setting is managed by Oracle Business Intelligence Enterprise Manager
                      -->
                      <DefaultRowsDisplayedInDownload>500000</DefaultRowsDisplayedInDownload>
                      <!--This Configuration setting is managed by Oracle Business Intelligence Enterprise Manager
                      -->
                      <DisableAutoPreview>false</DisableAutoPreview>
                      <MaxCells>1920000</MaxCells>
                      <MaxVisibleColumns>5000</MaxVisibleColumns>
                      <MaxVisiblePages>2500</MaxVisiblePages>
                      <MaxVisibleRows>500000</MaxVisibleRows>
                      <MaxVisibleSections>5000</MaxVisibleSections>
                      </Pivot>
                      <Table>
                      <!--This Configuration setting is managed by Oracle Business Intelligence Enterprise Manager
                      -->
                      <DefaultRowsDisplayedInDelivery>75</DefaultRowsDisplayedInDelivery>
                      <!--This Configuration setting is managed by Oracle Business Intelligence Enterprise Manager
                      -->
                      <DefaultRowsDisplayedInDownload>500000</DefaultRowsDisplayedInDownload>
                      <MaxCells>1920000</MaxCells>
                      <MaxVisiblePages>2500</MaxVisiblePages>
                      <MaxVisibleRows>500000</MaxVisibleRows>
                      <MaxVisibleSections>5000</MaxVisibleSections>
                      </Table>
                      <Charts>
                      <MaxVisibleRows>140000</MaxVisibleRows>
                      </Charts>
                      <Cube>
                      <CubeMaxRecords>1000000</CubeMaxRecords>
                      <CubeMaxPopulatedCells>5000000</CubeMaxPopulatedCells>
                      </Cube>
                      </Views>
                      • 8. Re: Maximum number of input records errors, tried different XML settings
                        CISguy
                        It was the cube settings that fixed it.

                        Instinctively i think of cube as having connected to an OLAP data source like Hyperion but apparently it applies to pivot tables too. Makes sense if you think about it. It's just confusing that raising <pivot> settings alone didn't correct the problem.

                        Thanks!
                        • 9. Re: Maximum number of input records errors, tried different XML settings
                          CArnold
                          I agree. I had the exact same thoughts as you.

                          I'm glad it fixed your issue. :)