This discussion is archived
6 Replies Latest reply: Mar 5, 2013 4:18 AM by DustinC RSS

OBIEE 11g: Blocking Analysis

DustinC Explorer
Currently Being Moderated
I was working on setting up Blocking Analysis, I read up on this in the Oracle documentation at...

http://docs.oracle.com/cd/E21764_01/bi.1111/e10541/answersconfigset.htm

I originally setup a javascript file and a CustomMessages folder for the XML, restarted the OBIEE components. And it did NOT work.

So I decided to just do the simplest piece. I went into the answerstemplates.xml (Made a backup of Original File) file at Oracle_BI1\bifoundation\web\msgdb\messages and changed the Query Blocking call from True to show a Message. Below is what I updated it too (I replaced the HTML tags with the [] characters):

[WebMessage name="kuiCriteriaBlockingScript" translate="no"][HTML[script type="text/javascript"]function validateAnalysisCriteria(analysisXml)
{
return "Pick Another Subject Area!"; // by default, no checking is done
}[script][HTML][WebMessage]

So the original text was set to return True.

This is all I did, in my mind any query that a user attempts to run should get the message.

I restarted all of the OBIEE components. Ran a query and data was returned. No message.

Has anyone implemented this successfullly? I feel I am doing the easiest change to validate the expected behaviour and it still does not behave as expected.
  • 1. Re: OBIEE 11g: Blocking Analysis
    Srini VEERAVALLI Guru
    Currently Being Moderated
    This part of code I'm not clear from your post, make sure you follow as said in the doc.

    <HTML>
    <script type="text/javascript" src="fmap:myblocking.js" />
    </HTML>

    If need send me email with files to validate
  • 2. Re: OBIEE 11g: Blocking Analysis
    DustinC Explorer
    Currently Being Moderated
    Thanks for the update but if you look in the answerstemplates XML file by deafult the Javascript is part of the document (called out with the Script tag). I tried it by calling the javascript saved in the folder analyticsres but didn't work.

    With that being said, I am just doing what is done out of the box. Excpet I am changing the script within the xml file so that it defaults to a Message Box instead of True (Allow all queries to run).
  • 3. Re: OBIEE 11g: Blocking Analysis
    Srini VEERAVALLI Guru
    Currently Being Moderated
    Try this
    <HTML><script type="text/javascript">
    "Pick Another Subject Area!"
    </script></HTML>

    Edited by: Srini VEERAVALLI on Mar 4, 2013 2:43 PM
  • 4. Re: OBIEE 11g: Blocking Analysis
    DustinC Explorer
    Currently Being Moderated
    Srini, if you look at my original post, that is what I have, except I have the semi-colon after the message. In regards to the file, the only file I have updated is the answerstemplates.xml file.

    Search for kuiCriteriaBlockingScript in that file. out of the box OBIEE 11g sets the return value to TRUE. I am replacing TRUE with a message "Pick Another Subject Area!" (See the original Post) in that xml file.

    Have you tried ths in your environment and it is working? I am on 11.1.1.6.0
  • 5. Re: OBIEE 11g: Blocking Analysis
    Hyder Mehtawala Expert
    Currently Being Moderated
    Hi,

    I tried this on 11.1.1.6.6 (on IE7) and it seems to be working fine. As mentioned, I just changed the return statement from return true to return "some message" and it behaved as expected. i.e. As soon as I click on the Results tab, I get the custom message.

    After making the changes in answerstemplates.xml file, I restarted only the Presentation services from EM, cleared browser cache and validated the change.


    Thanks
    Hyder
  • 6. Re: OBIEE 11g: Blocking Analysis
    DustinC Explorer
    Currently Being Moderated
    Thanks HM, then I am lost. As I am doing the same exact thing in the answerstemplates for the WebMessage "kuiCriteriaBlockingScript"

    Changing the following line from

    return true;

    to

    return "Pick a Subject Area";

    I am on IE 8 and have tried this in 11.1.1.6.0 and in 11.1.1.6.8 (We are in the process of moving to this version). I updated the answerstemplates file in the messages folder, restarted Presentation Services. Cleared browser cache.

    I am able to run ad-hoc queries and get results with no custom message.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points