This discussion is archived
0 Replies Latest reply: Mar 4, 2013 3:35 PM by Ravi Shah RSS

JMS Bridges not showing the right status

Ravi Shah Newbie
Currently Being Moderated
I am using the weblogic 9.2 MP3 on production servers with around 300 managed servers in 7 clusters. There are around 1200 queues and 2500 JMS bridges connecting the queues to internal and external world.

The JMS bridges on my system doesn't reflect the right status. Sometimes, it shows INACTIVE/Failed status but still keep forwarding the messages.

Different bridge status and description that I can see:

Inactive     Stopped by the administrator.
Active     Forwarding messages.
Inactive     WARN: failed to connect to the target.
Active     Connected to the source.

Also,

I see lots of warnings in the logs as follows...

####<5/03/2013 10:33:33 AM EST> <Warning> <MessagingBridge> <HOSTNAME> <MS NAME> <[ACTIVE] ExecuteThread: '11' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1362440013003> <BEA-200026> <Bridge "BRIDGE NAME" encountered some problems in one of its adapters or underlying systems. It stopped transferring messages and will try to reconnect to the adapters shortly. (The exception caught was javax.resource.ResourceException: Error setting message listener.)>

<27/01/2013 05:52:07 AM EST> <Warning> <Connector> <BEA-190024> << eis/jms/WLSConnectionFactoryJNDIXA > Error making initial connections for pool. Reason: javax.resource.ResourceException: Adapter internal error -- connectionFactory object is not instanceof ConnectionFactory>

Any help on the issue will be appreciated...

Thanks

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points