3 Replies Latest reply: Mar 7, 2013 7:38 AM by user12273962 RSS

    Networking problem

    Verdi
      Hello,

      I created a VM and installed Oracle Solaris 10 x86 on it. The hosting machine is Windows 7 64bit.
      For networking on the virtual machine I use Bridged-Network.
      When I am logged in the virtual machine with root and execute:
      #ifconfig -a
      I get:
      bash-3.2# ifconfig -a
      lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
               inet 127.0.0.1 netmask ff000000
      e1000g0: flags=1004843<UP,BROADCAST,RUNNING,MULTICAST,DHCP,IPv4> mtu 1500 index 2
               inet 10.29.5.101 netmask ffffff00 broadcast 10.29.5.255
               ether 8:0:27:6f:c:4d
      lo0: flags=2002000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8252 index 1
               inet6 ::1/128
      e1000g0: flags=2004841<UP,RUNNING,MULTICAST,DHCP,IPv6> mtu 1500 index 2
               inet6 fe80::a00:27ff:fe6f:c4d/10
               ether 8:0:27:6f:c:4d
      bash-3.2#
      When I ping from windows the VM, I get:
      C:\Users\usr1>ping 10.29.5.101
      
      Pinging 10.29.5.101 with 32 bytes of data:
      Reply from 10.29.5.101: bytes=32 time<1ms TTL=255
      Reply from 10.29.5.101: bytes=32 time=1ms TTL=255
      Reply from 10.29.5.101: bytes=32 time<1ms TTL=255
      Reply from 10.29.5.101: bytes=32 time<1ms TTL=255
      
      Ping statistics for 10.29.5.101:
          Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
      Approximate round trip times in milli-seconds:
          Minimum = 0ms, Maximum = 1ms, Average = 0ms
      However, when I try to connect to it via WinScp to transfer files I receive error: Access denied.

      Also when I try to access internet (open www.google.com for example) from the VM I receive error: Server not found

      Any ideas what can be the problem?

      Thank you very much!
        • 1. Re: Networking problem
          user12273962
          Do you have ssh enabled on the guest?

          what does ping www.google.com give you? Maybe a DNS issue.
          • 2. Re: Networking problem
            Verdi
            Hi and thanks a lot for the reply!

            I modified the /etc/ssh/sshd_config file to allow remote login with root user, so now I can access the VM remotely from the host machine. It was really easy thing, wasn't it :)

            However, the other thing seems to eb a DNS problem.
            When I ping from the VM www.google.com, I get the following error:
            bash-3.2# ping www.google.com
            ping: unknown host www.google.com
            bash-3.2#
            bash-3.2#
            bash-3.2# Mar 7 10:29:54 unknown sendmail[624]: [ID 702811 mail.alert] unable to qualify my own domain name (unknown) -- using short name
            bash-3.2#
            Please, can you advise me on how to resolve the DNS issue?
            Thanks again!
            • 3. Re: Networking problem
              user12273962
              Its been so long since I actually laid hands on Solaris... I don't remember when.

              run a...

              cat /etc/resolv.conf

              and post the output.

              This should list your DNS server settings and your domain search order.