This discussion is archived
1 Reply Latest reply: Mar 10, 2013 10:06 AM by souvik_das RSS

apache-siteminder-weblgogic

user10999846 Newbie
Currently Being Moderated
Hi ALL,


I am facing one issue in apache-siteminder-weblogic environment. We are using Siteminder for SSO functionality
where webagent is configured to apache and there is a redirection logic in apache

Coming to issue:
we recently upgraded weblogic from 10.0 to 10.3.4 , so after upgrade, this redirection thing is not working. So when i rolled out to previous version,
it starts working. No idea what could be the issue. We enabled weblogic Proxy-plugin parameter also for each manage server in new version. But still we are getting issue.



I am not sure, do i have to change anything in siteminder configurations. please advice.



Thanks
  • 1. Re: apache-siteminder-weblgogic
    souvik_das Newbie
    Currently Being Moderated
    Please can you clarify what exactly you mean by the redirection not working.
    Do you mean the weblogic-apache plugin which comes with the default installation is not working and does not load-balance and/or fail-over between weblogic servers when required?

    As for the change between Weblogic 10.0 and 10.3.4, please check if your servers are in a cluster or stand alone servers.
    For Cluster - Set the WebLogic Plug-in Enabled control in WebLogic Cluster level(where the cluster is defined).
    For stand-alone - Set the WebLogic Plug-in Enabled control in WebLogic Server level (each individual server).

    Refer to this link for the documentation - http://docs.oracle.com/cd/E17904_01/web.1111/e16435/toc.htm

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points