This discussion is archived
2 Replies Latest reply: Mar 11, 2013 8:34 PM by 940748 RSS

After 11g upgrade "REP - 501: Unable to connect...."

940748 Newbie
Currently Being Moderated
Hi All,

There is a problem in one of our application which is deployed on 10g AS(10.1.2.0). The database it was connecting was upgraded to 11.2.0.3 from 10gR2.
A report is not getting executed from a form. But from web browser the report is working in standalone. Below i have checked so far.

Error I am getting:
REP - 501: Unable to connect to the specified database.

1. Disabled case sensitive login in the 11g database.
2.Used FORMS_USERNAME_CASESENSITIVE = 1 in ORACLE_HOME/forms/server/default.env.
3.Checked for zrclient.jar and rwrun.jar in classpath env variable.
4.Changed Service_name to sid in the tns connect string.
5.Restarted the whole opmn stack.
6.Run the form in debug mode and find the username,password and connect string it is throwing to report is OK. I can connect through sqlplus.

No error in forms server log in opmn or in report server.

Please help.
Now where to look at?

Regards,
Gourab
  • 1. Re: After 11g upgrade "REP - 501: Unable to connect...."
    Fabian Pro
    Currently Being Moderated
    Hi,

    Try few things,
    1) try tnsping <sid name>, specified in tnsnames.ora file from Oracle Application Server

    2) try running the report through the below url
    http://ipaddress:port/reports/rwservlet?report=report.rdf&userid=username/password@database&destype=cache&desformat=pdf&
    paramform=yes

    3)Trace the form and try running the report (u can google how to trace a form in 10gAS),errors would be mentioned in the trace file.The trace file will be generated in $ORACLE_HOME/forms/trace

    http://ipaddress:port/forms/frmservlet?config=(name_specified_in_formsweb.cfg)&record=forms

    Regards
    Fabian
  • 2. Re: After 11g upgrade "REP - 501: Unable to connect...."
    940748 Newbie
    Currently Being Moderated
    Fabian wrote:
    Hi,

    Try few things,
    1) try tnsping <sid name>, specified in tnsnames.ora file from Oracle Application Server

    2) try running the report through the below url
    http://ipaddress:port/reports/rwservlet?report=report.rdf&userid=username/password@database&destype=cache&desformat=pdf&
    paramform=yes

    3)Trace the form and try running the report (u can google how to trace a form in 10gAS),errors would be mentioned in the trace file.The trace file will be generated in $ORACLE_HOME/forms/trace

    http://ipaddress:port/forms/frmservlet?config=(name_specified_in_formsweb.cfg)&record=forms

    Regards
    Fabian
    Thanks for your reply.
    1. tnsping is ok.
    2. reports is working in this way. Problem was when calling from forms.
    3. did not tried the trace. Before that the root cause of the problem was found.

    Well you may say this is a mistake from my side. The URL that was being generated by the form was with wrong report server name. The application has the capability to fetch the report server name from the server and store in a db table. From that table the report server name is read and URL is made. Don't know why, some developer wrote the report server name in the form instead of fetching it from the db. So there was a mismatch of the report server name and it was not running. All I was having access was screenshot of the error and the logs. So I missed out the URL.

    Regards,
    Gourab

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points