1 Reply Latest reply on Mar 10, 2013 6:52 PM by Jibba Jabba

    APEX Listener deployment fails-java.lang.reflect.InvocationTargetException

    Jibba Jabba
      I'm trying to intall the Listener and I'm at the point where I do "java -jar apex.war" but I get this:
      J-PC:J >java -jar apex.war
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
              at java.lang.reflect.Method.invoke(Unknown Source)
              at oracle.dbtools.jarcl.Entrypoint.main(Entrypoint.java:58)
      Caused by: java.lang.NullPointerException
              at oracle.dbtools.common.cmds.DefaultCommand.execute(DefaultCommand.java:70)
              at oracle.dbtools.common.cmds.Commands.main(Commands.java:91)
              ... 5 more
      Can anybody help? I have no clue what is going on here.


      Edit: I solved the problem by executing the "java -jar apex.war" command in a DOS box (I had previously tried to do it in cygwin).

      Edited by: 942375 on Mar 10, 2013 6:50 PM