This discussion is archived
5 Replies Latest reply: Mar 14, 2013 8:08 AM by 996404 RSS

Is there a way to determine if any installed Win programs require the JRE?

996404 Newbie
Currently Being Moderated
Re: Is there a way to determine if any installed Win programs require the JRE?


Hi,

I have two newbie JRE questions if I may:

1) Is there a way to determine if any currently (or previously) installed programs require the JRE? Here's why I ask:

I have a Windows 2003 server where Add/Remove Programs shows "Java 2 Runtime Environment Standard Edition v1.3" is installed. I recently replaced the old APC UPS (ie. battery backup) with a new APC unit. The old unit was just using the native Windows Server UPS management utility. The new UPS monitoring software says that it requires "the bundled Java version JRE 1.6 Update 37. Support for JRE 7 Update 13 has also been verified."

So I'm wondering if I can tell if there's some currently installed Windows software that specifically needs the existing installed JRE v1.3.

2) This all leads me to wonder, why would the UPS vendor now bundle "Java version JRE 1.6 Update 37" with their software, if "... Support for JRE 7 Update 13" has also been verified ? (Btw, I realize that as of today JRE 7 update 17 is available).

I appreciate your experience and assistance on these two JRE topics.

Regards,
Bret

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points