6 Replies Latest reply: Mar 14, 2013 1:37 PM by user007009 RSS

    OBIEE on 64 bit Windows 7 ??  Why harder than Cognos, Qlikview and Tableau?

      Hi --- Can you please elaborate this in detail..I am having issues while Installing OBIEE 11g version on 64 bit windows-7..
      Can you please provide set by step instructions with screenshots(if possible). I tried all the websites available... but still having issues and it is consuming a lot of time...
      I Downloaded...
      Version for Java----> and the Path of the Folder is c:\java
      java version "1.7.0_10"
      Java(TM) SE Runtime Environment (build 1.7.0_10-b18)
      Java HotSpot(TM) 64-Bit Server VM (build 23.6-b04, mixed mode)
      ---> Can you please keep us posted of the Environment Variables that we need to take care of on the Windows 7 machines. All the variables related to Temp Folders, Java and Others that were needed.

      WebLogic Version Downloaded from OTN:::::_
      Path of Temp Folder_
      OBIEE Version Downloaded:::_
      bi_windows_x86_111160_64_disk1_1of2 ----> Basically version for Windows 64 bit.

      Steps Followed::::
      I installed the ofm_rcu_win_11. ---> Basically the 64 bit version.
      Installed the Loopback adapter:::_
      ---> In the hosts file i had only one line added (rest of the file is commented). computername ---> where computername is the name of the computer.
      Installed and Configured the OBIEE_
      Installation fine with out errors and i did Software only Installation(the last option)...
      While Cofiguring, it stuck up at the first step ... configuring Domain... Tried 10000000 times... and when checked the log file, showing the below message...

      [2011-07-01T12:00:23.500+05:30] [as] [NOTIFICATION] [] [oracle.as.install.bi] [tid: 24] [ecid: 0000J3^OytODwWWFLzrI8A1E3LWh00000F,0] Found listening port from node manager properties: null
      [2011-07-01T12:00:23.500+05:30] [as] [NOTIFICATION] [] [oracle.as.install.bi] [tid: 24] [ecid: 0000J3^OytODwWWFLzrI8A1E3LWh00000F,0] Unable to reuse node manager - port is null
      [2011-07-01T12:00:23.500+05:30] [as] [NOTIFICATION] [] [oracle.as.install.bi] [tid: 24] [ecid: 0000J3^OytODwWWFLzrI8A1E3LWh00000F,0] No reusable node manager found.
      [2011-07-01T12:00:23.500+05:30] [as] [NOTIFICATION] [] [oracle.as.install.bi] [tid: 24] [ecid: 0000J3^OytODwWWFLzrI8A1E3LWh00000F,0] Completed initial node manager configuration.
      [2011-07-01T12:00:23.500+05:30] [as] [NOTIFICATION] [] [oracle.as.install.bi] [tid: 24] [ecid: 0000J3^OytODwWWFLzrI8A1E3LWh00000F,0] Assigning Port: 9556 to: NODE_MANAGER_PORT
      I had previously installed Cognos, Tableau and QlikView... by far this is the one that took a very long time, even to download the files , installing and configuring...
      Please let me know your thoughts.. Thanks a lot for your time.. please don't refer your individual sites or blogs to follow the installation.. as i already did followed most of them i found after googling... and some of them dont even point to the exact versions they were downloading....
        • 1. Re: OBIEE on 64 bit Windows 7 ??  Why harder than Cognos, Qlikview and Tableau?
          Sasi  Nagireddy
          Try installing loop back adapter.

          • 2. Re: OBIEE on 64 bit Windows 7 ??  Why harder than Cognos, Qlikview and Tableau?
            Sasi  Nagireddy
            And also check the url to remove the enviornment variable


            • 3. Re: OBIEE on 64 bit Windows 7 ??  Why harder than Cognos, Qlikview and Tableau?
              Hi --- I already installed Loopback adapter and i dont see any "classpath" variable in "Environment variables".

              I did see "Class" Environment Variable and below was it's value...

              C:\oraclexe\app\oracle\product\11.2.0\server\bin;;C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;c:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;C:\Program Files (x86)\Windows Live\Shared;C:\Program Files (x86)\Universal Extractor;C:\Program Files (x86)\Universal Extractor\bin;c:\OBIEE11g\Oracle_BI1\products\Essbase\EssbaseServer\bin;c:\OBIEE11g\Oracle_BI1\bin;c:\OBIEE11g\Oracle_BI1\opmn\bin;c:\OBIEE11g\Oracle_BI1\opmn\lib;c:\OBIEE11g\Oracle_BI1\perl\bin;C:\Program Files\Java\jdk1.7.0_10\bin;C:\Oracle\Middleware\Oracle_BI1\products\Essbase\EssbaseServer\bin;C:\Oracle\Middleware\Oracle_BI1\bin;C:\Oracle\Middleware\Oracle_BI1\opmn\bin;C:\Oracle\Middleware\Oracle_BI1\opmn\lib;C:\Oracle\Middleware\Oracle_BI1\perl\bin

              Can you please confirm for the hosts file below value is correct or not?

              Were you able to successfully install obiee on 64 bit?? If so, can you please provide the steps that you follow...
              • 4. Re: OBIEE on 64 bit Windows 7 ??  Why harder than Cognos, Qlikview and Tableau?

                Try the following for installation with screens :

                Instal: http://obieeelegant.blogspot.com/2011/09/obiee-11g-111150-software-only.html


                Troubleshooting your error:

                OBIEE 11g installation - Configuration Process failed
                OBIEE 11G Create Domain Faild

                Oracle Documentation : http://docs.oracle.com/cd/E14571_01/bi.htm

                De-installation : http://oraclebisolutions.blogspot.com/2013/01/obiee-11g-deinstall-from-windows764-bit.html

                - Install with Windows User Account you use is ‘Administrator’ account type.

                - While installing the database or OBIEE11g, make sure the folder you plan to install does not have any ‘white spaces’ in the name as it may throw errors during installation( java cannot handle space :)).

                - Install the Microsoft Loop back Adapter, follow the post below :


                Hope you get it install it this time. Else post your errors for troubleshooting.

                Mark if helps.!

                • 5. Re: OBIEE on 64 bit Windows 7 ??  Why harder than Cognos, Qlikview and Tableau?
                  user007009 wrote:

                  Were you able to successfully install obiee on 64 bit??
                  Yes it is installable on Windows 7 64 Bit :)
                  • 6. Re: OBIEE on 64 bit Windows 7 ??  Why harder than Cognos, Qlikview and Tableau?
                    Hi Guys -- Am finally able to install OBIEE11g...
                    Provided in the link were the pre-requisites that you need to make 100% sure for windows 7 64 bit install.
                    Coming to the Issues I made...
                    For Enterprise Edition Installation (Option 2 in the graphical user interface installation screen)*
                    1.) I had "jdk1.7.0_10" installed in "C:\Java" folder.
                    When trying to install OBIEE 11.1 it install weblogic version "10.3.5" as this is not compatible with "jdk1.7.0_10" had Issues.
                    For Software Only Install*
                    1.) I had to download and install "wls1036_generic.jar" from OTN.
                    You need to make sure that you install it by following the below steps but not just by double clicking it... because it is doing a kind of 32 bit installation when double clicking (yaa that's strange) even though you were expecting an 64 bit.
                    a.) open command prompt
                    b.) go to the folder where "java -jar wls1036_generic.jar" was installed
                    c.) Then run "java -jar wls1036_generic.jar"
                    Other Issues*
                    1.) Turn off Windows fire wall during Installation.
                    2.) Uninstall Antivirus
                    Not sure about the credibility of the above two points, came across some websites am tired of trying all the options and at one point.. I turned them off and never turned them back on...
                    Source*:::: Various Websites based on the different errors and mix matching the Info, trying different options to solve an error/Issue.
                    Hope this is helpful to someone..... I Still say the Installation is not as straight forward as other BI Tools in the market.