This discussion is archived
1 Reply Latest reply: Mar 15, 2013 6:12 AM by 818043 RSS

Errors "The installed product does not match the installation source(s)"

818043 Newbie
Currently Being Moderated
I have Java SE 6u30 32-bit installed on my Windows 7 SP1 64-bit home desktop. I am the only account on the computer. I downloaded and ran the install for Java 6u33 and got the message "The installed product does not match the installation sources(s). Until a matching source is provided or the installed product and source are synchronized, this action can not be performed. Contact your system administrator or product vendor for assistance. If there is a matching installation source, type it below or click Browse to locate it." The Use Source box in the message points to C:\users\username\AppData\LocalLow\Sun\Java.....

Why would I get this message just by running the installation for a newly-downloaded version of Java (downloaded from the Oracle site)? I then tried installing 6u35
with no luck.

Additional error messages which came after the initial one (first paragraph above) include:
"The path C:\users\username\AppData\LocalLow\Sun\jre 1.6.0_18\jre 1.6.0_18.msi" cannot be found. Verify that you have access to this location and try again, or try to find the installation package jre 1.6.0_18.msi in a folder from which you can install the product Java(TM) 6 Update 30."

This is quite strange, since the title of the message box is "Java(TM) 6 Update 35", the message refers to the Java 6 update 18 MSI (Java 6u18 iis not installed on my computer), and also refers to installing Java 6u30, so there are 3 update versions of Java being referenced in the same error!!

After clicking OK on the above error, a Java Setup error box comes up with the wording "Error 1714. The older version of Java(TM) 6 Update 35 cannot be removed. Contact your technical support group." This is puzzling since Java 6u35 is not installed on my computer. The installation failed as described above.

The above was followed by another Java Setup message "Installation Failed. The wizard was interrupted..."

I tried uninstalling Java 6u30 and got a similar error.

So in short, I am unable to uninstall the only version of Java (6u30) that I have on my computer, and I am unable to install any new versions.

Any help you could provide would be greatly appreciated!

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points