4 Replies Latest reply: May 27, 2013 3:42 AM by Nir RSS

    soainfra is not coming up

    karthiksingh_dba
      Dear Legends,

      Please help me on bringing up the soainfra

      Environment Details
      OS : OEL 5.8 64bit
      WEBLOGIC : 10.3.6
      SOA : 11.1.1.6
      RCU : 11.1.1.6
      DB : 11gR2 RAC

      1 Adminserver
      2 Managedservers - soa_server1 and soa_server2

      Errors so for
      ========
      <Mar 14, 2013 1:37:15 AM EDT> <Error> <Deployer> <BEA-149231> <Unable to set the activation state to true for the application 'soa-infra'.
      weblogic.application.ModuleException: Exception activating module: EJBModule(oracle.bpm.runtime.bpmn-engine-ejb.jar)

      Unable to deploy EJB: BPMNServerManagerBean from oracle.bpm.runtime.bpmn-engine-ejb.jar:

      Error deploying BPEL suitcase.
      error while attempting to deploy the BPEL component file "/u01/app/wsoat/FMW_111/user_projects/domains/wsoatDomain/servers/soa_server2/dc/soa_ab761886-d0ca-4d6d-8e00-34f56009fb8e"; the exception reported is: oracle.mds.exception.MDSException: MDS-00054: The file to be loaded oramds:/deployed-composites/default/test2_rev1.1/xsd/DB_testtimeout_sp.xsd does not exist.

      Startup Error on soa-infra
      ==========================
      Invoking Start Up operation for application soa-infra on target soa_server2.
      [Deployer:149193]Operation 'start' on application 'soa-infra' has failed on 'soa_server2'
      [Deployer:149034]An exception occurred for task [Deployer:149026]start application soa-infra on soa_server2.: Exception preparing module: EJBModule(oracle.bpm.runtime.bpmn-engine-ejb.jar)


      Unable to deploy EJB: InternalInstanceManagementServiceBean from oracle.bpm.runtime.bpmn-engine-ejb.jar:

      [EJB:011055]Error deploying the EJB 'InternalInstanceManagementServiceBean(Application: soa-infra, EJBComponent: oracle.bpm.runtime.bpmn-engine-ejb.jar)', the JNDI name 'InternalInstanceManagementService#oracle.bpm.bpmn.engine.instancemanagement.ejb.IInternalInstanceManagementServiceRemote' is already in use. You must set a different JNDI name in the weblogic-ejb-jar.xml deployment descriptor or corresponding annotation for this EJB before it can be deployed.

      Operation Start Up on target soa-infra Failed. Please see error logs for details.

      Error3
      ======
      weblogic.jms.common.JMSException: could not find Server soa_server1
      Nested exception: weblogic.jms.common.JMSException: could not find Server soa_server1
      Nested exception: weblogic.jms.common.JMSException: could not find Server soa_server1
      Nested exception: weblogic.jms.common.JMSException: could not find Server soa_server1
      Nested exception: weblogic.messaging.dispatcher.DispatcherException: could not find Server soa_server1

      Error4
      =====
      <Failed to deserialize statedump from server -7973665538765164622S:

      We tried restarting managed servers only, but from the deployments if we undeploy the soainfra we have the servers 100%, but again tried to redeploy it only 1 managed server is up and soa_server2 is not available in EM. Whereas in console it shows both MS's are running.

      Regards,
      Karthik
        • 1. Re: soainfra is not coming up
          Nir
          Hi karthiksingh_dba ,

          Were you able to find the solution for this.
          facing to the same issue which is soa-infra not coming up.


          *An exception occurred for task [Deployer:149026]start application soa-infra on soa_server2.: Exception preparing module: EJBModule(oracle.bpm.runtime.bpmn-engine-ejb.jar)*
          Unable to deploy EJB: InternalInstanceManagementServiceBean from oracle.bpm.runtime.bpmn-engine-ejb.jar:
          *[EJB:011055]Error deploying the EJB 'InternalInstanceManagementServiceBean(Application: soa-infra, EJBComponent: oracle.bpm.runtime.bpmn-engine-ejb.jar)'*

          Please share if you found the answer..

          Thanks,
          Nir
          • 2. Re: soainfra is not coming up
            karthiksingh_dba
            Hi,

            I tried

            stop the servers and
            remove cache files for Admin server from $ORACLE_HOME/user_projects/domains/base_domain/servers/AdminServer/cache
            remove cache files for SOA server from $ORACLE_HOME/user_projects/domains/base_domain/servers/soa_server1/cache
            remove tmp files for Admin server from$ORACLE_HOME/user_projects/domains/base_domain/servers/AdminServer/tmp
            remove tmp files for SOA server from$ORACLE_HOME/user_projects/domains/base_domain/servers/soa_server1/tmp
            NOTE: Do this for each node of your SOA cluster if you are running in cluster mode
            start admin server
            start node manager
            start soa_server

            after this I faced the same error, the I re-deployed the soainfra.

            Thanks,
            Karthik
            • 3. Re: soainfra is not coming up
              karthiksingh_dba
              Issue Resolved.
              • 4. Re: soainfra is not coming up
                Nir
                Hi karthiksingh_dba ,

                Thanks a lot for your update.....

                This issue happens to only one of the node in our cluster.

                Cluster is having soa_server1 and soa_server2.
                Issue happens only to soa_server2 node.

                I have deleted tmp and the cache directories.

                As you told i need to redeploy the soa-infra since it did not work. When I redeploy will it effect to soa_server1 also?? how can I make changes to soa_server2 only???

                Because this is our live environment...

                Thank You,
                Nir