This discussion is archived
9 Replies Latest reply: Mar 30, 2013 8:56 PM by FabioDouek RSS

Performance of Clustered Managed Servers

jmft2012 Explorer
Currently Being Moderated
WLS 10.3.5 on Solaris10

we have the clustered weblogic10.3.5 domain with two managed servers, which a web app deployed.
we use proxy server (an ohs server) as the frontend host.
we tested for the app login, if both managed servers are started, the login takes about 2 mins.
however if only one managed server is started, the login only takes less 1/2 min.

There is no problem to support two managed servers in the ram and cpu on the server

Why?
where should we start to look into the issue?
  • 1. Re: Performance of Clustered Managed Servers
    FabioDouek Journeyer
    Currently Being Moderated
    Hi,

    Most likely the java processes are running in the swap area.
    How much available RAM do you have in your server? Are you running linux or windows? How much RAM is the JAVA process allocating?


    Regards,
    Fabio Douek
  • 2. Re: Performance of Clustered Managed Servers
    jmft2012 Explorer
    Currently Being Moderated
    On Solaris 10 64-bit, java 6u 35
    RAM 4GB for each managed server.
  • 3. Re: Performance of Clustered Managed Servers
    jmft2012 Explorer
    Currently Being Moderated
    I think something may do with the clustering setup or configurations which I am kind new to.
    Hope some one could make the comments.
  • 4. Re: Performance of Clustered Managed Servers
    FabioDouek Journeyer
    Currently Being Moderated
    It could be the cluster config. However, before going in this path, we should make sure first that is not related to the process being in the swap area.
    You replied with the info about the memory allocation per managed server which is fine.
    How much RAM do you have in that server? How much is available and how much of the swap area is being used?

    Regards,
    Fabio Douek
  • 5. Re: Performance of Clustered Managed Servers
    jmft2012 Explorer
    Currently Being Moderated
    How much RAM do you have in that server? How much is available and how much of the swap area is being used?

    Regards,
    Fabio Douek
    load averages:  7.36,  7.32,  8.29                                                                           02:25:10
    52 processes:  50 sleeping, 2 on cpu
    CPU states: 83.6% idle,  5.9% user, 10.4% kernel,  0.0% iowait,  0.0% swap
    Memory: 256G real, 7279M free, 71G swap in use, 185G swap free
    
       PID USERNAME LWP PRI NICE  SIZE   RES STATE    TIME    CPU COMMAND
      4121 oracle   212   3    4    0K    0K cpu/59  98.5H  1.57% java
     10037 oracle   178  59    4    0K    0K sleep    6:03  0.01% java
      3139 root      18  59    0  103M   94M sleep  701:56  0.01% cma
      5288 oracle   182  59    4    0K    0K sleep    7:05  0.01% java
     10433 oracle   180  59    4    0K    0K sleep    2:20  0.01% java
     17816 oracle     1  59    0   11M 5176K cpu/60   0:00  0.01% top
  • 6. Re: Performance of Clustered Managed Servers
    FabioDouek Journeyer
    Currently Being Moderated
    Hi,

    According to the info you sent, there are 71GB of swap area in use and 7GB of real memory free.
    This is not conclusive, as we don't know what is in the swap area. It could be part or the entire JVM for your application. Also, we have to take into consideration shared memory.

    I believe you are running many applications in that server, and possible multiple environments.

    In order to avoid spending too much time investigating other config issues that might not exist, I think you should try to eliminate the swap to see if this is the issue. I believe that this could be the main issue, based on the info I have so far.

    Would be possible for you to stop all or some of the applications running in that server? Then you should check the available RAM (make sure that there are at least 10GB available before starting both managed servers) and restart both managed servers which you have your application running.

    Regarding the response times for the login, does it always take the same time to login? You mentioned about 30 seconds, this also seems very high to me. Are your discarding the first login after the server restart? Depending on which framework you are using, it might be interpreting some artifacts or compiling the JSPs in the first execution.

    Regards,
    Fabio Douek
  • 7. Re: Performance of Clustered Managed Servers
    FabioDouek Journeyer
    Currently Being Moderated
    Hi,

    Did you make any progress on this?

    Regards,
    Fabio Douek
  • 8. Re: Performance of Clustered Managed Servers
    jmft2012 Explorer
    Currently Being Moderated
    Fabio Douek wrote:
    Hi,

    Did you make any progress on this?

    Regards,
    Fabio Douek
    Thanks for your following up this.

    Via a ticket I have asked the SA in the org which hosting the zones for the specific context of TOP of this solaris10 zone.
    I have not heard from him back yet.

    We have about 15 zones on one realm in the Solaris10. I was told all zones are sharing the same resources -CPU, RAM and etc.

    I doubt the 7.2GB RAM shown was the free left for the zones. Because I have made a few new Oracle DB installations in the zones of the realm, those are allocating more than 10 GB RAM.
    But the TOP showing the 7.2GB free has been never changed from all the zones.
    load averages:  7.36,  7.32,  8.29                                                                           02:25:10
    52 processes:  50 sleeping, 2 on cpu
    CPU states: 83.6% idle,  5.9% user, 10.4% kernel,  0.0% iowait,  0.0% swap
    Memory: 256G real, 7279M free, 71G swap in use, 185G swap free
     
  • 9. Re: Performance of Clustered Managed Servers
    FabioDouek Journeyer
    Currently Being Moderated
    OK, let me know how it goes.

    Regards,
    Fabio.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points