6 Replies Latest reply on Mar 27, 2013 2:32 AM by 653697

    JMS bridges are going to WARN/FAILED state

      Hi Experts,

      We have 2 different weblogic domains(say domain-1,domain-2) configured on weblogic9.2_mp3 version.
      When there are X(let's say some 70) number of bridges in domain-1, there are no issue.
      But when there are some X+Y(let's say some 50) bridges in domain-1, some of the bridges in domain-1 are going to WARNING: WILL RECONNECT LATER, INACTIVE, WARNING: Unable to connect etc states. In the above states the messages are not being forwarded to the target.

      Now the pointers I am looking for are:

      1. Is there any count(like connection factory, threads etc) in domain-1 which should match with number of bridges?
      2. Why there is no issue when no. of bridges are less, why there is issue when number of bridges are more?
      3. If we bounce env, some of the bridges will become ACTIVE BUT NOT ALL & we cannot afford bounce to resolve this.
      4. What is the best way to fix this out? Like jms-xa-adapter, work-manager, applying some patch etc ?

      NOTE: All bridges are configured properly with reachable & existing source/target destinations.

      Thanks in advance.

      Edited by: 994778 on Mar 19, 2013 7:11 AM
        • 1. Re: JMS bridges are going to WARN/FAILED state
          You may find some helpful information in the messaging bridge tuning guide.
          • 2. Re: JMS bridges are going to WARN/FAILED state
            Thanks Dongbo for the reply, the link was useful.

            Can you also tell me, is there any factor like number of threads or connections that should be more than(or equal to) number of bridges in a domain?

            What I am wondering about was, when there are less number of bridges, there is no issue with bridges. But when there are more number of bridges, some bridges are failing to connect, ending up in WARNING/FAILED state.

            Waiting for reply !! :)
            • 3. Re: JMS bridges are going to WARN/FAILED state
              One thing you can try is to increase the max-capacity of the bridge adapter that you are using, say jms-notran-adp.rar or jms-xa-adp.rar. They are usually located in the server/lib dir under your WLS installation directory.

              The pre-packaged settings are something like:

              You can try a higher max-capacity based on the number of the bridge that you have. Here are the instructions of doing this.

              If the problem persists, you can turn on bridge debugging to see the cause of the connection failure.


              Edited by: Dongbo on Mar 25, 2013 9:36 AM
              • 4. Re: JMS bridges are going to WARN/FAILED state
                Another thing to look into is to tune the work manager for the bridge. The details can be found in the tuning guide.
                • 5. Re: JMS bridges are going to WARN/FAILED state
                  Thanks a lot Dangbo.

                  Can you also please share some pointer on "Configuring a work manager for the weblogic.jms.MessagingBridge class" to let the workmanager dedicatedly work for Messaging-Bridges. We are not finding enough info in tuning guide.

                  • 6. Re: JMS bridges are going to WARN/FAILED state
                    The following link contains information about work manager.

                    The name of the work manager used by the bridge is "weblogic.jms.MessagingBridge". For example, you can tune the Min Threads Constraint and Max Threads Constraint of this work manager.

                    Edited by: Dongbo on Mar 26, 2013 7:31 PM