This discussion is archived
3 Replies Latest reply: Mar 21, 2013 6:02 AM by user12273962 RSS

PVM OL6 kickstart install challenges on Oracle VM 3.1.1.544

Roddy Rodstein Explorer
Currently Being Moderated
Thank you all in advance for your support!

Environment:
Oracle VM 3.1.1.544 patched
4 Dell M610's, 1 with Oracle VM Manager (4 NICS, 2 active, eth3/private and eth0/public), 3 Oracle VM servers (4 NICS, 2 bonds w 802.1q VLANS, 3 private non routable management (management, heartbeat, live migration) VLANs on bond0 and 4 public routable VLANs for VMs on bond1.
The dom0s are on private non routable networks accessible via an interface on the private management network channel on the oracle vm manager host.
The dom0s have no access to public networks.
We have multiple web servers with kickstart files and installation trees on multiple public networks to support OL 5.8 and 6.2 kickstart installs.

Requirement:
Use existing Linux kickstart process (customer has been running RHEL for years), i.e. use existing web servers with kickstart files (with slight modifications for ovm) and install trees for Oracle Linux installs on Oracle VM. Customer is new to OVM.

Challenge:
We create a OL 6.2 VM in Oracle VM Manager and have tried the following settings in the "Boot Order → Network Boot Path":
Please note that the 10.2.x.x addresses are on a public network and the 192.168.x.x address is on a private network. The public networks are accessible by domUs and web servers with ks/install trees, not by dom0s.
Dom0:
/usr/bin/xenpvboot http://192.168.x.x/ks/oel62/ kernel=isolinux ramdisk=isolinux --args="http://192.168.x.x/ks/ol62.ks ip 10.2.x.x netmask 255.255.0.0 gateway 10.2.x.x nameserver 10.2.x.x,10.3.x.x hostname ol62test.ovm.com"
The above command generates a clean response, i.e. no errors.
DomU - Boot Order → Network Boot Path:
--args ks=http://192.168.x.x/ks/ol62.ks http://192.168.x.x/ks/oel62
The result from the above example is that the VM boots and then stops on the network manager screen. We view other ttys and see that eth0 is unable to start.

DomU - Boot Order → Network Boot Path:
--args= http://10.2.x.x/stage/ol62test.ks http://192.168.x.x/ks/oel62/

DomU - Boot Order → Network Boot Path:
http://192.168.x.x/ks/oel62/ --args="http://10.2.x.x/stage/ol62test.ks ip 10.2.x.x netmask 255.255.0.0 gateway 10.2x.x.x nameserver 10.2.x.x,10.4.x.x hostname ol62test.ovm.com"
The results from the above two examples is that the VM boots but the ks file does no invoke. The httpd access logs show the boot process and do not show the ks file being accessed.

Questions:
1. Could you please help confirm the PVM kickstart workflow between the dom0 (private) and domU (public).
1. For example, could you please help confirm the following?:
2. step 1 – start a VM with Boot Order → Network Boot Path: --args ks=http://192.168.x.x/ks/ol62.ks http://192.168.x.x/ks/oel62
3. dom0 accesses the install tree via the server management network channel, i.e. http://192.168.x.x/ks/oel62/ and boots the VM
4. domU gets an IP from either a) –args in “ Boot Order → Network Boot Path” or b) from a kickstart file
5. all good and hit the pub :-)

Thank you again for your support!
  • 1. Re: PVM OL6 kickstart install challenges on Oracle VM 3.1.1.544
    user12273962 Pro
    Currently Being Moderated
    2. I can confirm this works with PVM guests. I don't run OL 6 so I can't confirm 6. OL5 is rock solid when it comes to oracle products.

    --args ks=http://ipaddress/test/ks.cfg http://ipaddressofhttpserver/distrubutioniso/

    4. I always set a static DHCP mapping for the MAC for the VM guest. I never try passing the ip on the boot line. If I were to do it... I would try adding ksdevice=eth0 and then ip params.

    The /distrubutioniso/ only gives you the boot files to boot the VM guest. The ks= value serves the kickstart file/script which then details the mount point for the distribution to load.

    You should list /distubutioniso/ last. Not before the --args. At least that is the way I've always done it.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                       
  • 2. Re: PVM OL6 kickstart install challenges on Oracle VM 3.1.1.544
    Roddy Rodstein Explorer
    Currently Being Moderated
    user12273962,

    Thank you for your help!

    No love with all further attempts.

    We need to install tcpdump on our dom0s to track down the root cause.

    We opened an SR a couple days ago, no response :-)

    Thanks again for your assistance!
  • 3. Re: PVM OL6 kickstart install challenges on Oracle VM 3.1.1.544
    user12273962 Pro
    Currently Being Moderated
    Forget to mention that I've seen multi nic servers... that serve the distribution iso.... act weird when receiving requests from a subnet interface that does not have the default route defined on that specific interface. Make sure you're hitting the http server with the iso interface that has the default route or define "strict" routing ( at least what it use to be called in Unix) so what interface receives the request will actually be the one that responds. Or the return will be sent over the nic with the default route. I've seen that confuse the boot process in Oracle VM. At least the way the manger handles the request being passed to the VM server.

    Good luck on the SR. I had one open for two months for a PXE installation issue and finally just gave up. It was an issue related to a server with certain processor model and # of cores. I had the exact server model with a different model CPU with less core that worked perfect.

    Edited by: user12273962 on Mar 21, 2013 6:01 AM

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points