3 Replies Latest reply: Mar 21, 2013 12:50 PM by Alan.S-Oracle RSS

    pkg: Unable to clone the current boot environment.

    997963
      I am trying to upgrade solaris 11 to solaris 11 SRU1, but face below error:
      pkg: Unable to clone the current boot environment.

      Anyone can help? Thanks a lot in advance!
      +++++++++++++++++++++++++++++++++++++++++++++++++++++++
      root@SGH26-H7:/snow# lofiadm -a sol-11-1111-sru1-incr-repo.iso
      /dev/lofi/1
      root@SGH26-H7:/snow# mount /dev/lofi/1 /snow/powerpath
      mount: /dev/lofi/1 is not this fstype
      root@SGH26-H7:/snow# mount -F hsfs /dev/lofi/1 /snow/powerpath
      root@SGH26-H7:/snow# pkg unset-publisher solaris
      root@SGH26-H7:/snow# pkg set-publisher -G '*' -g file:///snow/powerpath/repo solaris
      root@SGH26-H7:/snow# pkg publisher
      PUBLISHER TYPE STATUS URI
      solaris origin online file:///snow/powerpath/repo/
      root@SGH26-H7:/snow# pkg update
      Packages to update: 13
      Create boot environment: Yes
      Create backup boot environment: No

      DOWNLOAD PKGS FILES XFER (MB)
      Completed 13/13 350/350 13.2/13.2

      pkg: Unable to clone the current boot environment.

      root@SGH26-H7:/snow# pkg info entire
      Name: entire
      Summary: Incorporation to lock all system packages to the same build
      Description: This package constrains system package versions to the same
      build. WARNING: Proper system update and correct package
      selection depend on the presence of this incorporation.
      Removing this package will result in an unsupported system.
      Category: Meta Packages/Incorporations
      State: Installed
      Publisher: solaris
      Version: 0.5.11
      Build Release: 5.11
      Branch: 0.175.0.0.0.2.0
      Packaging Date: October 20, 2011 02:38:22 PM
      Size: 5.45 kB
      FMRI: pkg://solaris/entire@0.5.11,5.11-0.175.0.0.0.2.0:20111020T143822Z
      ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++