14 Replies Latest reply: Mar 31, 2013 7:08 AM by Srini Chavali-Oracle RSS

    How can i enable sql*plus  or isql*plus  in my virtaul machine

    972355
      Hello to all ;

      I am using oracle 10g on rhel 5 ( running on virtaul machine).
      How can i enable sqlplus or isql*plus in my virtaul machine ?*
      I have putty . Any other utilities (free tool ) available to access my database ?

      Thanks ..
        • 1. Re: How can i enable sql*plus  or isql*plus  in my virtaul machine
          Srini Chavali-Oracle
          iSQL*Plus has been obsoleted - try SQL Developer instead - http://www.oracle.com/technetwork/developer-tools/sql-developer/downloads/index.html

          HTH
          Srini
          • 2. Re: How can i enable sql*plus  or isql*plus  in my virtaul machine
            972355
            Hello Srini ;
            # rpm -Uhv sqldeveloper-3.2.20.09.87-1.noarch.rpm
            Preparing... ########################################### [100%]
            1:sqldeveloper ########################################### [100%]

            I can't proceed next step ..
            i am following given url
            http://www.ecuoug.org/?p=529
            • 3. Re: How can i enable sql*plus  or isql*plus  in my virtaul machine
              972355
              Good Morning Oracle mates ;

              I can't solve my problem (enabling sql developer tool ).

              Can anyone clarify this ?

              - JDK took is it required ?
              • 4. Re: How can i enable sql*plus  or isql*plus  in my virtaul machine
                Srini Chavali-Oracle
                Do you have a JDK installed ? Are you following the official install instructions ? http://www.oracle.com/technetwork/developer-tools/sql-developer/downloads/sqldevlinux-installnotes-1719934.html

                After you install the rpm, what happens when you execute sqldeveloper ?

                HTH
                Srini
                • 5. Re: How can i enable sql*plus  or isql*plus  in my virtaul machine
                  972355
                  Hello Srini ;

                  Getting Error

                  *# rpm -Uvh jdk-7u17-linux-i586\ \(1\).rpm*
                  Preparing... ########################################### [100%]
                  1:jdk ########################################### [100%]
                  Unpacking JAR files...
                  rt.jar...
                  Error: Could not open input file: /usr/java/jdk1.7.0_17/jre/lib/rt.pack
                  jsse.jar...
                  Error: Could not open input file: /usr/java/jdk1.7.0_17/jre/lib/jsse.pack
                  charsets.jar...
                  Error: Could not open input file: /usr/java/jdk1.7.0_17/jre/lib/charsets.pack
                  tools.jar...
                  Error: Could not open input file: /usr/java/jdk1.7.0_17/lib/tools.pack
                  localedata.jar...
                  Error: Could not open input file: /usr/java/jdk1.7.0_17/jre/lib/ext/localedata.pack
                  plugin.jar...
                  Error: Could not open input file: /usr/java/jdk1.7.0_17/jre/lib/plugin.pack
                  javaws.jar...
                  Error: Could not open input file: /usr/java/jdk1.7.0_17/jre/lib/javaws.pack
                  deploy.jar...
                  Error: Could not open input file: /usr/java/jdk1.7.0_17/jre/lib/deploy.pack

                  ************************************************************************
                  • 6. Re: How can i enable sql*plus  or isql*plus  in my virtaul machine
                    Srini Chavali-Oracle
                    Are you installing or upgrading JDK ? The rpm command differs for both these scenarios, as detailed in the Install Documentation - http://docs.oracle.com/javase/7/docs/webnotes/install/linux/linux-jdk.html

                    It is always best practice to read and understand install instructions before attempting anything ;-)

                    HTH
                    Srini
                    • 7. Re: How can i enable sql*plus  or isql*plus  in my virtaul machine
                      972355
                      # pwd
                      /mnt/hgfs/SHARE

                      # rpm -e jdk-7u17-linux-i586
                      error: package jdk-7u17-linux-i586 is not installed

                      [root@oel5 SHARE]# rpm -ivh jdk-7u17-linux-i586
                      Preparing... ########################################### [100%]
                      package jdk-1.7.0_17-fcs.i586 is already installed

                      [root@oel5 SHARE]# rpm -Uvh jdk-7u17-linux-i586
                      Preparing... ########################################### [100%]
                      package jdk-1.7.0_17-fcs.i586 is already installed

                      [root@oel5 SHARE]*# chmod a+x jdk-7u17-linux-i586*

                      [root@oel5 SHARE]*# ./jdk-7u17-linux-i586*
                      -bash: ./jdk-7u17-linux-i586: cannot execute binary file


                      I can't  identify exact problem . Could you please help me ?
                      • 8. Re: How can i enable sql*plus  or isql*plus  in my virtaul machine
                        972355
                        If my approach is incorrect ( installing jdk tool) please provide the right steps ?

                        - I did n't catch where was the problem ?

                        *[root@oel5 SHARE]# ./jdk-7u17-linux-i586*

                        -bash: ./jdk-7u17-linux-i586: cannot execute binary file
                        • 9. Re: How can i enable sql*plus  or isql*plus  in my virtaul machine
                          Srini Chavali-Oracle
                          Pl post a link to the document you are following for the install

                          HTH
                          Srini
                          • 10. Re: How can i enable sql*plus  or isql*plus  in my virtaul machine
                            972355
                            Last 10 days before i mentioned this url.
                            http://www.ecuoug.org/?p=529
                            Still i tried in many ways .. No more improvement !!
                            • 11. Re: How can i enable sql*plus  or isql*plus  in my virtaul machine
                              Srini Chavali-Oracle
                              Pl decide which method you want to use to install JDK - the rpm method (listed in the official Install documentation), or the self-extracting executable method (listed in the link you posted above) - these two methods are separate and distinct, and cannot be mixed. You are essentially trying to execute an rpm file, which is impossible

                              HTH
                              Srini
                              • 12. Re: How can i enable sql*plus  or isql*plus  in my virtaul machine
                                972355
                                HELLO SRINI ..

                                OFFICIAL DOCUMENT TOTALLY CONFUSING ME ..

                                I  did  following steps
                                removing installed rpms
                                # rpm -e sqldeveloper-3.2.20.09.87-1.noarch.rpm
                                error: package sqldeveloper-3.2.20.09.87-1.noarch.rpm is not installed
                                Installing sqldeveloper rpm
                                # rpm -ivh sqldeveloper-3.2.20.09.87-1.noarch.rpm
                                Preparing... ########################################### [100%]
                                package sqldeveloper-3.2.20.09.87-1.noarch is already installed
                                upgrading sqldeveloper rpm
                                [root@oel5 SHARE]# rpm -Uvh sqldeveloper-3.2.20.09.87-1.noarch.rpm
                                Preparing... ########################################### [100%]
                                package sqldeveloper-3.2.20.09.87-1.noarch is already installed
                                when listing after all operations - (nothing is there)
                                [root@oel5 SHARE]# ls -l
                                -rwxrwxrwx 1 root root 111831898 Mar 21 21:06 jdk-7u17-linux-i586.rpm
                                -rwxrwxrwx 1 root root 181667839 Mar 20 18:56 sqldeveloper-3.2.20.09.87-1.noarch.rpm
                                FROM THIS OFFICIAL URL ( GIVEN STEPS N'T WORKABLE )
                                http://www.oracle.com/technetwork/developer-tools/sql-developer/downloads/sqldevlinux-installnotes-1719934.html
                                http://docs.oracle.com/cd/E35137_01/doc.32/e35119/install.htm#CIHEDDJE


                                Also i am very tired to did this. Completly  9 hours  left  (not succeed)

                                Ok srini .. If you  did any  steps please provide it otherwise none !

                                Thanks ..

                                Edited by: 969352 on Mar 30, 2013 7:41 PM
                                • 13. Re: How can i enable sql*plus  or isql*plus  in my virtaul machine
                                  972355
                                  *[root@oel5 ~]# su - oracle*
                                  *[oracle@oel5 ~]$ sqldeveloper*

                                  Oracle SQL Developer
                                  Copyright (c) 1997, 2011, Oracle and/or its affiliates. All rights reserved.

                                  Xlib: connection to ":0.0" refused by server
                                  Xlib: No protocol specified

                                  java.lang.InternalError: Can't connect to X11 window server using ':0.0' as the value of the DISPLAY variable.
                                  at sun.awt.X11GraphicsEnvironment.initDisplay(Native Method)
                                  at sun.awt.X11GraphicsEnvironment.access$200(X11GraphicsEnvironment.java:65)
                                  at sun.awt.X11GraphicsEnvironment$1.run(X11GraphicsEnvironment.java:110)
                                  at java.security.AccessController.doPrivileged(Native Method)
                                  at sun.awt.X11GraphicsEnvironment.<clinit>(X11GraphicsEnvironment.java:74)
                                  at java.lang.Class.forName0(Native Method)
                                  at java.lang.Class.forName(Class.java:188)
                                  at java.awt.GraphicsEnvironment.createGE(GraphicsEnvironment.java:102)
                                  at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(GraphicsEnvironment.java:81)
                                  at java.awt.Window.initGC(Window.java:467)
                                  at java.awt.Window.init(Window.java:487)
                                  at java.awt.Window.<init>(Window.java:536)
                                  at java.awt.Frame.<init>(Frame.java:420)
                                  at javax.swing.JFrame.<init>(JFrame.java:224)
                                  at oracle.ide.IdeCore$StartupWindow.<init>(IdeCore.java:1960)
                                  at oracle.ide.IdeCore.startupImpl(IdeCore.java:1148)
                                  at oracle.ide.Ide.startup(Ide.java:703)
                                  at oracle.ideimpl.DefaultIdeStarter.startIde(DefaultIdeStarter.java:35)
                                  at oracle.ideimpl.Main.start(Main.java:184)
                                  at oracle.ideimpl.Main.main(Main.java:146)
                                  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                                  at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
                                  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
                                  at java.lang.reflect.Method.invoke(Method.java:601)
                                  at oracle.ide.boot.PCLMain.callMain(PCLMain.java:62)
                                  at oracle.ide.boot.PCLMain.main(PCLMain.java:54)
                                  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                                  at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
                                  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
                                  at java.lang.reflect.Method.invoke(Method.java:601)
                                  at oracle.classloader.util.MainClass.invoke(MainClass.java:128)
                                  at oracle.ide.boot.IdeLauncher.bootClassLoadersAndMain(IdeLauncher.java:189)
                                  at oracle.ide.boot.IdeLauncher.launchImpl(IdeLauncher.java:89)
                                  at oracle.ide.boot.IdeLauncher.launch(IdeLauncher.java:65)
                                  at oracle.ide.boot.IdeLauncher.main(IdeLauncher.java:54)
                                  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                                  at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
                                  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
                                  at java.lang.reflect.Method.invoke(Method.java:601)
                                  at oracle.ide.boot.Launcher.invokeMain(Launcher.java:713)
                                  at oracle.ide.boot.Launcher.launchImpl(Launcher.java:115)
                                  at oracle.ide.boot.Launcher.launch(Launcher.java:68)
                                  at oracle.ide.boot.Launcher.main(Launcher.java:57)

                                  Error: SQL Developer can't recognize the JDK version

                                  # env
                                  SSH_AGENT_PID=3998
                                  HOSTNAME=oel5.myserver
                                  DESKTOP_STARTUP_ID=
                                  TERM=xterm
                                  SHELL=/bin/bash
                                  HISTSIZE=1000
                                  GTK_RC_FILES=/etc/gtk/gtkrc:/root/.gtkrc-1.2-gnome2
                                  WINDOWID=24162053
                                  USER=root
                                  LS_COLORS=no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;35:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:
                                  GNOME_KEYRING_SOCKET=/tmp/keyring-HwItSL/socket
                                  SSH_AUTH_SOCK=/tmp/ssh-aefsay3959/agent.3959
                                  SESSION_MANAGER=local/oel5.myserver:/tmp/.ICE-unix/3959
                                  MAIL=/var/spool/mail/root
                                  PATH=/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin
                                  DESKTOP_SESSION=default
                                  GDM_XSERVER_LOCATION=local
                                  INPUTRC=/etc/inputrc
                                  PWD=/root
                                  XMODIFIERS=@im=none
                                  LANG=en_US.UTF-8
                                  GDMSESSION=default
                                  SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
                                  SHLVL=2
                                  HOME=/root
                                  GNOME_DESKTOP_SESSION_ID=Default
                                  LOGNAME=root
                                  CVS_RSH=ssh
                                  DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-Nf9CuFQGCr,guid=aefd372bbfaf4c4200b4c10051579444
                                  LESSOPEN=|/usr/bin/lesspipe.sh %s
                                  DISPLAY=:0.0
                                  G_BROKEN_FILENAMES=1
                                  COLORTERM=gnome-terminal
                                  XAUTHORITY=/tmp/.gdmT0UKUW
                                  _=/bin/env
                                  • 14. Re: How can i enable sql*plus  or isql*plus  in my virtaul machine
                                    Srini Chavali-Oracle
                                    I have moved this thread to the SQL Developer forum, as it is more relevant here.

                                    The SQL Developer install guide states that you need to install JDK 1.6.x - http://docs.oracle.com/cd/E35137_01/doc.32/e35119/install.htm#CIHCHECD

                                    As stated before, you need to read and understand all installation instructions before attempting to install anything.

                                    So uninstall JDK 1.7.x that you installed, then reinstall JDK 1.6.x as per the above link, then try again

                                    HTH
                                    Srini