13 Replies Latest reply: Apr 23, 2013 8:49 AM by 772286 Branched to a new discussion. RSS

    ORA-01034 , ORA-27101 in windows Domain

    772286
      Hi to everyone, I have a problem with the Oracle 11g express edition.

      My pc belongs to a windows Domain, I log in in Windows PC using an acount for that domain. I installed Oracle 11g express edition x86 in a windows 7 (32 bits) in the localhost, I modiffied the : sqlnet.ora file as bellow :
      SQLNET.AUTHENTICATION_SERVICES=(NONE)
      when I try connect to sqlplus , it show me the following message :
      http://www.subirimagenes.net/i/130320111734420433.png
      Too the oracle's http server is not working in the localhost

      What am I doing wrong ?

      Thanks in advance :D
        • 1. Re: ORA-01034 , ORA-27101 in windows Domain
          TSharma-Oracle
          Seems like your database is not up and running
          Check your oracle service. If it's stopped...start it.
          set oracle_sid=<your sid>
          Start your database.
          • 2. Re: ORA-01034 , ORA-27101 in windows Domain
            Srini Chavali-Oracle
            Looks like your database is not running. Have you verified that that install was successful and that there were no errors in the install log file ? What exact version of Win 7 ?

            http://docs.oracle.com/cd/E17781_01/install.112/e18803/toc.htm#CIHHJEHF (Check Step 12 for log file name)

            If the install was successful without any errors, then you will need to start up the database

            http://docs.oracle.com/cd/E17781_01/install.112/e18803/toc.htm#CIHBCFDD
            http://docs.oracle.com/cd/E17781_01/server.112/e18804/startup.htm#CHDGJGHB

            HTH
            Srini
            • 3. Re: ORA-01034 , ORA-27101 in windows Domain
              772286
              Thanks for your replies, but I cannot loggin in the DB, what am I doing wrong ?

              Please help. :(
              • 4. Re: ORA-01034 , ORA-27101 in windows Domain
                Srini Chavali-Oracle
                Pl post details of what exactly you are doing and the complete error messages/codes that you are seeing

                HTH
                Srini
                • 5. Re: ORA-01034 , ORA-27101 in windows Domain
                  772286
                  Hi again, My computer belong to a Windows Server Directory ( Windows Domain ) I log in in the computer :

                  <my_name>@aduana.gob.bo.com

                  I installed Oracle 11g express edition 32 bits successful, but when I try to log in in the database it show me the error .


                  SQL*Plus: Release 11.2.0.2.0 Production on Jue Abr 11 16:08:52 2013
                  Copyright (c) 1982, 2010, Oracle. All rights reserved.
                  SQL> conn
                  Enter user-name: system
                  Enter password:
                  ERROR:
                  ORA-01034: ORACLE not available
                  ORA-27101: shared memory realm does not exist
                  Process ID: 0
                  Session ID: 0 Serial number: 0
                  SQL>
                  I see the Services.msc program and the OracleService and Listener are UP AND RUNNING

                  sqlnet.ora  file

                  SQLNET.AUTHENTICATION_SERVICES=(none)


                  tnsnames.ora file
                  XE =
                  (DESCRIPTION =
                  (ADDRESS = (PROTOCOL = TCP)(HOST =Aduana-Pc.aduana.gob.bo)(PORT = 1521))
                  (CONNECT_DATA =
                  (SERVER = DEDICATED)
                  (SERVICE_NAME = XE)
                  )
                  )

                  EXTPROC_CONNECTION_DATA =
                  (DESCRIPTION =
                  (ADDRESS_LIST =
                  (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1))
                  )
                  (CONNECT_DATA =
                  (SID = PLSExtProc)
                  (PRESENTATION = RO)
                  )
                  )

                  ORACLR_CONNECTION_DATA =
                  (DESCRIPTION =
                  (ADDRESS_LIST =
                  (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1))
                  )
                  (CONNECT_DATA =
                  (SID = CLRExtProc)
                  (PRESENTATION = RO)
                  )
                  )






                  listener.ora file

                  SID_LIST_LISTENER =
                  (SID_LIST =
                  (SID_DESC =
                  (SID_NAME = PLSExtProc)
                  (ORACLE_HOME = D:\Orecle_XE_11g\app\oracle\product\11.2.0\server)
                  (PROGRAM = extproc)
                  )
                  (SID_DESC =
                  (SID_NAME = CLRExtProc)
                  (ORACLE_HOME = D:\Orecle_XE_11g\app\oracle\product\11.2.0\server)
                  (PROGRAM = extproc)
                  )
                  )

                  LISTENER =
                  (DESCRIPTION_LIST =
                  (DESCRIPTION =
                  (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1))
                  (ADDRESS = (PROTOCOL = TCP)(HOST = ADUANA-PC.aduana.gob.bo)(PORT = 1521))
                  )
                  )

                  DEFAULT_SERVICE_LISTENER = (XE)


                  and the

                  clsc.log file is showing

                  Oracle Database 11g Clusterware Release 11.2.0.2.0 - Production Copyright 1996, 2010 Oracle. All rights reserved.
                  2013-04-11 16:01:28.248: [ default][4308]ut_read_reg:2:ocr registry key SOFTWARE\Oracle\olr cannot be opened. error 2
                  [    CLSE][4308]clse_get_crs_home: Error retrieving OLR configuration [0] [Error opening olr registry key. El sistema no puede encontrar el archivo especificado.
                  ]


                  I find this links :
                  ORA-12514: TNS:listener does not currently know of service requested
                  "ora-12638 credential retrieval failed"
                  https://cn.forums.oracle.com/forums/thread.jspa?threadID=332525&start=15&tstart=0


                  But they not help me to solve this problem.

                  Thanks in advance. :(
                  • 6. Re: ORA-01034 , ORA-27101 in windows Domain
                    Srini Chavali-Oracle
                    >
                    ERROR:
                    ORA-01034: ORACLE not available
                    ORA-27101: shared memory realm does not exist
                    >

                    This indicates the database is not up - pl see my previous reply above

                    HTH
                    Srini
                    • 7. Re: ORA-01034 , ORA-27101 in windows Domain
                      clcarter
                      ORA-01034: ORACLE not available
                      Database is down. Services have to be running, be sure and double check the OracleServiceXE in the services applet, with a sysdba connection try a startup, in a command box ...
                      sqlplus /nolog
                      conn /as sysdba;
                         ... connected to idle instance ...
                      startup
                        ... memory info ...
                        ... Database mounted.
                        ... Database open.
                      If the database does not startup and say "database open", installer probably did not get to complete all its tasks, if so a deinstall and try another installer run. See the windows uninstall steps at http://docs.oracle.com/cd/E17781_01/install.112/e18803/toc.htm#CIHDDHJD
                      clsc.log file is showing ...
                      Not relevant, that's a cluster ready services piece and not part of an XE install.
                      • 8. Re: ORA-01034 , ORA-27101 in windows Domain
                        772286
                        Thans to everyone. Windows Services reports that OracleServiceXE is Runniinng and the Listener too.

                        when I ran the commans :
                        sqlplus /nolog
                        conn /as sysdba

                        SQL> conn /as sysdba

                        ERROR:
                        ORA-01031: insufficient privileges
                        Help Please.

                        Edited by: Marco on Apr 12, 2013 10:58 AM
                        • 9. Re: ORA-01034 , ORA-27101 in windows Domain
                          clcarter
                          conn /as sysdba ... ERROR: ORA-01031: insufficient privileges
                          The user logged into the host is most likely not in the ORA_DBA group. There are other client settings that can cause this setup problem but lacking group membership is the most common one.

                          Find out who is in the ora_dba group, with a command box:
                          net localgroup ora_dba
                          Alias name     ora_dba  ... Members
                          <domain>\<user1>
                          <user2>
                          NT AUTHORITY\SYSTEM
                          ...
                          Try the start/run/lusrmgr.msc for the local users and groups applet, in Groups, pick ora_dba and the Add button for your user login.

                          Edited by: clcarter on Apr 12, 2013 12:22 PM
                          fix lusrmgr.msc typo
                          • 10. Re: ORA-01034 , ORA-27101 in windows Domain
                            clcarter
                            Oh ....
                            modiffied the : sqlnet.ora file as bellow : SQLNET.AUTHENTICATION_SERVICES=(NONE)
                            That's one of the other causes of the insufficient privs error when using conn /as sysdba. A "connect /" uses OS authentication and the NONE disables it. Can't connect / or conn /as sysdba with that particular setting.

                            Either comment out the sqlnet.auth... entry or try ...=(NTS) if you want to be able do any kind of "connect /" connections, or use connect sys as sysdba; to take the OS authentication out of the equation.

                            Edited by: clcarter on Apr 12, 2013 12:31 PM
                            add sys
                            • 11. Re: ORA-01034 , ORA-27101 in windows Domain
                              772286
                              thanks to everyone for yours replies, but I cannot connect to Oracle DB.


                              C:\Windows\System32>net localgroup ora_dba
                              Nombre de alias ora_dba
                              Comentario Oracle DBA Group

                              Miembros

                              -------------------------------------------------------
                              ADUANA
                              ADUANA\mamolina
                              NT AUTHORITY\SYSTEM
                              Se ha completado el comando correctamente.

                              ------------------------------
                              I m using
                              SQLNET.AUTHENTICATION_SERVICES=(NTS)
                              This is my users
                              C:\Windows\System32>net localgroup ora_dba
                              Nombre de alias ora_dba
                              Comentario Oracle DBA Group

                              Miembros

                              ------------------------------------------------------
                              ADUANA
                              ADUANA\mamolina
                              NT AUTHORITY\SYSTEM
                              Se ha completado el comando correctamente.
                              when I use the command : lsnrctl status ; I Get :
                              LSNRCTL for 32-bit Windows: Version 11.2.0.2.0 - Production on 18-ABR-2013 12:26:26

                              Copyright (c) 1991, 2010, Oracle. All rights reserved.

                              Welcome to LSNRCTL, type "help" for information.

                              LSNRCTL> status
                              Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=IPC)(KEY=EXTPROC1)))
                              STATUS of the LISTENER
                              ------------------------
                              Alias LISTENER
                              Version TNSLSNR for 32-bit Windows: Version 11.2.0.2.0 - Production
                              Start Date 18-ABR-2013 12:21:36
                              Uptime 0 days 0 hr. 4 min. 54 sec
                              Trace Level off
                              Security ON: Local OS Authentication
                              SNMP OFF
                              Default Service XE
                              Listener Parameter File D:\Orecle_XE_11g\app\oracle\product\11.2.0\server\network\admin\listener.ora
                              Listener Log File D:\Orecle_XE_11g\app\oracle\diag\tnslsnr\ADUANA-PC\listener\alert\log.xml
                              Listening Endpoints Summary...
                              (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(PIPENAME=\\.\pipe\EXTPROC1ipc)))
                              (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=ADUANA-PC.aduana.gob.bo)(PORT=1521)))
                              Services Summary...
                              Service "CLRExtProc" has 1 instance(s).
                              Instance "CLRExtProc", status UNKNOWN, has 1 handler(s) for this service...
                              Service "PLSExtProc" has 1 instance(s).
                              Instance "PLSExtProc", status UNKNOWN, has 1 handler(s) for this service...
                              The command completed successfully
                              As you see, the listener and the Service are running succesful,

                              Dou you think security param is the root problem ?
                              Security ON: Local OS Authentication
                              Thanks very much.
                              • 12. Re: ORA-01034 , ORA-27101 in windows Domain
                                clcarter
                                security param is the root problem ?
                                Don't think so, that's a listener setting. I've got the SQLNET.AUTHENTICATION_SERVICES = (NTS) and lsnrctl status shows the same exact Security line.
                                the listener and the Service are running succesful,
                                Well, not exactly. The listener is running but the database has not registered with the listener, should have a "Service" line similar to:
                                Service "xe" has 1 instance(s).
                                And should also have another one, 'Service "XEXDB" has 1 instance(s).' as well for Apex, but that only means the web pages at http...:8080/apex won't work. Most likely something not exactly correct with the client network setup, but first things first, lets get past the sqlplus can't connect trouble.

                                Verify that you're logged into the host with the right user, at the cmd box ...
                                echo %username%
                                ... mamolina ?
                                echo %userdomain%
                                ...  ADUANA ? 
                                And take a look in the folder ...diag/rdbms/xe/xe/trace/alert_xe.log and go to the very bottom, there should not be a line similar to:
                                Instance shutdown complete
                                at the end of the file.
                                • 13. Re: ORA-01034 , ORA-27101 in windows Domain
                                  772286
                                  Thanks to everyone for your replies, I solved this problem of the following way :
                                  1 Uninstall Oracle XE
                                  2 Log In as NOT A USER DOMAIN in the windows PC.
                                  3 Install Oracle XE again
                                  4 Verify the Installation , and it Run OK !!!
                                  5 Log In as A USER DOMAIN in the windows PC.
                                  6 verify the Oracle XE DB, and it , Runnig and all is Ok !!! :D
                                  7 Now everytime log as a USER DOMAIN in the windows PC and load the ServiceXE and the Listener normally.
                                  Thanks to everyone again. :D