This discussion is archived
5 Replies Latest reply: Mar 21, 2013 10:35 AM by 950615 RSS

Create Weblogic Domain for Identity Management

user12106734 Newbie
Currently Being Moderated
I have wl 10.3.6 and am using Identity Management 11.1.1.6 on RHELS 6. I am following this guide located here-
http://www.oratraining.com/blog/2012/12/configure-oracle-identity-and-access-management-components/
I successfully completed this step- Create Weblogic Domain for Identity Management.
After completing the next step (this one)- Prepare Admin server for startup without prompting password
My Weblogic Server will not start.
After a quick Google search I was informed to delete the ldap directory in my admin server. That did not work.
Here is the error I’m receiving.

####<Mar 20, 2013 3:37:07 PM MDT> <Info> <messaging.interception> <GILL> <AdminServer> <[STANDBY] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1363815427564> <BEA-400000> <Initializing message interception service>
####<Mar 20, 2013 3:37:07 PM MDT> <Critical> <WebLogicServer> <GILL> <AdminServer> <main> <<WLS Kernel>> <> <> <1363815427586> <BEA-000386> <Server subsystem failed. Reason: java.lang.NullPointerException
java.lang.NullPointerException
at weblogic.management.internal.PendingDirectoryManager.find(PendingDirectoryManager.java:571)
at weblogic.management.internal.PendingDirectoryManager.find(PendingDirectoryManager.java:556)
at weblogic.management.internal.PendingDirectoryManager.getAllFiles(PendingDirectoryManager.java:413)
at weblogic.management.provider.internal.EditAccessImpl.<init>(EditAccessImpl.java:165)
at weblogic.management.provider.internal.EditAccessImpl.initialize(EditAccessImpl.java:218)
at weblogic.management.provider.internal.EditAccessService.start(EditAccessService.java:24)
at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:256)
at weblogic.work.ExecuteThread.run(ExecuteThread.java:221)
>
####<Mar 20, 2013 3:37:07 PM MDT> <Notice> <WebLogicServer> <GILL> <AdminServer> <main> <<WLS Kernel>> <> <> <1363815427607> <BEA-000365> <Server state changed to FAILED>

Any help would be much appreciated.
Thanks in advance.
  • 1. Re: Create Weblogic Domain for Identity Management
    950615 Newbie
    Currently Being Moderated
    Hi,

    Try this:

    move the folder data to bakup and restart the server
    <domain>/servers/<server name>/data to
    <domain>/servers/<server name>/data.bkp

    While starting the server don't start the server as a background process, provide the username and password for the first time. It must help you to start the server.

    After the server is started create a boot.properties under <domain_home>/servers/<Admin Server>/security/.

    If security folder is not there create it manually.

    In the boot.properties just add the below info:

    username=<username of the Adminserver>
    password=<password>

    save it and restart the server, the server is will start without prompting the username and password.

    Humble Regards,
    Sandeep N.
  • 3. Re: Create Weblogic Domain for Identity Management
    user12106734 Newbie
    Currently Being Moderated
    I have done what you have requested, and I am now receiving the following errror.


    <Mar 21, 2013 9:01:23 AM MDT> <Critical> <Security> <BEA-090402> <Authentication denied: Boot identity not valid; The user name and/or password from the boot identity file (boot.properties) is not valid. The boot identity may have been changed since the boot identity file was created. Please edit and update the boot identity file with the proper values of username and password. The first time the updated boot identity file is used to start the server, these new values are encrypted.>
    <Mar 21, 2013 9:01:23 AM MDT> <Critical> <WebLogicServer> <BEA-000386> <Server subsystem failed. Reason: weblogic.security.SecurityInitializationException: Authentication denied: Boot identity not valid; The user name and/or password from the boot identity file (boot.properties) is not valid. The boot identity may have been changed since the boot identity file was created. Please edit and update the boot identity file with the proper values of username and password. The first time the updated boot identity file is used to start the server, these new values are encrypted.
    weblogic.security.SecurityInitializationException: Authentication denied: Boot identity not valid; The user name and/or password from the boot identity file (boot.properties) is not valid. The boot identity may have been changed since the boot identity file was created. Please edit and update the boot identity file with the proper values of username and password. The first time the updated boot identity file is used to start the server, these new values are encrypted.
    at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.doBootAuthorization(CommonSecurityServiceManagerDelegateImpl.java:960)
    at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.initialize(CommonSecurityServiceManagerDelegateImpl.java:1054)
    at weblogic.security.service.SecurityServiceManager.initialize(SecurityServiceManager.java:873)
    at weblogic.security.SecurityService.start(SecurityService.java:141)
    at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
    Truncated. see log file for complete stacktrace
    Caused By: javax.security.auth.login.FailedLoginException: [Security:090304]Authentication Failed: User weblogic javax.security.auth.login.FailedLoginException: [Security:090302]Authentication Failed: User weblogic denied
    at weblogic.security.providers.authentication.LDAPAtnLoginModuleImpl.login(LDAPAtnLoginModuleImpl.java:261)
    at com.bea.common.security.internal.service.LoginModuleWrapper$1.run(LoginModuleWrapper.java:110)
    at java.security.AccessController.doPrivileged(Native Method)
    at com.bea.common.security.internal.service.LoginModuleWrapper.login(LoginModuleWrapper.java:106)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    Truncated. see log file for complete stacktrace


    Everything is correct in the boot.properties file. Any suggestions?
    Thanks in advance.
  • 4. Re: Create Weblogic Domain for Identity Management
    user12106734 Newbie
    Currently Being Moderated
    I went back and just deleted the boot.properties file and was prompted for username and pw. I entered them and am receiving the same error as before.

    <Mar 21, 2013 9:25:21 AM MDT> <Info> <Security> <BEA-090065> <Getting boot identity from user.>
    Enter username to boot WebLogic server:weblogic
    Enter password to boot WebLogic server:
    <Mar 21, 2013 9:25:32 AM MDT> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to STARTING>
    <Mar 21, 2013 9:25:32 AM MDT> <Info> <WorkManager> <BEA-002900> <Initializing self-tuning thread pool>
    <Mar 21, 2013 9:25:33 AM MDT> <Notice> <Log Management> <BEA-170019> <The server log file /u01/app/oracle/middleware/10.3.6/IDMDomain/aserver/IDM_domain/servers/AdminServer/logs/AdminServer.log is opened. All server side log events will be written to this file.>
    <Mar 21, 2013 9:25:44 AM MDT> <Notice> <Security> <BEA-090082> <Security initializing using security realm myrealm.>
    <Mar 21, 2013 9:25:44 AM MDT> <Critical> <WebLogicServer> <BEA-000386> <Server subsystem failed. Reason: java.lang.NullPointerException
    java.lang.NullPointerException
    at weblogic.management.internal.PendingDirectoryManager.find(PendingDirectoryManager.java:571)
    at weblogic.management.internal.PendingDirectoryManager.find(PendingDirectoryManager.java:556)
    at weblogic.management.internal.PendingDirectoryManager.getAllFiles(PendingDirectoryManager.java:413)
    at weblogic.management.provider.internal.EditAccessImpl.<init>(EditAccessImpl.java:165)
    at weblogic.management.provider.internal.EditAccessImpl.initialize(EditAccessImpl.java:218)
    Truncated. see log file for complete stacktrace


    Thanks
  • 5. Re: Create Weblogic Domain for Identity Management
    950615 Newbie
    Currently Being Moderated
    Great....

    Try Deleting the servers folder which located under <domain_home>

    If it is also not working I beleive u must recreate a domain.

    Before that check that is there any boot.properties file in <domain_home> directory or <domain_home>/security/.


    Humble Regards,
    Sandeep N.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points