2 Replies Latest reply: May 27, 2013 8:48 AM by 987288 RSS

    Register Rule when attached to rate which is attached to SUB  SA

    987288
      A Register Rule to delete entry from read details in bill segments after checking some condition(say UOM_CD is 'KWH') is required.
      when this register rule attached to rate which is attached to master SA. it works fine.
      But when attached to SUB SA it fires but result is not reflected on screen.I don't know why it doesn't commit as I can see my algorithm firing in debug mode successfuuly.
      Help needed on How register rule behave differently on SUB SAs than Master SAs
        • 1. Re: Register Rule when attached to rate which is attached to SUB  SA
          992942
          984285 wrote:
          A Register Rule to delete entry from read details in bill segments after checking some condition(say UOM_CD is 'KWH') is required.
          when this register rule attached to rate which is attached to master SA. it works fine.
          But when attached to SUB SA it fires but result is not reflected on screen.I don't know why it doesn't commit as I can see my algorithm firing in debug mode successfuuly.
          Help needed on How register rule behave differently on SUB SAs than Master SAs
          Hi,


          As far as I understand you should have the Register Rule on the Master SA for it to have effect on the Sub-SA, while SQ Rule on the master SA will have no impact. Each sub-SA can have their own SQ rule.

          Hope this answers you query.

          Regards
          • 2. Re: Register Rule when attached to rate which is attached to SUB  SA
            987288
            Rule is working fine. there were some other dependencies which were causing the roll backs. We can attach a rule in sub SA and it works perfect as in Master SA.
            Thanks