1 Reply Latest reply: Apr 1, 2013 4:40 AM by 997468 RSS

    While integrating Weblogic server with Iplanet webserver

    962104
      Hi ,

      I am facing issues while connecting weblogic application server with Iplanet webserver:

      while i hit the desired url, it showing the below log, it is not providing me proper page (weblogic console page )

      Sat Mar 23 06:12:37 2013 <1535513639993579> URL::parseHeaders: CompleteStatusLine set to [HTTP/1.1 302 Moved Temporarily]
      Sat Mar 23 06:12:37 2013 <1535513639993579> URL::parseHeaders: StatusLine set to [302 Moved Temporarily]
      Sat Mar 23 06:12:37 2013 <1535513639993579> Hdrs from WLS:[Date]=[Sat, 23 Mar 2013 00:42:37 GMT]
      Sat Mar 23 06:12:37 2013 <1535513639993579> Hdrs from WLS:[Transfer-Encoding]=[chunked]
      Sat Mar 23 06:12:37 2013 <1535513639993579> Hdrs from WLS:[Location]=[http://10.11.12.231/console/login/LoginForm.jsp]
      Sat Mar 23 06:12:37 2013 <1535513639993579> Hdrs from WLS:[X-WebLogic-JVMID]=[-420809910]
      Sat Mar 23 06:12:37 2013 <1535513639993579> Hdrs from WLS:[X-Powered-By]=[Servlet/2.5 JSP/2.1]
      Sat Mar 23 06:12:37 2013 <1535513639993579> parsed all headers OK
      Sat Mar 23 06:12:37 2013 <1535513639993579> sendResponse() : uref_p->getStatus() = '302'
      Sat Mar 23 06:12:37 2013 <1535513639993579> Hdrs to client (add):[date]=[Sat, 23 Mar 2013 00:42:37 GMT]
      Sat Mar 23 06:12:37 2013 <1535513639993579> Hdrs to client (add):[Location]=[http://10.11.12.231/console/login/LoginForm.jsp]
      Sat Mar 23 06:12:37 2013 <1535513639993579> Hdrs to client (add):[X-Powered-By]=[Servlet/2.5 JSP/2.1]
      Sat Mar 23 06:12:37 2013 <1535513639993579> canRecycle: conn=1 status=302 isKA=1 clen=-1 isCTE=1
      Sat Mar 23 06:12:37 2013 <1535513639993579> closeConn: pooling for '10.11.12.231/7001'
      Sat Mar 23 06:12:37 2013 <1535513639993579> request [console/] processed successfully..................


      Please help me.

      Thanks,
      Chinna
        • 1. Re: While integrating Weblogic server with Iplanet webserver
          997468
          Hi,

          First thing are you seeing any request coming to weblogic server? if not then,
          What configuration you have added in server.xml and virtual server instance object conf file for weblogic integration.
          It is pretty straight forward,

          1. add weblogic plugin libproxy_61.so in plugin/weblogic directory on webserver.
          2. add WLS cluster server/ standalone server information in server.xml
          3. in object file create a new object of type="magnus-internal/directory" add WL specific configuration and then add condition to select WLS object created or make it default object for handling all request.

          Thanks,
          Ranjan