4 Replies Latest reply: Mar 28, 2013 7:18 AM by Gaétan Berthold RSS

    INIFiles option sometimes ignored by IDS

    Gaétan Berthold
      Hi,

      On the same IDS installation, I process RPD and PRT requests types. For RPD requests, the ini setting < INIFiles > is being read by IDS / Gendata, but it is ignored when processing a PRT-type request. Here's my setup:

      This request works
      ReqType:RPD
      DAP.INI
      [ Configurations ]
           Config          = DGAG_SYST_C100_BordereauNum

      DGAG_SYST_C100_BordereauNum.INI
      < RPDRunRP >
           UserINI          = \\Ntdonl5\DocumakerDataDiv\Syst\Impr_332\IDS_FSIUSER.INI

      IDS_FSIUSER.INI
      Contains all the INI groups and options, except those listed below under DATABASE_IDS.INI
      < INIFiles >
           File          = \\ntdonl5\DocumakerDataDiv\Syst\DATABASE_IDS.INI

      DATABASE_IDS.INI
      Contains only the database connexions groups and options.
      ;*******************************************************************************
      < DBHandler:MRL_Divers >
           AlwaysSQLPrepare     = Yes
           Class          = ODBC
           Connect          = Yes
           CreateIndex     = No
           CreateTable     = No
           Debug          = No
           Description          = Librairie Divers
           InstallFunc          = SQInstallHandler
           InstallMod          = SQOS2
           PassWd          = ~ENCRYPTED 0-kIjgAleeAoZlZ88QWqI10SD
           Server          = DMKR_DEV_LIBR
           UserID          = DEV_LIBR_DIV
      < DBTable:MRL_Divers >
           DBHandler          = MRL_Divers
      < DBTable:MRL_DiversC >
           DBHandler          = MRL_Divers
           UniqueTag          = CATALOGID
      < DBTable:MRL_DiversD >
           DBHandler          = MRL_Divers
           DFD          = \\ntdonl5\DocumakerDataah\Syst\DEFLib\carfileora.dfd
           UniqueTag          = ARCKEY+SEQ_NUM
      < DBTable:MRL_DiversL >
           DBHandler          = MRL_Divers
           UniqueTag          = DATE+TIME
      < Library:MRL_Divers >
           Catalog          = MRL_DiversC
           DBTable          = MRL_DiversD
           Description          = Librairie MRL_Divers Intégration Oracle
           LBYLogFile          = MRL_DiversL
      < ODBC_FileConvert >
      ;     Personnaliser selon les environnements.
      ;     Nom pour Documaker     = Nom dans Oracle DBMS
           MRL_Divers          = SYST_INDEX
           MRL_DiversC     = SYST_CATALOG
           MRL_DiversD     = SYST_DATA
           MRL_DiversL     = SYST_LOG
      < LibraryManager >
           Library          = MRL_Divers
      ;*******************************************************************************

      *This request fails
      ReqType:PRT
      DAP.INI*
      [ Configurations ]
           Config          = DGAG_SYST_C100

      DGAG_SYST_C100.INI
      This setting is ignored by IDS
      < INIFiles >
           File          = \\ntdonl5\DocumakerDataDiv\Syst\DATABASE_IDS.INI

      If any of these groups, and their options, is moved from DGAG_SYST_C100 to DATABASE_IDS.INI, IDS will fail with database access errors.
      < DBHandler:MRL_Divers >
      < DBTable:MRL_Divers >
      < DBTable:MRL_DiversC >
      < DBTable:MRL_DiversD >
      < DBTable:MRL_DiversL >
      < Library:MRL_Divers >
      < ODBC_FileConvert >
      < LibraryManager >

      I have tried to insert the group < INIFiles > in the DAP.INI file and in the Docserv.xml file, in the section

      <section name="INIFiles">
      <entry name="File">[ INIFiles:~Platform ] File =</entry>
      <entry name="File">ccm_requests.ini</entry>
      <entry name="File">\\ntdonl5\DocumakerDataDiv\Syst\DATABASE_IDS.INI</entry>
      <!-- -->
      </section>

      No luck, it is ignored by the PRT request.

      Any suggestions?

      Thanks

      Gaétan