This discussion is archived
1 Reply Latest reply: Mar 27, 2013 6:29 AM by cdelahun RSS

How can I turn off toplink logs?

raymondctc Newbie
Currently Being Moderated
Hi,

I am using OC4J 10.3.5.0. May I know how can I turn off toplink's logs? As it is currently generating something like this in stdout:

DatabaseSession(219604438)--Connection(1514883920)--TopLink, version: OracleAS TopLink - 10g (9.0.4.5) (Build 040930)
DatabaseSession(219604438)--Connection(1514883920)--connecting session: Not named
DatabaseSession(219604438)--Connection(1514883920)--connecting(DatabaseLogin(
     platform=>Oracle9Platform
     user name=> "ABC"
     datasource URL=> "jdbc:oracle:thin:@XXXXX:1521:XXXX"
))

DatabaseSession(1395221594)--acquire unit of work: 2097725879
DatabaseSession(1395221594)--Connection(1115388765)--SELECT t0.ID, t1.USER_ID, t0.ADDRESS, FROM ABC
....

Thanks!

Edited by: raymondctc on Mar 25, 2013 9:24 PM

Edited by: raymondctc on Mar 25, 2013 9:25 PM

Edited by: raymondctc on Mar 25, 2013 9:27 PM
  • 1. Re: How can I turn off toplink logs?
    cdelahun Pro
    Currently Being Moderated
    You had to have turned logging on somehow, so it depends on how you turned it on.
    If you are using native TopLink api such as Sessions.xml check the documents here: http://docs.oracle.com/cd/E21764_01/web.1111/b32441/sescfg.htm#BABFDFFD
    if Using JPA, its done in persistence.xml through properties as described here: http://www.oracle.com/technetwork/middleware/ias/configure-logging-092723.html

    Best Regards
    Chris

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points