9 Replies Latest reply: Mar 27, 2013 12:18 PM by user6445925 RSS

    R12.1.3 db upgrade from 11107 to 11203

    user6445925
      In kind of a rush so I'll just say up front I haven't researched this question.
      R12.1.3 on RH Linux with 1107 db.
      I previously installed 11.2.0 and patched that $OH with pacthes per [ID 1058763.1].
      I then ran dbua and upgraded the db.
      And lastly applied Jan 2013 PSU.

      Now due to some other issues I am now redoing the upgrade prcoess starting with a clone from Prod and then dbua cycle and post steps again.
      Question is when I go to do the PSU again will I need to rollback first? I mean will the 11203 home's lsinventory see it was applied?
        • 1. Re: R12.1.3 db upgrade from 11107 to 11203
          Srini Chavali-Oracle
          Yes you should be able to see that the PSU was applied to the OH using the lsinventory command. All you will need to do after the database upgrade is to run the necessary post-install scripts in the PSU README file

          Do Patchset Updates (PSU's) Change the Oracle Release Version/Fifth Digit? [ID 861152.1]

          HTH
          Srini
          • 2. Re: R12.1.3 db upgrade from 11107 to 11203
            Hussein Sawwan-Oracle
            Question is when I go to do the PSU again will I need to rollback first? I mean will the 11203 home's lsinventory see it was applied?
            Yes it will see it was applied.

            If the inventory was renamed/recreated, then it will not see the patches as applied.

            Thanks,
            Hussein
            • 3. Re: R12.1.3 db upgrade from 11107 to 11203
              user6445925
              I did make the mistake of using the 11.1.0 Inventory location last time but I don't plan on changing it this time around (just test).
              • 4. Re: R12.1.3 db upgrade from 11107 to 11203
                Hussein Sawwan-Oracle
                user6445925 wrote:
                I did make the mistake of using the 11.1.0 Inventory location last time but I don't plan on changing it this time around (just test).
                This should not matter.

                Thanks,
                Hussein
                • 5. Re: R12.1.3 db upgrade from 11107 to 11203
                  user6445925
                  Well for whatever reason (me I guess) my Inventory location is not valid so I can't run opatch.

                  List of Homes on this system:

                  Inventory load failed... OPatch cannot load inventory for the given Oracle Home.
                  Possible causes are:
                  Oracle Home dir. path does not exist in Central Inventory
                  Oracle Home is a symbolic link
                  Oracle Home inventory is corrupted
                  LsInventorySession failed: OracleHomeInventory gets null oracleHomeInfo

                  OPatch failed with error code 73

                  I've tried pointing my /etc/oraInst.loc file to my 11.1.0 and my 11.2.0 homes and tried the "$ORACLE_HOME/oui/bin/attachHome.sh" or
                  "opatch lsinventory -invPtrLoc" but no success with either.
                  Really I'm just guessing at how to fix it though.

                  I've used the attachHome script successfully before on this server where I have multiple instances and update /etc/oraInst.loc as required.
                  • 6. Re: R12.1.3 db upgrade from 11107 to 11203
                    Hussein Sawwan-Oracle
                    user6445925 wrote:
                    Well for whatever reason (me I guess) my Inventory location is not valid so I can't run opatch.

                    List of Homes on this system:

                    Inventory load failed... OPatch cannot load inventory for the given Oracle Home.
                    Possible causes are:
                    Oracle Home dir. path does not exist in Central Inventory
                    Oracle Home is a symbolic link
                    Oracle Home inventory is corrupted
                    LsInventorySession failed: OracleHomeInventory gets null oracleHomeInfo

                    OPatch failed with error code 73

                    I've tried pointing my /etc/oraInst.loc file to my 11.1.0 and my 11.2.0 homes and tried the "$ORACLE_HOME/oui/bin/attachHome.sh" or
                    "opatch lsinventory -invPtrLoc" but no success with either.
                    Really I'm just guessing at how to fix it though.

                    I've used the attachHome script successfully before on this server where I have multiple instances and update /etc/oraInst.loc as required.
                    Please see these docs.

                    OPatch Fails With "LsInventorySession failed: OracleHomeInventory gets null oracleHomeInfo" [ID 728417.1]
                    Error Applying Patch to ECM 11g: Inventory Load Failed, OPatch Cannot Load Inventory for the Given Oracle Home. [ID 1265361.1]
                    OPatch Errors with "OPatch failed with error code = 73" [ID 1091946.1]
                    Steps To Recreate Central Inventory(oraInventory) In RDBMS Homes [ID 556834.1]
                    How To Create, Update or Rebuild The Central Inventory For Oracle Applications EBS R12 [ID 742477.1]

                    Thanks,
                    Hussein
                    • 7. Re: R12.1.3 db upgrade from 11107 to 11203
                      user6445925
                      Thanks for the reply Hussein.
                      I meant to update it right away but OTN was down for a bit there. I was able to fix it by doing the attach after all. If I looked at it closely it was failing on swap space check so I had to add the -ignoreSysPrereqs option to get around it.

                      Now opatch lsinventory works and I see my patches including Patch 14727310 "Database Patch Set Update : 11.2.0.3.5 (14727310)".
                      So based on that I should now just have to run the "@catbundle.sql psu apply" step against the DB as Srini replied initially?
                      • 8. Re: R12.1.3 db upgrade from 11107 to 11203
                        Hussein Sawwan-Oracle
                        user6445925 wrote:
                        Thanks for the reply Hussein.
                        I meant to update it right away but OTN was down for a bit there. I was able to fix it by doing the attach after all. If I looked at it closely it was failing on swap space check so I had to add the -ignoreSysPrereqs option to get around it.

                        Now opatch lsinventory works and I see my patches including Patch 14727310 "Database Patch Set Update : 11.2.0.3.5 (14727310)".
                        So based on that I should now just have to run the "@catbundle.sql psu apply" step against the DB as Srini replied initially?
                        Yes.

                        Thanks,
                        Hussein
                        • 9. Re: R12.1.3 db upgrade from 11107 to 11203
                          user6445925
                          ok all good. Thanks.