9 Replies Latest reply: Apr 2, 2013 2:56 AM by Vikz28 RSS

    Issue with Dataguard configuration

    sandy121
      DB - Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - 64bit
      My laptop has 8 g and processor is i3. I developed 3 nodes in VMWARE workstation 7.1 and configured data guard in it (3 rd node being the observer and 2 gb is allocated to each node).
      Now the issue is whenever the 3 nodes are running simultaneously, the nodes goes in hang state along with host operating system. Right now I don't have the option to upgrade my system, so any idea how to fix this? Any advice will be highly appreciated. Thanks in advance.
        • 1. Re: Issue with Dataguard configuration
          Mohamed ELAzab
          Hello,

          I have some questions:
          1-Is that a production or testing server?.
          2-If it is a production why you developed it on a laptop?.
          3-How many memeory you assigned to each node and to the observer?.
          BR
          Mohamed ELAzab
          http://mohamedelazab.blogspot.com
          • 2. Re: Issue with Dataguard configuration
            mseberg
            Hello;

            If you don't have the resources and have no option to increase them then you have to drop something. I would shutdown the "observer".

            The other option is to cut the "observer" resources. It needs very little, 2GB is a lot for that.

            Also, what OS are you running on the laptop and within the VM's ?

            You can run Oracle 11 on VMware with as little as 1GB of RAM.

            The observer can be completely stripped down, it does very little work.

            I can run 3 Oracle 11.2.0.3 databases on Red Hat 5 in vmware using Windows 7 as a host. I use 1 CPU ( core ) each for the VM's and 1.2 GB memory. No issues. Cut your memory and you won't waste CPU on swap you don't need.

            Best Regards

            mseberg

            Edited by: mseberg on Mar 27, 2013 7:37 AM
            • 3. Re: Issue with Dataguard configuration
              sandy121
              1) It will be used for testing purpose to know Dataguard technologies in depth.
              2) Not Applicable.
              3)I have assigned 2 gb to each node and automatic memory management is enabled(memory_target = 1Gb each db)
              • 4. Re: Issue with Dataguard configuration
                Mohamed ELAzab
                Hello ,

                Since this is for education purpose i would recommend you to do the following:
                1-Check the available memory left on the latop and try to close any unseeded applications. This should save for you 2 gigas additional and say 2 giga for the OS.
                2-If this didn't work then please reduce the database memory assigned for the SGA to 1.5 or 2 giga although oracle recommends that the memory to be 2 giga at least but since it is for education then lets try that.
                I think if you do this it would be ok however i still think 8 giga RAM would be enought to assign 2 giga memory for each database and run ok.I have installed oracle RAC on a laptop similar to that one before and everything was going ok.
                Check the memory on windows:
                Please user ALT+CTRL+DELETE to see where your OS memory is consumed on windows machine.
                BR
                Mohamed ELAzab
                http://mohamedelazab.blogspot.com
                • 5. Re: Issue with Dataguard configuration
                  sandy121
                  I have Oracle Enterprise Linux 5 installed in each node of VMWARE, i reduced the observer dedicated ram to 1 GB but nothing much improves, so still looking badly for all of your inputs and comments.Thanks everyone.
                  • 6. Re: Issue with Dataguard configuration
                    sandy121
                    The problem is still continuing even after implementing all the ideas.
                    • 7. Re: Issue with Dataguard configuration
                      sandy121
                      Freinds, I am still waiting for some tips/advices to overcome this problem. Your suggestions and ideas will be highly appreciated as always.
                      • 8. Re: Issue with Dataguard configuration
                        Seberg
                        What comes to mind is the movie Jaws. The one from 1975. At one point they do a quick summary. I believe the line is something like:

                        "We're going to need a bigger boat"
                        • 9. Re: Issue with Dataguard configuration
                          Vikz28
                          Hi,

                          You can try to disable the 3rd node (observer) & configure dataguard on two nodes. Because your primary objective is to understand the indepth technology of dataguard which can also be achieved by working on 2 node setup.