3 Replies Latest reply on Mar 28, 2013 2:32 PM by 999564

    Cannot Establish New Connection

    999564
      Hello all, I have quite a peculiar problem regarding the what I've come to find fairly common error, "Network Adapter could not establish the connection."

      Now, before you close the tab/page/browser, hear me out -- I've looked through at least two dozen threads with this topic, but none share the same situation I have, and none have supplied any help whatsoever.

      I'm a college student in a databasing class of 12 other students, where the instructor created a sql developer setup batch file and package, so that all copies of SQL Developer would be absolutely identical. As well, all machines within this classroom are absolutely identical as well, being imaged school harddrives in identical hardware computers. Within the classroom environment, we use database connections on localhost for the purpose of training. The instructor wrote the batch file to set the listener and start the service. Somehow, I receive the above error while no other person within the room has a problem.

      I have verified that the listener is set to listen on localhost and port 1521, and that I am connecting to localhost and port 1521.
      - I have attempted changing the listening port.
      - I have attempted changing the listening IP to 127.0.01, this machine's network IP, this machine's internet IP, this machine's name, and this machine's qualified domain name.

      I have verified that the listener service is operating.
      - I have attempted stopping and starting the service.
      - I have attempted changing the service to manual startup, rebooting the computer, and restarting manually.

      I have verified that the network adapter is operational.
      - Used Ipconfig /release and /renew
      - Can ping self, as well as all other computers in room.
      - Can ping the default gateway
      - Can tracert the default gateway
      - Have DNS connectivity

      I also attempted a fresh copy downloaded from oracle on my personal laptop, and manually used the same settings as the instructor prescribed. I received the same error, where I attempted all items in the above list to no avail. I then moved to another machine in the room, which also did nothing, and finally I moved to a machine that another student had already used, which worked fine.

      Working at my own workstation now, I finally attempted simply running as administrator, which attained the same error, and I rolled back my version of Java, which still received the same error.

      At this point, I have exhausted everything I know to do, and am quickly becoming frustrated. Neither my workstation nor another unused computer within the room work. My personal laptop not connecting doesn't bother me. If anyone at all has any advice whatsoever, I'm all ears. I'd even make sure it's plugged in at this point.
        • 1. Re: Cannot Establish New Connection
          thatJeffSmith-Oracle
          It looks like you've done your homework - pardon the pun.

          I was going to suggest changing the listener off of localhost, but you already tried that.

          Can you try the bequeath option to connect in SQL Developer - it bypasses the listener for local connections. If that works, awesome, but also interested in figuring out what's 'wrong' with your setup.
          1 person found this helpful
          • 2. Re: Cannot Establish New Connection
            Gary Graham-Oracle
            Hi,

            Windows XP is now 3 generations back, so this memory is growing dim, but if that is the OS version used in your class, then the problem could be related to lack of a loopback adapter. Here are a couple of (older) links that mention it:

            Oracle Forum ->Oracle Database -> Installation (points to page 2 of 3):
            SQL Developer: "network adapter could not establish the connection"

            Other Forum -> DBA Forum
            http://dbaforums.org/oracle/index.php?showtopic=19831

            There is mention made that the loopback adapter should be installed prior to database installation.

            Hope this helps,
            Gary
            1 person found this helpful
            • 3. Re: Cannot Establish New Connection
              999564
              Thank you both for your answers. I marked both as helpful. The bequeath option for local connection changed the error to something about the service, but upon reboot and re-initialization, the error returned to network adapter. After reading about XP SP3, I checked the compatibility mode considering the idea of improper setting. I changed the program to XP SP3, then changed it back, but did not resolve the issue. I was able to use the instructor's batch file to successfully install on my home server and use it as an external server with no problem whatsoever. I set the server's listener to port 25560 and connected to the internet IP from the same computer that can't connect to localhost without any trouble whatsoever. Weird. I think it's just a general glitch at this point.