3 Replies Latest reply: Mar 28, 2013 8:54 AM by Jon Finke RSS

    ORA-28817 when attempting to manage instance settings in 4.2

    Jon Finke
      As with some others reporting, I got the dreaded ORA-28817 when attempting to manage the instance settings.

      I upgraded from 4.1 to 4.2 a few months back. After reading some of the comments here, I tried applying the Patch Release 4.2.1.00.08 which claims to fix it - but alas - no joy - still can't manage the instance settings.

      I can also get the error via the command line:
      exec apex_instance_admin.set_parameter('WALLET_PWD',Null);
      BEGIN apex_instance_admin.set_parameter('WALLET_PWD',Null); END;
       
      *
      ERROR at line 1:
      ORA-28817: PL/SQL function returned an error.
      ORA-06512: at "SYS.DBMS_CRYPTO_FFI", line 67
      ORA-06512: at "SYS.DBMS_CRYPTO", line 44
      ORA-06512: at "APEX_040200.WWV_FLOW_CRYPTO", line 89
      ORA-06512: at "APEX_040200.WWV_FLOW_SECURITY", line 1931
      ORA-06512: at "APEX_040200.WWV_FLOW_INSTANCE_ADMIN", line 197
      ORA-06512: at line 1
      I am not sure what else to try....

      Version Info: Application Express 4.2.1.00.08

      Oracle Database 11g Enterprise Edition Release 11.2.0.3.0 - 64bit Production
      PL/SQL Release 11.2.0.3.0 - Production
      CORE     11.2.0.3.0     Production
      TNS for Linux: Version 11.2.0.3.0 - Production
      NLSRTL Version 11.2.0.3.0 - Production

      (Note - I had started this as a reply to a similar thread)