0 Replies Latest reply: Mar 28, 2013 8:34 AM by 999737 RSS

    SAML settings

    999737
      Dear all,

      I set up Weblogic in order to use SAML authentication in my app and it works fine. After that I was notified for additional attributes to be get. So, For extracting additional attributes received in the SAML Assertion, a custom attribute mapper needs to be implemented in the Identity Asserter configuration. I did that by setting provider-specific information (through my mapper class) for this SAML 2.0 Identity Assertion provider. This works ok locally, but when I apply this change in my app server in preproduction environment I got:

      An error occurred during activation of changes, please see the log for details.
      [Management:141191]The prepare phase of the configuration update failed with an exception:
      SAMLBeanUpdateListener SAML2IdentityAsserter: prepareUpdate() failed with exception: [Security:096628]The value configured for NameMapper attribute: com.pp.sp.util.MYSAMLAttributeMapper is not valid.

      I was looking for information in order to fix this but I could not find anything. The weird thing here is that SAML is working in both my local environment and preproduction environment, when I tried to set provider-specific locally it works but in preproduction environment it does not. The only different I found is: my local environment is running under windows and the preproduction environment is running under linux suse.

      Any ideas?

      Thanks in advance,

      Luis.